Вход | Регистрация


Формирование спискаВыбора

Формирование спискаВыбора
Я
   iznvi
 
09.10.18 - 12:30
Ребят,проблема в том что формирую в реквизите формы СписокВыбора из всех подсистем которые есть в базе Делаю это все приОткрытии


&НаСервере
Функция ПолучитьСписокПодсистем()
    СписокПодсистем = Новый СписокЗначений;
    Для Каждого ТекущаяПодсистема из Метаданные.Подсистемы Цикл
        СписокПодсистем.Добавить(ТекущаяПодсистема.Имя);    
    КонецЦикла;
    Возврат СписокПодсистем;
КонецФункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    СписокПодсистем = Новый СписокЗначений;
    СписокПодсистем = ПолучитьСписокПодсистем();
    Для каждого ТекущаяПодсистема из СписокПодсистем Цикл
        Элементы.Подсистема.СписокВыбора.Добавить(ТекущаяПодсистема,ТекущаяПодсистема.Значение);
    КонецЦикла;
КонецПроцедуры


Здесь все нормально,все формируется,но проблема состоит в том,что при выборе подсистемы значение которое я выбираю не возвращается в это поле,тоесть поле остается полностью пустым,пытался вернуть вот так


&НаКлиенте
Процедура ПодсистемаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Подсистема = ДанныеВыбора;
КонецПроцедуры


В чем проблема может быть ?
 
 
   Sasha_H
 
1 - 09.10.18 - 12:43
Во-первых сделай по феншую не в при открытии, а ПриСоздании(), а функцию ПолучитьСписокПодсистем размести НаСервереБезКонтекста 

Элементы.Подсистема.СписокВыбора.ЗагрузитьЗначения или как-то так
   iznvi
 
2 - 09.10.18 - 12:46
(1) Поправил,не помогло
   Sasha_H
 
3 - 09.10.18 - 12:48
Элементы.Подсистема.СписокВыбора = СписокПодсистем;

а так?
   iznvi
 
4 - 09.10.18 - 12:54
(3) Все спасибо,исправил.Я если честно в шоке.Просто убрал галку с Режим выбора из Списка
Какого ?Просто,а ска
   Sasha_H
 
5 - 09.10.18 - 12:55
(4) Все верно. Когда режим выбора со списка тогда при начале выбора надо было формировать этот список
   iznvi
 
6 - 09.10.18 - 12:57
(5) Каапец,не знал
Только учусь,но большое спасибо)
   iznvi
 
7 - 09.10.18 - 12:58
(5)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует