Вход | Регистрация


Невозможно подключить дополнительную обработку из файла. Возможно, она не подходит для это

Невозможно подключить дополнительную обработку из файла. Возможно, она не подходит для это
Я
   meniki
 
09.10.18 - 11:48
Функция СведениеОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = новый Структура;
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");
    ПараметрыРегистрации.Вставить("Назначение", ПолучитьНазначениеОбработки());
    ПараметрыРегистрации.Вставить("Наименование", "Счет на оплату ВНЕШНИЙ");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("Информация", "Счет на оплату (внешняя печатная форма)");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    
    Команды = ПолучитьТаблицуКоманд();
    
    ДобавитьКоманду(Команды, "Счет на оплату (внешняя печатная форма)",
                             "СчетНаОплатуВнешний",
                             "ВызовСерверногоМетода",
                             Ложь,
                             "ПечатьXML");
                             
    ПараметрыРегистрации.Вставить("Команды", Команды);
    
    Возврат ПараметрыРегистрации;
    
    
Конецфункции


При попытке подключить внешнюю печатную форму выдает ошибку
"Невозможно подключить дополнительную обработку из файла. Возможно она не подходит для этой версии программы.


Комплексная автоматизация для Казахстана, редакция 2. Локализация для Казахстана: "1С-Рейтинг" (2.1.3.12)
 
 
   hhhh
 
1 - 09.10.18 - 11:58
(0) что-то ДобавитьКоманду - это же одну команду добавляете. А вы херакнули 10 команд сразу. Так разве можно?
   cons24
 
2 - 09.10.18 - 12:05
Может все-таки СведениЯОВнешнейОбработке а не СведениЕОВнешнейОбработке?
   meniki
 
3 - 09.10.18 - 12:06
(2) Думаете?
   meniki
 
4 - 09.10.18 - 12:07
(1) ну кажется так и надо писать
   Cyberhawk
 
5 - 09.10.18 - 12:12
Троль какой-то
   hhhh
 
6 - 09.10.18 - 12:14
(4) функцию ДобавитьКоманду() покажи. Там 6 параметров?
   meniki
 
7 - 09.10.18 - 12:15
(6)
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
    
КонецПроцедуры
   meniki
 
8 - 09.10.18 - 12:17
(6)
Функция ПолучитьТаблицуКоманд()

    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    
    Возврат Команды;
    
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
    
КонецПроцедуры
   hhhh
 
9 - 09.10.18 - 12:18
(7) хорошо. ну тогда (2)
   meniki
 
10 - 09.10.18 - 12:21
(2) (9)
Спасибо!!!
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует