Вход | Регистрация


Косяк при передаче на сервер

Косяк при передаче на сервер
Я
   iznvi
 
08.10.18 - 15:39
Задача состоит в том чтобы передать массив с клиента на сервер

&НаКлиенте
Функция ПередачаМассива() 
     
    Массив = Новый Массив;
    Возврат Массив;    
    //Файл = Новый ДвоичныеДанные(Массив);

    //ФайлВХранилище = Новый ХранилищеЗначения(Файл);

    //ПроцедурыДляРаботыНаСервере.ЗаписатьФайлНаСервере(ФайлВХранилище);

        
        //Адрес = ПоместитьВоВременноеХранилище(Массив);

    
КонецФункции



Процедура СКлиентаНаСервере(Команда,Массив,Список)
    
    Если Выберите = "Массив" Тогда    
        Массив.Добавить("ПередаюМассив");
    Для Каждого ЭлементМассива из Массив Цикл
        Сообщить(ЭлементМассива);
    КонецЦикла;
    
    ИначеЕсли Выберите = "СписокЗначений"  Тогда 
        ПередачаСписка="ПередачаСписка";
    Список.Добавить(ПередачаСписка);
    Для Каждого ЭлементСписка из Список Цикл
        Сообщить(ЭлементСписка);    
    КонецЦикла;

    ИначеЕсли Выберите = "ТаблицаЗначений" Тогда
        
        
    КонецЕсли;
 
        
    
//КонецЕсли;    

КонецПроцедуры


Ошибка : Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.

В чем проблема?
 
 
   spiller26
 
1 - 08.10.18 - 15:51
(0) Это точно массив?
В коде ни черта не понятно что вы хотите сделать.
   Cyberhawk
 
2 - 08.10.18 - 15:51
Проблема у тебя явно не в "чем"
   Сияющий в темноте
 
3 - 08.10.18 - 15:54
хрень какая то
Выберите это поле формы,а где сами массивы и списки создаются?
   Дмитрий
 
4 - 08.10.18 - 16:02
Задача состоит в том чтобы передать массив с клиента на сервер

&НаСервере
Процедура СделатьЧтотоСМассивомНаСервере(М)
   М.Добавить(1);
КонецПроцедуры

&НаКлиенте
Процедура ПередатьМассивНаСервер()
   М = Новый Массив;
   СделатьЧтотоСМассивомНаСервере(М);
КонецПроцедуры

Не благодари
   iznvi
 
5 - 08.10.18 - 16:24
(4) : Выдает ошибку 
: Значение не является значением объектного типа (Добавить)
     М.Добавить(1);
   iznvi
 
6 - 08.10.18 - 16:24
(4)
   Дмитрий
 
7 - 08.10.18 - 16:29
(5) не верю
   iznvi
 
8 - 08.10.18 - 16:32
(7) Где-то я косячу,сейчас кину код
   iznvi
 
9 - 08.10.18 - 16:32
&НаКлиенте
Функция ПередачаМассива() 
     
    МассивЭлементаСписка = Новый Массив;
    МассивЭлементаСписка.Добавить("ПередаюМассив");

    Возврат МассивЭлементаСписка;        
КонецФункции

&НаКлиенте
Функция ПередачаCписокЗначений()
    
    Список = Новый СписокЗначений;
         
    Возврат Список;
    
КОнецФункции



&НаСервере
Процедура НуДавайтеПосмотримНаСервере(Список,МассивЭлементаСписка)
    
    Если Выберите = "Массив" Тогда    
    МассивЭлементаСписка.Добавить("ПередачаМассива");    
    Для Каждого ЭлементМассива из МассивЭлементаСписка Цикл
        Сообщить(ЭлементМассива);
    КонецЦикла;
    
    ИначеЕсли Выберите = "СписокЗначений"  Тогда 
        ПередачаСписка="ПередачаСписка";
    Список.Добавить(ПередачаСписка);
    Для Каждого ЭлементСписка из Список Цикл
        Сообщить(ЭлементСписка);    
    КонецЦикла;

    ИначеЕсли Выберите = "ТаблицаЗначений" Тогда
        
        
    КонецЕсли;
 

КонецПроцедуры

&НаКлиенте
Процедура НуДавайтеПосмотрим(Команда,Список,МассивЭлементаСписка)
    НуДавайтеПосмотримНаСервере(Список,МассивЭлементаСписка);
КонецПроцедуры
   iznvi
 
10 - 08.10.18 - 16:32
(7) Сделал как в примере у тебя
 
 Рекламное место пустует
   iznvi
 
11 - 08.10.18 - 16:41
(7) Я просто только учусь и не понимаю в чем ошибка
   youalex
 
12 - 08.10.18 - 16:41
открой уже для себя отладчик.
   iznvi
 
13 - 08.10.18 - 16:44
(12) Открывал,пишет тип неопределенно
   youalex
 
14 - 08.10.18 - 16:47
(13) А тебе что нужно?
   iznvi
 
15 - 08.10.18 - 16:48
(14) Мне нужно  передать массив из функции ПередачаМассива в процедуру НуДавайтеПосмотримНаСервере
   youalex
 
16 - 08.10.18 - 16:51
(15) тебе нужно передать массив, но массива у тебя нет. Что нужно сделать? см. (4) внимательно
   lodger
 
17 - 08.10.18 - 16:53
(15) а как они между собой связаны? телепатически?
   iznvi
 
18 - 08.10.18 - 16:55
(17) А как их связать между собой?
   lodger
 
19 - 08.10.18 - 17:02
(18) написать код заново. благо его не так много.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует