Вход | Регистрация



Передача с клиента на сервер

Передача с клиента на сервер
Я
   iznvi
 
08.10.18 - 10:16
Ребят,задача стоит допустим просто передать массив с клиента на сервер. Создаю функцию,создаю там массив,добавляю в него значение и передаю название функции на сервер,а 1с говорит,что такой функции нет.В чем проблема?
 
 
   FIXXXL
 
1 - 08.10.18 - 10:18
(0) клиент "видит" сервер
сервер НЕ "видит" клиента
   RomanYS
 
2 - 08.10.18 - 10:19
где находится созданная функция?
   iznvi
 
3 - 08.10.18 - 10:19
(2) На форме,в модуле
   iznvi
 
4 - 08.10.18 - 10:20
(1) А как тогда передать значения ?
   unregistered
 
5 - 08.10.18 - 10:20
(0)  > передаю название функции на сервер

Как это понимать? Что это означает? Приведи пример кода, чтобы было понятно - что и где ты создаешь и кого откуда вызываешь.
   unregistered
 
6 - 08.10.18 - 10:21
(3) > На форме,в модуле

Вопрос не об этом. Вопрос о том на клиенте или на сервере функция.
   iznvi
 
7 - 08.10.18 - 10:22
(6) На клиенте
   iznvi
 
8 - 08.10.18 - 10:22
Функция ПередачаМассива() 
     
    Массив = Новый Массив;
    Массив.Добавить("ПередаюМассив");
    Для Каждого ЭлементМассива из Массив Цикл
        
        Сообщить(ЭлементМассива);
        
        
    КонецЦикла;
    
//    Файл = Новый ДвоичныеДанные(Массив);

//ФайлВХранилище = Новый ХранилищеЗначения(Файл);
//ПроцедурыДляРаботыНаСервере.ЗаписатьФайлНаСервере(ФайлВХранилище);

    
    //Адрес = ПоместитьВоВременноеХранилище(Массив);

    
КонецФункции



&НаСервере
Процедура СКлиентаНаСервере(Команда,Адрес,ТаблицаЗначений)
    
     Если Выберите = "Массив" Тогда 
        ПередачаМассива();     
        
    
КонецЕсли;    
КонецПроцедуры
   iznvi
 
9 - 08.10.18 - 10:23
(6) Опубликовал пример кода
   Провинциальный 1сник
 
10 - 08.10.18 - 10:23
(8) Сервер не может вызывать клиента
 
 Рекламное место пустует
   Скиурус
 
11 - 08.10.18 - 10:24
Меняй логику, сервер не должен заставлять что-то делать клиента, он же сервер.
   unregistered
 
12 - 08.10.18 - 10:25
(8) В (0) написано "задача стоит ... передать массив с клиента на сервер". А в (8) ты пытаешься сделать обратное - вызвать с сервера клиентскую функцию. А так делать нельзя.
   FIXXXL
 
13 - 08.10.18 - 10:25
(4)
создал массив на клиенте, вызвал СервернаяФункция(СозданныйМассив)
   МимохожийОднако
 
14 - 08.10.18 - 10:33
(8) Синтаксическую проверку твой код проходит?
"Сумлеваюсь я "©Дед Щукарь
   iznvi
 
15 - 08.10.18 - 10:53
(13)  Так наоборот надо же

Создать на Клиенте и передать на Сервер
   FIXXXL
 
16 - 08.10.18 - 11:04
(15) ну а я тебе что написал?
на клиенте вызываешь серверную функцию, параметром передаешь свой массив
   Cyberhawk
 
17 - 08.10.18 - 11:15
(12) Где ты увидел вызов клиентской функции?
   hhhh
 
18 - 08.10.18 - 11:18
(17) &НаСервере
Процедура СКлиентаНаСервере(Команда,Адрес,ТаблицаЗначений)
    
     Если Выберите = "Массив" Тогда 
        ПередачаМассива();     
        
    
КонецЕсли;    
КонецПроцедуры
   Cyberhawk
 
19 - 08.10.18 - 11:20
(18) Что-то ты просто скопировал тот же самый код, что приведен выше. Как это отвечает на мой вопрос, не ясно.
   Остап Сулейманович
 
20 - 08.10.18 - 11:24
Стесняюсь спросить - а кто какие видит варианты значения у "Выберите"? В коде из (18)
   Cyberhawk
 
21 - 08.10.18 - 11:26
(20) Переменная модуля формы или реквизит формы, например
   hhhh
 
22 - 08.10.18 - 11:28
(19) ты же спросил, где вызов клиентской функции. Ответ:

ПередачаМассива();

клиентская функция, вызывается ТС с сервера. А как еще ответить на твой вопрос?
   Cyberhawk
 
23 - 08.10.18 - 11:28
(22) Кто сказал, что это клиентская функция?
   hhhh
 
24 - 08.10.18 - 11:31
(23) тс сказал, в (7)
   Cyberhawk
 
25 - 08.10.18 - 11:36
(24) Он заблуждается
   hhhh
 
26 - 08.10.18 - 11:38
(25) может быть
   Остап Сулейманович
 
27 - 08.10.18 - 11:39
(25) А если он просто директиву не скопировал?
   Cyberhawk
 
28 - 08.10.18 - 11:41
(27) Все возможно. Именно поэтому Я и спрашиваю в (17), а не утверждаю


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует