Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как сделать чтоб таблица из отчета открывалась поверх документа из которого вызвали отчет

v7: Как сделать чтоб таблица из отчета открывалась поверх документа из которого вызвали отчет
Я
   sysadminlk
 
08.10.18 - 10:00
Процедура ПриДвойномНажатииЛевойКнопки(сост,х,у,фсо)
    Если Проведен() = 1 Тогда    
        Если Форма.АктивныйЭлемент() = "Тов" Тогда
            глРасшифровка = СоздатьОбъект("СписокЗначений");
            глРасшифровка.Установить("Тов",Тов);
            глФлагРасшифровки = 1;
            ОткрытьФорму("Отчет.ИсторияТов",);
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Есть документ, в нем если кликнуть по товару открывается и выполняется отчет в итоге открывается готовая печатная форма, но она на заднем плане. Приходится жать Ctrl+TAB чтобы её увидеть. Как сделать чтоб она была на переднем плане сразу?
 
 
   Масянька
 
1 - 08.10.18 - 10:04
Показать(<?>,,);
Show(<?>,,);
Синтаксис:
Показать(<Заголовок>,<ИмяФайла>,<Активизировать>)
Назначение:
Открыть окно редактирования таблицы.
Параметры:
<Заголовок> - необязательный параметр. Заголовок окна редактирования. Если параметр не задан, в заголовке будет выдаваться слово ''Таблица''.
<ИмяФайла> - необязательный параметр. Имя файла для сохранения таблицы. Если параметр задан, то при закрытии окна табличного документа система будет предлагать сохранить документ в файле с указанным именем. Если файла с таким именем не существует, то будет создан новый файл с таким именем. Если параметр опущен или имеет пустое значение, то при закрытии окна табличного документа система не будет предлагать сохранить данные в файле.
<Активизировать> - необязательный параметр. Признак активизации. Число: 1 - активизировать окно табличного документа; 0 - не активизировать окно табличного документа;  -1 (минус единица) - закрыть окно если оно открыто; по умолчанию  1. (необязателен).
   sysadminlk
 
2 - 08.10.18 - 10:22
(1) по умолчанию  1.
   vcv
 
3 - 08.10.18 - 10:39
Может фсо в ноль сбросить? Подозреваю, что сначала отрабатывает ОткрытьФорму и выводится таблица отчёта, в потом отрабатывает стандартная обработка ПриДвойномНажатииЛевойКнопки с активизацией элемента, на который покликали.
   Масянька
 
4 - 08.10.18 - 10:41
А сам док-т не модально открывается? Ну, случайно...
   Злопчинский
 
5 - 08.10.18 - 10:41
ну так у тебя активной остается форма из которой отчет вызываешь, она и активизируется, видимо, вместо активизации окна ПФ.
   sysadminlk
 
6 - 08.10.18 - 10:46
(4) не не модально
   Масянька
 
7 - 08.10.18 - 10:46
Ну, и в стандарте покапайся...
Например, в ТиС в док-те ЗаякаПокупателя (и не только в нем) есть кнопка "Долг контрагента". По ней вызывается отчет, а в отчете есть ПриОткрытии (там прилично буков). Мне - лень ковыряться.
   Масянька
 
8 - 08.10.18 - 10:47
(6) Пробуй (7).
Судя по всему, в ПриОткрытии нужно обрабатывать.
   sysadminlk
 
9 - 08.10.18 - 10:56
(3) супер! спасибо помогло.

Процедура ПриДвойномНажатииЛевойКнопки(сост,х,у,фсо)
    фсо = 0;
    Если Проведен() = 1 Тогда    
        Если Форма.АктивныйЭлемент() = "Идн1" Тогда
            ИИ = СоздатьОбъект("Справочник.ИДН");
            Если ИИ.НайтиПоНаименованию(СокрЛП(Идн1),0,1) = 1 Тогда
                ОбработкаЯчейкиТаблицы(ИИ.ТекущийЭлемент(),"","","");
            КонецЕсли;            
        ИначеЕсли Форма.АктивныйЭлемент() = "Тов" Тогда
            ОбработкаЯчейкиТаблицы(Тов.ТекущийЭлемент(),"","","");
        КонецЕсли;
    КонецЕсли;    
КонецПроцедуры
   Масянька
 
10 - 08.10.18 - 10:59
(9) А чего код другой? Совсем...
 
 Рекламное место пустует
   sysadminlk
 
11 - 08.10.18 - 11:44
(10) переписал ))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует