Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

КД 2.1 реквизит в табличную часть.

КД 2.1 реквизит в табличную часть.
Я
   Туц
 
08.10.18 - 09:54
Суть. В 77 Отчет ККМ, в нем есть реквизиты шапки "безнал сбербанк", "безнал корона" и т.д.
Грузим в БП30. Там есть табличная часть безналичные оплаты. В неё нужно заполнить соответственно "сбербанк", "корона" и т.д.

Просьба опытных спецов по КД опишите кратко, поэтапно что и как в КД нужно настроить.

В данный момент для ПКГС группы "Оплаты" поместил код
КоллекцияОбъектов = СоздатьОбъект("ТаблицаЗначений");
Если (Источник.СуммаБезНала+Источник.СуммаБезНалаЗК+Источник.СуммаПоВаучерам+Источник.СуммаПоВаучерам) > 0 Тогда
    
    КоллекцияОбъектов = СоздатьОбъект("ТаблицаЗначений");
    КоллекцияОбъектов.НоваяКолонка("ВидОплаты","Строка");
    КоллекцияОбъектов.НоваяКолонка("СуммаОплаты","Число",15,2);
    
    Если Источник.СуммаБезНала>0 Тогда
        КоллекцияОбъектов.НоваяСтрока();
        КоллекцияОбъектов.ВидОплаты         = "Сбербанк";
        КоллекцияОбъектов.СуммаОплаты         = Источник.СуммаБезНала;    
    КонецЕсли;
    
    Если Источник.СуммаБезНалаЗК>0 Тогда
        КоллекцияОбъектов.НоваяСтрока();
        КоллекцияОбъектов.ВидОплаты         = "ЗолотаяКорона";
        КоллекцияОбъектов.СуммаОплаты         = Источник.СуммаБезНалаЗК;
    КонецЕсли;
    
    Если Источник.СуммаПоВаучерам>0 Тогда
        КоллекцияОбъектов.НоваяСтрока();
        КоллекцияОбъектов.ВидОплаты         = "ОплатаБонусами";
        КоллекцияОбъектов.СуммаОплаты         = Источник.СуммаПоВаучерам;
    КонецЕсли;
    
    Если Источник.СуммаПоВаучерам>0 Тогда
        КоллекцияОбъектов.НоваяСтрока();
        КоллекцияОбъектов.ВидОплаты         = "ОплатаСертификатами";
        КоллекцияОбъектов.СуммаОплаты         = Источник.СуммаПоВаучерам;
    КонецЕсли;
    
КонецЕсли;

Что и где дальше нужно доделать пока не могу понять, перепробовал много, без результата.
 
 
   Туц
 
1 - 08.10.18 - 09:55
(0) в ПКГС группы указанный код в обработчике "Перед обработкой"

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует