Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как добавить дополнительные отчеты в начальную страницу?

Как добавить дополнительные отчеты в начальную страницу?
Я
   wms
 
05.10.18 - 12:10
1С ERP 2.4
Нужно новому пользователю настроить интерфейс с дополнительными отчетами и обработками на начальной странице.Доступа к разделам (подсистемам) у него нет.
Дал пользователю базовые права и права на чтение дополнительных отчетов и обработок.
Добавил права на новую роль и в ней дал доступ на:
-общую форму Дополнительные отчеты и обработки;
-общую команду ДополнительныеОтчетыГлавное;
-общую команду ДополнительныеОбработкиГлавное;

Захожу под пользователем Дополнительных отчетов НЕТ, а вот дополнительные обработки есть.
 
 
   wms
 
1 - 05.10.18 - 12:54
на что еще дать права? или хотя бы где рыть? не знаю даже где
   Фрэнки
 
2 - 05.10.18 - 13:11
я со своих предпочтений лезть глубоко в переделку кода типовой конфиги не захотел.
Сделал вывод стартовой страницы в расширении.
   Фрэнки
 
3 - 05.10.18 - 13:21
в расширение заимствовал Модуль сеанса, а точнее:

&После("УстановкаПараметровСеанса")
Процедура МОЯ_УстановкаПараметровСеанса(ИменаПараметровСеанса)
    
    МОЯ_НастройкаНачальнойСтраницы();
    
КонецПроцедуры

Процедура МОЯ_НастройкаНачальнойСтраницы()

    //НастройкиНачальнойСтраницы = Новый НастройкиНачальнойСтраницы;

    //СоставФорм = Новый СоставФормНачальнойСтраницы;

    //

    //Если РольДоступна( "ПолныеПрава" ) Тогда

    //    СоставФорм.ЛеваяКолонка.Добавить("ОбщаяФорма.МОЯ_ФормаАдминистратора");

    //Иначе

    //    СоставФорм.ЛеваяКолонка.Добавить("ОбщаяФорма.МОЯ_ФормаПользователя");

    //КонецЕсли;


    //НастройкиНачальнойСтраницы.УстановитьСоставФорм( СоставФорм );

    //ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиНачальнойСтраницы", , НастройкиНачальнойСтраницы);


КонецПроцедуры
   Cyberhawk
 
4 - 05.10.18 - 13:27
"дополнительные обработки есть" // Покажи на картинке
   wms
 
5 - 05.10.18 - 13:58
(3) спасибо за наводку , попробую
(4)
http://www.picshare.ru/view/9297607/
но меня не устраивает когда Главное появилось, там лишнее.
Хочу сделать как "Дополнительные обработки"
   cons24
 
6 - 05.10.18 - 14:29
На сколько помню, команды "дополнительные отчеты" и "дополнительные обработки" добавляются в разделы программно, в каких-то общих модулях. Подробнее ищите в описании БСП на ИТС в разделе вида "дополнительные обработки".
   wms
 
7 - 05.10.18 - 17:00
(3) по твоему варианту вроде получилось
тоже пришлось свою форму нарисовать и ее вызывать при установке сеанса
    НастройкиНачальнойСтраницы = Новый НастройкиНачальнойСтраницы;    
    СоставФорм = Новый СоставФормНачальнойСтраницы;
    Если РольДоступна("ивс_ПравоДоступаКОтчетуРасчетыСПартнерамиПоСпискуПартнеров") Тогда
        СоставФорм.ЛеваяКолонка.Добавить("ОбщаяФорма.ДополнительныеОтчетыИОбработкиДоп");
    КонецЕсли;    
    НастройкиНачальнойСтраницы.УстановитьСоставФорм( СоставФорм );
    ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиНачальнойСтраницы", , НастройкиНачальнойСтраницы);    

в этой форме добавил 2 кнопки для вызова внешних отчетов и обработок
с одной типовой формой ОбщаяФорма.ДополнительныеОтчетыИОбработки не получилось- она без параметров открывается и пустая

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует