Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Добавить программно дополнительное поле в отчет на базе универсального.

Добавить программно дополнительное поле в отчет на базе универсального.
Я
   Румата
 
03.10.18 - 11:02
Ни как не получается САБЖ.

Вот текст запроса :

ВЫБРАТЬ РАЗРЕШЕННЫЕ
    ЗаявкаНаВыдачуДенежныхСредствУслуги.Ссылка КАК Заявка,
    ЗаявкаНаВыдачуДенежныхСредствУслуги.Ссылка.КонтрагентБаинг КАК Клиент,
    ЗаявкаНаВыдачуДенежныхСредствУслуги.Ссылка.Поставщик КАК Поставщик,
    СУММА(ЗаявкаНаВыдачуДенежныхСредствУслуги.Цена) КАК Продажа,
    СУММА(ЗаявкаНаВыдачуДенежныхСредствУслуги.СуммаОплаты) КАК Закупка,
    ЗаявкаНаВыдачуДенежныхСредствУслуги.Номенклатура,
    СУММА(1 - ВЫБОР
            КОГДА ЗаявкаНаВыдачуДенежныхСредствУслуги.Цена = 0
                ТОГДА 1
            ИНАЧЕ ЗаявкаНаВыдачуДенежныхСредствУслуги.СуммаОплаты / ЗаявкаНаВыдачуДенежныхСредствУслуги.Цена
        КОНЕЦ) КАК Рентабельность,
    СУММА(ЗаявкаНаВыдачуДенежныхСредствУслуги.Цена * 0.93 - ЗаявкаНаВыдачуДенежныхСредствУслуги.СуммаОплаты) КАК Маржа
{ВЫБРАТЬ
    Заявка.*,
    Клиент.*,
    Поставщик.*,
    Продажа,
    Закупка,
    Номенклатура.*,
    Рентабельность,
    Маржа}
ИЗ
    Документ.ЗаявкаНаВыдачуДенежныхСредств.Услуги КАК ЗаявкаНаВыдачуДенежныхСредствУслуги
{ГДЕ
    ЗаявкаНаВыдачуДенежныхСредствУслуги.Ссылка.* КАК Заявка}

СГРУППИРОВАТЬ ПО
    ЗаявкаНаВыдачуДенежныхСредствУслуги.Ссылка,
    ЗаявкаНаВыдачуДенежныхСредствУслуги.Ссылка.КонтрагентБаинг,
    ЗаявкаНаВыдачуДенежныхСредствУслуги.Ссылка.Поставщик,
    ЗаявкаНаВыдачуДенежныхСредствУслуги.Номенклатура
ИТОГИ
    МАКСИМУМ(Клиент),
    МАКСИМУМ(Поставщик)
ПО
    ОБЩИЕ
{ИТОГИ ПО
    Заявка.*,
    Номенклатура.*}
АВТОУПОРЯДОЧИВАНИЕ



Вот процедура установки начальных настроек :

Процедура УстановитьНачальныеНастройки(ДополнительныеПараметры=Неопределено) Экспорт
    Если ДополнительныеПараметры <> Неопределено Тогда
        УправлениеОтчетами.ВосстановитьРеквизитыОтчета(ЭтотОбъект,ДополнительныеПараметры);
    КонецЕсли;
    //УниверсальныйОтчет.мНазваниеОтчета = СокрЛП(ЭтотОбъект.Метаданные().Синоним);

    УниверсальныйОтчет.мНазваниеОтчета = "Маржа баинг";
    УниверсальныйОтчет.мВыбиратьИмяРегистра = Ложь;
    УниверсальныйОтчет.ВыводитьДетальныеЗаписи = Ложь;
    УниверсальныйОтчет.мВыбиратьИспользованиеСвойств = Истина;
    УниверсальныйОтчет.мРежимФормыНастройкиБезГруппировокКолонок = Ложь;
    УниверсальныйОтчет.ПоказыватьЗаголовок = Истина;
    //Пока ЗначениеЗаполнено(УниверсальныйОтчет.ДатаКон) Цикл

        УниверсальныйОтчет.ДатаКон = ДатаКонца;
        УниверсальныйОтчет.ДатаНач = ДатаНачала;
        //УниверсальныйОтчет.ПостроительОтчета.Параметры.Вставить("Организация",Справочники.Организации.НайтиПоКоду("УТ0000003"));

        //УниверсальныйОтчет.ДатаКонца = ДатаКонца;

        //УниверсальныйОтчет.ДатаНачала = ДатаНачала;


    //КонецЦикла;

    УстановитьТекстЗапроса();
    
    //УниверсальныйОтчет.ПостроительОтчета.Параметры.Вставить("Организация");

    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Заявка","Заявка");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Клиент", "Клиент");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Поставщик", "Поставщик");

    
    //УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Заявка","Заявка");

    //УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("НазначениеПлатежа","Назначение платежа");




    УниверсальныйОтчет.ДобавитьПоказатель("Продажа","Продажа",Истина,"ЧЦ=15; ЧДЦ=2",,);
    УниверсальныйОтчет.ДобавитьПоказатель("Закупка","Закупка",Истина,"ЧЦ=15; ЧДЦ=2",,);
    УниверсальныйОтчет.ДобавитьПоказатель("Рентабельность","Рентабельность",Истина,"ЧЦ=15; ЧДЦ=2",,);
    УниверсальныйОтчет.ДобавитьПоказатель("Маржа","Маржа",Истина,"ЧЦ=15; ЧДЦ=2",,);

    
    
    УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Заявка");
    УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Номенклатура");
    //УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Регистратор");

    //УниверсальныйОтчет.ДобавитьИзмерениеСтроки("МасштабКомпании");



    УниверсальныйОтчет.ДобавитьОтбор("Заявка");
    //УниверсальныйОтчет.ДобавитьОтбор("Регистратор");

    //УниверсальныйОтчет.ДобавитьОтбор("МасштабКомпании");

    //УниверсальныйОтчет.ДобавитьОтбор("СфераДеятельности");

    
         
    УниверсальныйОтчет.ДобавитьДополнительноеПоле("Клиент", ТипРазмещенияРеквизитовИзмерений.Отдельно);
    УниверсальныйОтчет.ДобавитьДополнительноеПоле("Поставщик", ТипРазмещенияРеквизитовИзмерений.Отдельно);
    
    
    УниверсальныйОтчет.УстановитьПредставленияПолей(УниверсальныйОтчет.мСтруктураПредставлениеПолей,УниверсальныйОтчет.ПостроительОтчета);
    УниверсальныйОтчет.УстановитьТипыЗначенийСвойствДляОтбора();
    УниверсальныйОтчет.УстановитьНачальныеНастройки();
    УниверсальныйОтчет.ВыводитьОбщиеИтоги = Истина;
    
    УниверсальныйОтчет.УстановитьСвязьПоляИИзмерения("Клиент", "Заявка");
    УниверсальныйОтчет.УстановитьСвязьПоляИИзмерения("Поставщик", "Заявка");

      
КонецПроцедуры


Поля просто не отображаются.
 
 
   Румата
 
1 - 03.10.18 - 12:31
Все разобрался, шаблон отчета был каким-то коцнутым, взял за основу отчет из типовой конфигурации - все получилось. Всем спасибо.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует