Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Запаролить внеш обработку на пользователя

Запаролить внеш обработку на пользователя
Я
   lirt82
 
03.10.18 - 08:31
Пишу для базы на управляемых обработку, в бухгалтерии возникла жесткая конкуренция за нее:)...и меня попросили сделать так чтоб пользоваться ей мог только один конкретный пользователь. Как реализовать, нужно учесть что в базе используется несколько внеш. обработок.
 
 
   Vadim_37
 
1 - 03.10.18 - 08:35
ТекущийПользователь()
   lirt82
 
2 - 03.10.18 - 08:35
:-) форму ввода пароля при запуске?
   SweetaAngel
 
3 - 03.10.18 - 08:36
Создай спец права и назнач одному пользователю и проверяй через РольДоступна или тупо проверяй Текущего пользователя.
   lirt82
 
4 - 03.10.18 - 08:39
всем спасибо, сделал форму ввода пароля с проверкой, сам пароль зашью в модуль.
   SweetaAngel
 
5 - 03.10.18 - 09:14
(4) Ровно до тех пор пока, человек со знанием пароля под большим секретом не расскажет его другому.
   Cool_Profi
 
6 - 03.10.18 - 09:15
Я бы на роль лучше завязался...
   lirt82
 
7 - 03.10.18 - 09:31
(5) :)
теперь другая проблема
не могу в этой внешней обработке из формы ввода пароля открыть другую форму этой же обработки. Т.е. после того как ввели пароль должна открыться другая форма.

&НаКлиенте
Процедура ОК(Команда)
    
    Psw = "1";
    Если НЕ ЗначениеЗаполнено(Пароль) Тогда
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Введите пароль для запуска обработки!";
        Сообщение.Сообщить();
        Возврат
    ИначеЕсли Пароль <> Psw Тогда        
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Неверный пароль!";
        Сообщение.Сообщить();
        Пароль = "";
        Возврат
    Иначе
        ЭтаФорма.Закрыть();
    //тут открыть вторую форму    

    КонецЕсли;       
    
КонецПроцедуры
   ASU_Diamond
 
8 - 03.10.18 - 09:34
(5) ровно до тех пор, пока главбух не спросит что за хрень твориться.
(0) ты работаешь на конкретного бухгалтера или на организацию? что в постановке задачи было?
   lirt82
 
9 - 03.10.18 - 09:36
(8) это она и попросила, подскажи лучше с открытием второй формы
   hhhh
 
10 - 03.10.18 - 09:37
(9)         

Фрм = ПолучитьФорму("ВнешняяОбработка.ЗагрузитьИзExcel.Форма.КорректировкаДанных", ПараметрыФормы, ЭтотОбъект, КлючУник);
        Если Фрм <> Неопределено Тогда
            Фрм.Открыть();
        КонецЕсли;
 
 Рекламное место пустует
   DSSS
 
11 - 03.10.18 - 09:37
Пароль - это какая-то дичь. Но если очень хочется, читай https://its.1c.ru/db/v8std/content/2149184389/hdoc

При создании на сервере сделай проверку на РольДоступа и все
   lirt82
 
12 - 03.10.18 - 09:44
(10) Переменная не определена (ПараметрыФормы)
   catena
 
13 - 03.10.18 - 09:49
<Параметры> (необязательный)

Тип: Структура. 
Параметры формы. Ключ структуры - имя параметра, а значение - значение параметра формы. Имя элемента должно совпадать с именем параметра структуры.
П = Новый Структура("Ключ", Поставщик);
Форма = ПолучитьФорму("Справочник.Контрагенты.ФормаОбъекта", П);
Форма.Открыть();
   seevkik
 
14 - 03.10.18 - 09:51
Мне кажется или в дополнительных обработках можно выбрать пользователей которым она видна?
   lirt82
 
15 - 03.10.18 - 09:56
При этом внешний отчет или обработка должны быть предварительно зарегистрированы в системе.
Блин вот морока)) у гл буха будет просто этот файл храниться не нужно его никуда встраивать в базу...короче в ж эту форму пароля тупо проверка на пользака
   lirt82
 
16 - 03.10.18 - 09:56
) хотел творчески подойти...
   lirt82
 
17 - 03.10.18 - 09:58
все нашел решение
https://forum.infostart.ru/forum9/topic132349/
   catena
 
18 - 03.10.18 - 09:58
(15)Если файл будет у главбуха храниться, нафига вообще какие-то проверки)))
   lirt82
 
19 - 03.10.18 - 10:01
(18) она вышла за ее комп села другая и запустила эту обработку
   lirt82
 
20 - 03.10.18 - 10:07
все получилось спасибо (13) (10) 
&НаКлиенте
Процедура ОК(Команда)
    
    Psw = "1";
    Если НЕ ЗначениеЗаполнено(Пароль) Тогда
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Введите пароль для запуска обработки!";
        Сообщение.Сообщить();
        Возврат
    ИначеЕсли Пароль <> Psw Тогда        
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Неверный пароль!";
        Сообщение.Сообщить();
        Пароль = "";
        Возврат
    Иначе
        ЭтаФорма.Закрыть();
        ПараметрыФормы = Новый Структура("ЭтаФорма", Psw);
        Форма = ПолучитьФорму("ВнешняяОбработка.ХХХХХХХХ.Форма.ОсФорма", ПараметрыФормы, ЭтотОбъект);
        Если Форма <> Неопределено Тогда
            Форма.Открыть();
        КонецЕсли;
    КонецЕсли;       
    
КонецПроцедуры
   catena
 
21 - 03.10.18 - 10:26
(19)Она вышла и не закрыла обработку, за ее комп села другая. В конторе, в которой даже главбух не умеет блокировать машину поможет только порка.
   Быдло замкадное
 
22 - 03.10.18 - 10:37
перед открытием если текпользователь.имя <> марьиванна тогда отказ = истина
   bolobol
 
23 - 03.10.18 - 10:39
(22) Перед нажатием кнопки ВыполнитьОбработку!
   Остап Сулейманович
 
24 - 03.10.18 - 10:39
(22) )))
Первое слово ника совпадает с первым словом стиля кодинга.
   bolobol
 
25 - 03.10.18 - 10:40
(22) И - пароль! Ибо за компом МарьИванны может оказаться СанСаныч
   Остап Сулейманович
 
26 - 03.10.18 - 10:46
(25) Лучше переспросить.
ПоказатьВопрос(Обработчик, "А вы точно ли марьиванна?, нажмите Да - если нет, Нет - если да, Отмена - если ПтляБуду.
И случайным образом менять кнопки. Пусть в капчу поиграются.
)))


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует