Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Перебор дерева по строкам с добавлением ифотографии в номенклатуру.

Перебор дерева по строкам с добавлением ифотографии в номенклатуру.
Я
   SkillUp
 
03.10.18 - 08:19
Идет перебор в цикле строк дерева...

В одной из строк, находим картинку. Дальше у меня заполнение номенклатуры и его основного изображение (КОТОРОЕ ДОЛЖНО БЫТЬ ПЕРВОЕ)
                     Для Каждого  стр ИЗ Строки Цикл
                       ...

            //Картинка

            Если стр.Имя = "picture" Тогда
                СтрокаТ = стр.Значение;
            ...    
            КонецЕсли;


Если картинка одна все норм., но если несколько он берет последнюю...

ИТОГ: Если несколько строк со (стр.Имя = "picture"),  то берет последнюю. Не могу понять как выделить первую в цикле, для указания ее основной номенклатуры?
 
 
   Лодырь
 
1 - 03.10.18 - 08:29
КартинкаНайдена = Ложь;
Для Каждого Стр из Строки Цикл
Если стр.Имя = "picture" и КартинкаНайдена Тогда
    продолжить;
ИначеЕсли стр.Имя = "picture" Тогда
    СтрокаТ = стр.Значение;
    КартинкаНайдена = Истина;
КонецЕсли;

КонецЦикла;
   SkillUp
 
2 - 03.10.18 - 08:36
(1) При обходе следующей номенклатуры, КартинкаНайдена = Истина будет?
   Лодырь
 
3 - 03.10.18 - 08:37
(2) Предполагается, что флаг скидывается при смене номенклатуры. Непонятно на самом деле что и как у тебя устроено в (0)
   SkillUp
 
4 - 03.10.18 - 08:39
(3) Ок, спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует