Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при вызове метода контекста (Прочитать)

Ошибка при вызове метода контекста (Прочитать)
Я
   VoditelKobyly
 
02.10.18 - 08:32
Добрый день!
Есть функция:
Функция ЗагрузитьФайлПечФормыВТабличныйДокумент(пИмяФайла) Экспорт
    лВыбФайл=Новый Файл(пИмяФайла);
    Если лВыбФайл.Существует() Тогда
        ПечатнаяФорма=Новый ТабличныйДокумент;
        ПечатнаяФорма.Прочитать(пИмяФайла);
        Если УдалитьФайл Тогда
            УдалитьФайлы(пИмяФайла);
        КонецЕсли;
    Иначе
        ПечатнаяФорма="Не найден файл печатной формы: "+пИмяФайла;
    КонецЕсли;
    Возврат ПечатнаяФорма;
КонецФункции    
Работает правильно, грузит файл mxl в табличный документ.
Но если внутри файла есть встроенный объект Ocvita BarCode то выдает ошибку на методе записать. При этом файл свободно открывается интерактивно через меню Файл\Открыть.
Что предпринять, чтобы файлы с этими объектами открыть программно?
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует