Вход | Регистрация


УФ. Открыть форму документа, после заполнения типовым методом

УФ. Открыть форму документа, после заполнения типовым методом
Я
   1CIlya
 
01.10.18 - 19:05
Здравствуйте, друзья!

Не могу взять в толк как открыть УФ. Заполняю в обработке программно на сервере документ ВедомостьНаВыплатуЗарплатыВБанк.

Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ ...";        
    
    Для Каждого ОбъектНазначения Из ОбъектыНазначенияМассив Цикл        
        Запрос.УстановитьПараметр("Ссылка", ОбъектНазначения.Ссылка);
        ОбъектНазначения.ЗаполнитьПоТаблицеЗарплат(Запрос.Выполнить().Выгрузить());        
    КонецЦикла;
    
КонецПроцедуры    

Все заполняется хорошо. Теперь нужно показать результат заполнения пользователю, и если его все устроит, он заполненный документ сохранит. Код модуля формы обработки такой:


&НаСервере
Процедура ЗаполнитьНаСервере(ДанныеФормы)
    
    ОбъектыНазначенияМассив = Новый Массив;
    ОбъектыНазначенияМассив.Добавить(Объект.Ссылка.ПолучитьОбъект());
    
    ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
    ОбработкаОбъект.ВыполнитьКоманду("НТХ_ЗаполнитьВедомостьВБанк", ОбъектыНазначенияМассив);
    
    Для Каждого ОбъектНазначения Из ОбъектыНазначенияМассив Цикл
        Результат = КопироватьДанныеФормы(ОбъектНазначения, ДанныеФормы);//здесь выскакивает ошибка

    КонецЦикла;
    
КонецПроцедуры

&НаКлиенте
Процедура Заполнить(Команда)
    
    ПараметрыФормы = Новый Структура("Ключ", Объект.Ссылка);
    ФормаОбъекта = ПолучитьФорму("Документ.ВедомостьНаВыплатуЗарплатыВБанк.ФормаОбъекта", ПараметрыФормы);
    ДанныеФормы = ФормаОбъекта.Объект;
    ЗаполнитьНаСервере(ДанныеФормы);
    Результат = КопироватьДанныеФормы(ДанныеФормы, ФормаОбъекта.Объект);
    
    ФормаОбъекта.Открыть();
    
КонецПроцедуры


Как передать форме данные из объектов, находящихся на сервере?
 
 
   breezee
 
1 - 01.10.18 - 19:44
ДанныеФормыВЗначние() вроде

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует