Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

БП 3.0. Как отловить факт выполнения регламентированной операции при закрытии мсяца?

БП 3.0. Как отловить факт выполнения регламентированной операции при закрытии мсяца?
Я
   Креатив
 
01.10.18 - 15:04
При закрытии месяца есть пункт расчет резервов по сомнительным долгам. Клиенты просят, чтобы я подкорректировал расчёт. Править модули не хочется. А необходимо, чтобы после выполнения операции вызывалась моя процедура.
 
 
   OldCondom
 
1 - 01.10.18 - 15:10
расширение
   OldCondom
 
2 - 01.10.18 - 15:10
&После
   Креатив
 
3 - 01.10.18 - 15:12
(1)Заморочно при обновлениях.
(2)А про это поподробней, если можно.
   OldCondom
 
4 - 01.10.18 - 15:14
Что там заморочного? И как обновление повлияет?
У меня такое есть:
&После("ЗакрытиеСчета97")
Процедура АЗАЗА_ЗакрытиеСчета97(СтруктураШапкиДокумента, Отказ, Ошибки)
    
    НаборХоз = Движения.Хозрасчетный;
    Для каждого ЗаписьНабора Из НаборХоз Цикл
    // всякое        

    КонецЦикла;
    
    
КонецПроцедуры
   OldCondom
 
5 - 01.10.18 - 15:16
Или вот такое:


&Перед("ЗакрытиеСчетов20_23_25_26")
Процедура АЛР_ЗакрытиеСчетов20_23_25_26(Период, Организаци, Ссылка, Отказ, Ошибки)
    
    
    ДокументЗакрытия25 = ПолучитьОперациюЗаМесяц(НачалоМесяца(Период), КонецМесяца(Период), "25");    
    
    ДокументЗакрытия23 = ПолучитьОперациюЗаМесяц(НачалоМесяца(Период), КонецМесяца(Период), "23");    
    
    СписатьЗатраты(ДокументЗакрытия25, "25", НачалоМесяца(Период), КонецМесяца(Период)
        , Организаци);
    СписатьЗатраты(ДокументЗакрытия23, "23", НачалоМесяца(Период), КонецМесяца(Период)
        , Организаци);

КонецПроцедуры
   Креатив
 
6 - 01.10.18 - 15:17
(4)Еси 1с поменяет обработку закрытие месяца, то нужно будет все изменения перетягиватть.
Это всё в расширении?
(5)А в каком модуле это всё?
   OldCondom
 
7 - 01.10.18 - 15:19
(6) так не меняй ничего типового, это атата всегда. Да, это все в расширении.
Модуль сам бы уже нашел через отладчик, для общего развития бухни.
А так - это процедуры в модуле документа "регламентнаяоперация". Вызываются в зависимости от того или иногда действия при закрытии.
   Креатив
 
8 - 01.10.18 - 15:22
(7)Спасибо, попробую.
   Aleksey
 
9 - 01.10.18 - 15:42
(4) Ну вот на этих выходных после обновления на 3.0.65 пришлось все расширения переписывать
   OldCondom
 
10 - 01.10.18 - 15:47
(9) еще не обновлялся. Можно вкратце, что там случилось?
 
 Рекламное место пустует
   Aleksey
 
11 - 01.10.18 - 15:57
(10) ну из явных Сменился режим совместимости. Пришлось во всех расширениях менять.
Атак по мелочи. К примеру при загрузки ЭД обработка по сопоставлению номенклатуры была раньше в общих формах, сейчас как форма обработки. Были у меня правки кода по 1С-отчетности (в основном запросы падали на RLS, приходилось править) они эти моменты переписали в хлам,как сами процедуры, так и запросы и их расположения. Пока что отключил эти расширения, решил что проще по новой баги выловить, чем разбираться в новом коде
   Креатив
 
12 - 04.10.18 - 09:12
Что-то у меня вообще не взлетело.
В основной конфигурации в модуле документа регламентированная операция есть процедура. Назовём её процедура1
Добавил а адаптивное расширение документ регламентированная операция. В модуле документа в раcширении написал
&ВМЕСТО("процедура1")
Процедура МояПроцедура1()
 Сообщить("работает");
КонецПроцедуры
Провожу документ. Отладчик заходит в процедуру основной конфигурации, а в мою процедуру не заходит.
   Креатив
 
13 - 04.10.18 - 09:45
Может кто поделиться ссылкой на хорошую статейку по расширениям. А то чувствую, что будут ещё вопросы.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует