Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Печатные формы документов в управляемом приложении

Печатные формы документов в управляемом приложении
Я
   laby1
 
01.10.18 - 09:52
Здравствуйте!


Подскажите, как создать печатную форму в новом не типовом управляемом приложении?

(Пишу небольшую конфигурацию...)

Переносить туда из типовой конфигурации весь механизм обработки внешних печатных форм. Или есть решение попроще?
 
 
   Cool_Profi
 
1 - 01.10.18 - 09:58
Просто рисуешь свою кнопку.
А если тебе нужен механизм подключения внешних - тогда лучше дёрнуть механизм из БСП
   laby1
 
2 - 01.10.18 - 10:13
(1) Кнопку я умею рисовать, спасибо. А что дальше?
   Healer
 
3 - 01.10.18 - 16:17
(2) В команде кнопки прописываем обращение к процедуре печати, которую лучше всего поместить в модуль менеджера документа или что там печатать будем...
   Healer
 
4 - 01.10.18 - 16:18
Так быстрее всего будет работать, а вообще можно в расширение конфигурации засунуть или во внешнюю печатную форму, как уже предложили выше.
   laby1
 
5 - 09.10.18 - 11:34
Я сделал так:

&НаКлиенте
 Процедура Печать(Команда)
     
     
    Если Объект.Ссылка = ПредопределенноеЗначение("Документ.ПоступлениеТехники.ПустаяСсылка") Тогда
        Предупреждение("Документ не записан");
        Возврат;
    Иначе
        ПечатьНаСервере().Показать("Поступление техники. Печатная форма.");
    КонецЕсли;
    
КонецПроцедуры

&НаСервере
Функция ПечатьНаСервере()
    
    ДокОбъект = РеквизитФормыВЗначение("Объект");
    Схема = ДокОбъект.ПолучитьМакет("Макет");
    Настройки = Схема.НастройкиПоУмолчанию;
    КомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных();
    КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);

    ПараметрДок = Новый ПараметрКомпоновкиДанных("Документ");
    ЗначениеПараметраДок = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрДок);
    ЗначениеПараметраДок.Значение = Объект.Ссылка;
    ЗначениеПараметраДок.Использование = Истина;
    Настройки = КомпоновщикНастроек.Настройки;
    
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    МакетКомпоновки = КомпоновщикМакета.Выполнить(Схема, Настройки);
    ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки);
    ДокументРезультат = Новый ТабличныйДокумент;
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);

    ДокументРезультат.ОтображатьЗаголовки = Ложь;
    ДокументРезультат.ОтображатьСетку = Ложь;
    ДокументРезультат.АвтоМасштаб = Истина;
    
    Возврат ДокументРезультат;
        
КонецФункции
   unregistered
 
6 - 09.10.18 - 11:54
(0) > как создать печатную форму в новом не типовом управляемом приложении?

Абсолютно точно так же как и в неуправляемом (обычном) приложении:

У твоего объекта (документа, например) в дереве метаданных нажимаешь правую кнопку мыши, в контекстном меню в подменю "Конструкторы..." находишь пункт "Конструктор печати". Жмешь. Готово.
   laby1
 
7 - 10.10.18 - 07:54
(6) Где ж ты раньше был ...

Список тем форума
Рекламное место пустует  Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует