Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Apache 2.2 не запускается с модулем wsap22.dll от 8.3.11-8.3.13, что посоветуете?

Apache 2.2 не запускается с модулем wsap22.dll от 8.3.11-8.3.13, что посоветуете?
Я
   Провинциальный 1сник
 
30.09.18 - 23:19
Обновил на сервере 1с, и столкнулся с такой проблемой. Публикую на веб-сервере базу, веб-сервер запускается и сразу вылетает с ошибкой. Если в httpd.conf прописать путь к wsap22 из каталога платформы 8.3.10 - апач запускается нормально.
В чем может быть проблема?
 
 
   sechs
 
1 - 30.09.18 - 23:21
Ошибку предлагается телепатировать?
   Провинциальный 1сник
 
2 - 30.09.18 - 23:22
А нет никакой ошибки. Просто вылетает модуль и всё.
   sechs
 
3 - 30.09.18 - 23:23
А если в логи посмотреть?
   Провинциальный 1сник
 
4 - 30.09.18 - 23:29
Служба при запуске пишет "Не удалось запустить службу apache22, дополнительные сведения в журнале системных событий". А там - "Служба apache22 завершена из-за внутренней ошибки". В журнале событий "Приложение" - Apache service reported the following error >>> (крякозябры, декодируемые как "доступа к адресу памяти").
В error.log пусто.
   Провинциальный 1сник
 
5 - 30.09.18 - 23:31
ОС - Windows Server 2003R2 x64 со всеми апдейтами. 1c и апач - 32-разрядные.
   kittystark
 
6 - 01.10.18 - 05:03
   Провинциальный 1сник
 
7 - 01.10.18 - 06:59
(6) Это я читал. Там не решена проблема.
   Amra
 
8 - 01.10.18 - 07:17
(7) Показывай с каким путем к длл работает, а с каким не работает
   Провинциальный 1сник
 
9 - 01.10.18 - 07:33
(8)
Работает:
LoadModule _1cws_module "C:/Program Files (x86)/1cv8/8.3.10.2699/bin/wsap22.dll"

Не работает:
LoadModule _1cws_module "C:/Program Files (x86)/1cv8/8.3.13.1513/bin/wsap22.dll"

С 8.3.11 не работает аналогично.
   Amra
 
10 - 01.10.18 - 07:38
(9) Попробуй снести 2.2 и поставить 2.4. Можно даже х64. Ну и переопубликуй базы
 
 Рекламное место пустует
   Провинциальный 1сник
 
11 - 01.10.18 - 07:42
(10) Непонятно где найти 2.4, собранные для 2003 сервера. Нашел где-то древнюю версию 2.4.4 - но она вообще игнорирует публикацию 1с, вместо обращения к модулю тупо открывается каталог. А более новые все собраны минимум под VC11, а это соответственно минимум виста..
   pavig
 
12 - 01.10.18 - 08:29
(0)
IIS не подходит?
   arsik
 
13 - 01.10.18 - 08:32
(11) Ну видимо просто настало время апгрейда софта.
   Провинциальный 1сник
 
14 - 01.10.18 - 08:58
(12) Вряд ли древний iis из 2003 года будет лучше работать. С апачем не было проблем, с разными версиями, начиная с 8.2. Думаю, проблема очень глубоко в потрохах 1с, в том самом с++ stl, который был заменен в 8.3.11 в целях облегчения сборки под новые ОС. И глюки, тормоза, несовместимости со старым софтом однозначно вызваны этим. И как быть непонятно. Апгрейд софта - это огромные затраты в условиях кризиса, не потянем.
   pavig
 
15 - 01.10.18 - 09:21
(14)
Вы даже не пробовали.
"Вряд ли" и "По факту" - таки разные вещи)
   Провинциальный 1сник
 
16 - 01.10.18 - 09:23
(15) Нашел на просторах интернета апач 2.2.34 x64, установил 64-разрядную платформу на сервер, вроде работает. Правда, сервер 1с оставил 32-разрядный, ибо ключ такой.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует