Вход | Регистрация


Достать емаил активных пользователей с определенной ролью

Достать емаил активных пользователей с определенной ролью
Я
   Shoot3D
 
28.09.18 - 13:06
Собственно сабж
Пока достаю пользователей с ролью через 
ТаблицаЗначений = Новый ТаблицаЗначений;                                        //Получаем список пользователей

    ТаблицаЗначений.Колонки.Добавить("Пользователь");                                            //с ролью <кадровик>

    ТаблицаЗначений.Колонки.Добавить("ЕстьРоль");
    Роль = "Кадровик";
     
    Для Каждого Строчка Из ПользователиИнформационнойБазы.ПолучитьПользователей() Цикл
    
        СтрТЗ = ТаблицаЗначений.Добавить();
        СтрТЗ.Пользователь     = Справочники.Пользователи.НайтиПоНаименованию(Строчка.Имя);
        СтрТЗ.ЕстьРоль        = Строчка.Роли.Содержит(Метаданные.Роли.Кадровик);
        Если СтрТЗ.ЕстьРоль Тогда
            Сообщить("У пользователя: " + СтрТЗ.Пользователь + " есть эта роль!");
        КонецЕсли;
    КонецЦикла;     

И емаилы через 

Запрос = Новый Запрос;                            //Получаем е-маил пользователей

    Запрос.Текст =     "ВЫБРАТЬ
    |    Пользователи.КонтактнаяИнформация.(
    |        АдресЭП КАК АдресЭП
    |    ) КАК КонтактнаяИнформация
    |ИЗ
    |    Справочник.Пользователи КАК Пользователи  ";
    //|ГДЕ   ;

    //|    Пользователи.Наименование = &Наименование";

    ПочтаЮзера=новый ТаблицаЗначений;
    
    ПочтаЮзера = Запрос.Выполнить().Выгрузить();
    Для Каждого ТекущаяСтрока Из ПочтаЮзера Цикл
        Сообщить(АдресЭП);
    КонецЦикла;
Как можно их скрестить?
 
 
   1Сергей
 
1 - 28.09.18 - 13:08
ТЗ можно в запрос передать

Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует