Вход | Регистрация


Присоединение области

[Волшебник, 28.09.18 - 11:13]
Присоединение области
Я
   Альбатрос
 
28.09.18 - 11:11
Втупляю

Выборка = Результат.Выбрать();
    н = 1;
    Присоединять = Ложь;
    Область = Макет.ПолучитьОбласть("ОбластьПечати");
    Пока Выборка.Следующий() цикл
        
        
        Область.Параметры.Заполнить(Выборка);
        Если Присоединять Тогда
            ТабДок.Присоединить(Область);
            Присоединять = ложь;
        Иначе
            ТабДок.Вывести(Область);
            Присоединять = Истина;
        КонецЕсли;
        Если н = 12 тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
            н = 0;
        КонецЕсли;
        н = н + 1;
    КонецЦикла;
    
    Возврат ТабДок;


Какого черта он не присоединяет, а выводит область одну за одной?
 
 
   dka80
 
1 - 28.09.18 - 11:14
Потому что чтобы что-то присоединить к чему-то, нужно это "чему-то" сначала вывести, а у тебя ТабДок.Вывести() нет
   dka80
 
2 - 28.09.18 - 11:14
упс. извини. не увидел
   dka80
 
3 - 28.09.18 - 11:17
Попробуй определить область как 
Область = Макет.ПолучитьОбласть("ОбластьПечатиСтроки|ОбластьПечатиСтолбцы");
   catena
 
4 - 28.09.18 - 11:23
Присоединяемая область должна быть ограничена справа.
   Альбатрос
 
5 - 28.09.18 - 11:35
(3) Спасибо
(4) В сп это не прописано, но действительно так. Спасибо.
   catena
 
6 - 28.09.18 - 12:43
(5)Там написано " правее самой правой выведенной колонки")))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует