Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Сравнение значения поле формы.

Сравнение значения поле формы.
Я
   igand73
 
27.09.18 - 15:43
Добрый день.
Уперся в проблему и ни как не подается. На форме есть поле ввода, путь к данным объект.ТипРасхода Он в свою очередь ссылается на перечисления. ТипРасхода. Мне нужно сравнить выбранное значение и в зависимости от значения будут происходить действия.
&НаСервереБезКонтекста
Функция  ТипРасходаОбработкаВыбораНаСервере()
    // Вставить содержимое обработчика.

    Возврат Перечисления.СтРасходы.Аванс
КонецФункции

&НаКлиенте
Процедура ТипРасходаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    СрРасхода = ТипРасходаОбработкаВыбораНаСервере();
    СрРасхода2 = Объект.ТипРасхода;
    Если СрРасхода2 = СрРасхода тогда
        Элементы.Сотрудник.Видимость = истина;
    КонецЕсли;
КонецПроцедуры

Через точку останова видно что СрРасхода получает значение, а СрРасхода2 пустое.
Подскажите, что может быть?
 
 
   singlych
 
1 - 27.09.18 - 15:58
ОбработкаВыбора (ChoiceProcessing)
.....
Описание:

Вызывается после осуществления выбора, но до помещения выбранного значения в элемент управления.

Сравнивай с ВыбранноеЗначение.
   Лефмихалыч
 
2 - 27.09.18 - 15:59
ты значение возвращаешь в одну переменную, а сравниваешь потом с другой, которая не объявлена
   Лефмихалыч
 
3 - 27.09.18 - 16:00
и есть функция ПредопределенноеЗначение(), которую надо использовать в таких ситуациях вместо своих этих рукопильных ТипРасходаОбработкаВыбораНаСервере()
   igand73
 
4 - 27.09.18 - 16:27
Спасибо.
Но я пробовал предопределенное знаяение
{Документ.ДвижениеДенег.Форма.ФормаДокумента.Форма(6,53)}: Переменная не определена (Перечисления)
        если ВыбранноеЗначение = ПредопределенноеЗначение(<<?>>Перечисления.СтРасходы.Аванс) тогда (Проверка: Тонкий клиент)
   s03
 
5 - 27.09.18 - 16:38
(4) ПредопределенноеЗначение(ПеречислениЕ...
   AneJIbcuH
 
6 - 27.09.18 - 16:47
(4) криво попробовал. Там случайно не в кавычках?
   AneJIbcuH
 
7 - 27.09.18 - 16:48
(5) ПредопределенноеЗначение("ПеречислениЕ....")
   igand73
 
8 - 27.09.18 - 17:32
{Документ.ДвижениеДенег.Форма.ФормаДокумента.Форма(6,53)}: Переменная не определена (Перечисление)
        если ВыбранноеЗначение = ПредопределенноеЗначение(<<?>>Перечисление.СтРасходы.Аванс) тогда (Проверка: Тонкий клиент)
   igand73
 
9 - 27.09.18 - 17:32
Без ковычек конечно
   Cool_Profi
 
10 - 27.09.18 - 17:33
Синтаксис:

ПредопределенноеЗначение(<ИмяПредопределенногоЗначения>)
Параметры:

<ИмяПредопределенногоЗначения> (обязательный)

Тип: Строка.
Содержит полный путь до предопределенного значения, включая имя самого значения. Например, "ПланСчетов.Основной.Счет41".
 
 Рекламное место пустует
   AneJIbcuH
 
11 - 27.09.18 - 19:14
(8) Уже все написали, кроме (9) - вводит в заблуждение.
Если ВыбранноеЗначение = ПредопределенноеЗначение("Перечисление.СтРасходы.Аванс") Тогда
   igand73
 
12 - 28.09.18 - 07:05
Получилось спасибо. Объясните пожалуйста почему перечисление.... в кавычках?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует