Вход | Регистрация


Как добавить реквизит табличной части внешнеобработки в проверку заполнения ?

Как добавить реквизит табличной части внешнеобработки в проверку заполнения ?
Я
   gabd_marat
 
27.09.18 - 10:18
Как добавить реквизит табличной части внешней обработки в проверку заполнения?

Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
    Если  Маршрутки.Количество() Тогда
        Если  Маршрутки[0].Номенклатура =  Справочники.Номенклатура.НайтиПоКоду("0000063079").Ссылка   и ЭлементыФормы.ТаблСостояний.ТекущиеДанные.Состояние = Справочники.Состояния.НайтиПоКоду("57")
            и ЭлементыФормы.ТаблОпераций.ТекущиеДанные.ВидОперации = Перечисления.ВидыОпераций.Изготовление  Тогда
            ПроверяемыеРеквизиты.Добавить("Маршрутки.СостояниеВходногоКонтроля");
        Иначе
            МаршруткиСостояниеВходногоКонтроля = ПроверяемыеРеквизиты.Найти("Маршрутки.СостояниеВходногоКонтроля"); 
            Если МаршруткиСостояниеВходногоКонтроля <> Неопределено Тогда
                ПроверяемыеРеквизиты.Удалить(МаршруткиСостояниеВходногоКонтроля);
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Процедура ЗаписатьДанные()
    
    Если Не ЭтотОбъект.ПроверитьЗаполнение() Тогда
        Возврат;
    КонецЕсли;
        
КонецПроцедуры
 
 
   gabd_marat
 
1 - 27.09.18 - 10:18
Так не работает
   Гипервизор
 
2 - 27.09.18 - 10:27
Свойство реквизита "Проверка заполнения" установить в значение "Выдавать ошибку".
В коде: Если Не ПроверитьЗаполнение() Тогда..
   gabd_marat
 
3 - 27.09.18 - 10:45
(2) Как обратиться к свойству реквизита табличной части?
   Вафель
 
4 - 27.09.18 - 10:46
если нужно в конкретной строке, то просто делай сообщить и отказ устанавливай.
А проверяй кодом
   Cyberhawk
 
5 - 27.09.18 - 10:49
Что, за почти 10 лет так и не исправили?
   Вафель
 
6 - 27.09.18 - 10:52
(5) что не исправили?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует