Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Скопировал рабочую базу к себе, у меня ошибка. На рабочей все работает... Что не так?

Скопировал рабочую базу к себе, у меня ошибка. На рабочей все работает... Что не так?
Я
   SkillUp
 
26.09.18 - 15:15
Скопировал рабочую базу к себе, у меня ошибка. На рабочей все работает... Что не так?

Код, на который выдает ошибку (часть кода):

&НаКлиенте
Процедура СписокВыполненияВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
          
    СтандартнаяОбработка = Ложь;
    Если ТипЗнч(ВыбраннаяСтрока) <> Тип("РегистрСведенийКлючЗаписи.ВыполенияЗаданий") Тогда
        Возврат;    
    КонецЕсли;
    Рег = РегистрыСведений.ВыполенияЗаданий.Получить(Новый Структура("Клиент,Задание,КоммерческоеПредложение",ВыбраннаяСтрока.Клиент,ВыбраннаяСтрока.Задание,ВыбраннаяСтрока.КоммерческоеПредложение));
    Если Рег.Выполнено или Рег.Завершено Тогда
        Если Вопрос("Этот клиент уже обработан ИЛИ задание отменено. Открыть на просмотр?", РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет  Тогда
            Возврат;
        КонецЕсли; ;
    КонецЕсли;
    Если ВыбраннаяСтрока.Задание.ТипЗадания=ПредопределенноеЗначение("Перечисление.ПМ_ТипыЗаданийАктуализатору.Актуализировать") Тогда
        //подготовим кеш

        ПМ_Лига.ПодготовитьКеш(ВыбраннаяСтрока.Задание);
        Об=ВыбраннаяСтрока.Клиент.ПолучитьОбъект();
        П = Новый Структура("Ключ,Задание", ВыбраннаяСтрока.Клиент,ВыбраннаяСтрока.Задание);
        
        
        Если ПараметрыСеанса.ТекущийПользователь.ИспользоватьКомплекснуюФормуКлиента3в1 = Истина Тогда
            Форм=ОткрытьФорму("Справочник.ПМ_Клиенты.Форма.КомплекснаяФорма3в1",П);
        Иначе
            Форм=ОткрытьФорму("Справочник.ПМ_Клиенты.Форма.ФормаАктуализации",П);
        КонецЕсли;


Сама ошибка:


{Задача.ЗадачаИсполнителя.Форма.ЗадачиАктуализатораДляРабочегоСтола.Форма(180,8)}: Переменная не определена (РегистрыСведений)
    Рег = <<?>>РегистрыСведений.ВыполенияЗаданий.Получить(Новый Структура("Клиент,Задание,КоммерческоеПредложение",ВыбраннаяСтрока.Клиент,ВыбраннаяСтрока.Задание,ВыбраннаяСтрока.КоммерческоеПредложение));
{Задача.ЗадачаИсполнителя.Форма.ЗадачиАктуализатораДляРабочегоСтола.Форма(193,8)}: Переменная не определена (ПараметрыСеанса)
        Если <<?>>ПараметрыСеанса.ТекущийПользователь.ИспользоватьКомплекснуюФормуКлиента3в1 = Истина Тогда
{Задача.ЗадачаИсполнителя.Форма.ЗадачиАктуализатораДляРабочегоСтола.Форма(223,9)}: Переменная не определена (ПараметрыСеанса)
            Если <<?>>ПараметрыСеанса.ТекущийПользователь.ИспользоватьКомплекснуюФормуКлиента3в1 = Истина Тогда

Сталкивался ли кто-то с подобной ситуацией?
 
 
   Вафель
 
1 - 26.09.18 - 15:16
и это все на клиенте? как это вообще работало?
   Вафель
 
2 - 26.09.18 - 15:17
хотя может рабочая запускается в режиме толстый клиент уф
   SkillUp
 
3 - 26.09.18 - 15:17
(2) Сейчас проверю....
   SkillUp
 
4 - 26.09.18 - 15:18
(2) Нет, не в этом дело...
   SkillUp
 
5 - 26.09.18 - 15:19
(1) Да, это на клиенте.
   SkillUp
 
6 - 26.09.18 - 15:20
(1) Как работало? Да просто у пользователя открывалось пользовательское приложение и все... А у меня выдает ошибку эту ,под любым пользователем...
   SkillUp
 
7 - 26.09.18 - 15:23
Переменная не определена (РегистрыСведений)
    
Что-то я не понимаю...
   Вафель
 
8 - 26.09.18 - 15:24
(7) загляни в СП и увидь, что на тонком клиенте это не доступно
   s03
 
9 - 26.09.18 - 15:25
(6) проверь, в каком режиме работают пользователи с рабочей базой
   Флориан
 
10 - 26.09.18 - 15:25
"ВыполенияЗаданий" - бггг...
 
 Рекламное место пустует
   Малыш Джон
 
11 - 26.09.18 - 15:26
(0) запускаешь в автоматическом режиме, а там откуда копировал, толстый клиент стоял?
   SkillUp
 
12 - 26.09.18 - 15:29
Да, вот сейчас проверяю!!!
   Фрэнки
 
13 - 26.09.18 - 15:30
(7) может в строке запуска на пользователе там прописан толстый клиент, а тебе этого не видно?
   SkillUp
 
14 - 26.09.18 - 15:30
(11) Да, ДЕЛО БЫЛО В ЭТОМ.
   SkillUp
 
15 - 26.09.18 - 15:30
СПАСИБО!!!
   SkillUp
 
16 - 26.09.18 - 15:31
(8) Да, просмотрел, спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует