Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Проблема с модальной формой в web интерфейсе

Проблема с модальной формой  в web интерфейсе
Я
   9451523
 
26.09.18 - 12:43
Помогите с кодом пожалуйста, не получается исправить код для работы через веб клиент вот код:

&НаКлиенте
Процедура ИмяФайлаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    #Если ВебКлиент Тогда 

    Если Не ПодключитьРасширениеРаботыСФайлами() Тогда 
    УстановитьРасширениеРаботыСФайлами();
    ПодключитьРасширениеРаботыСФайлами();
    КонецЕсли;
    #КонецЕсли

        
    диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    диалог.МножественныйВыбор = Ложь;
    диалог.Заголовок = "Выберите прикрепляемый файл";
    Если диалог.Выбрать() Тогда
        файл = Новый Файл(диалог.ПолноеИмяФайла);
        Запись.ИмяФайла = файл.Имя;
        ЗагрузитьФайл(ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(файл.ПолноеИмя)));
        Элементы.ОткрытьФайл.Видимость = Истина;
        Если Не РольДоступнаПолныеПрава() Тогда
            Попытка
                ЭтаФорма.ВладелецФормы.Родитель.Элементы.Список.Обновить();
            Исключение
                
            КонецПопытки;
            ЭтаФорма.Закрыть();
        КонецЕсли; 
    КонецЕсли;
КонецПроцедуры

ругается на использование модальных окон, в инете есть много примеров но ни один толком не подходит все примеры с добавлением нескольких файлов а мне нужно прикреплять только один файл
 
 
   Вафель
 
1 - 26.09.18 - 12:44
диалог.Показать()
   9451523
 
2 - 26.09.18 - 12:45
я так понял вместо диалог.Выбрать?
   tesseract
 
3 - 26.09.18 - 12:47
(0) НачатьПомещениеФайла(<ОписаниеОповещенияОЗавершении>, <Адрес>, <НачальноеИмяФайла>, <Интерактивно>, <УникальныйИдентификаторФормы>) 

<Интерактивно> = Истина;

Не работает только на мобильной платформе.
   Вафель
 
4 - 26.09.18 - 12:49
если 1 и без фильтра, то проще (3)
   9451523
 
5 - 26.09.18 - 12:49
блин нужно чтобы на планшете открывал

Список тем форума
Рекламное место пустует  Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует