Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Загрузка из ДБФ. Как написать условие, чтобы создавался 1 документ и в нем было 5 строк?

v7: Загрузка из ДБФ. Как написать условие, чтобы создавался 1 документ и в нем было 5 строк?
Я
   Work1
 
26.09.18 - 12:37
Есть ДБФ и 5 строк
2     инфо1
2     инфо2
2     инфо3
2     инфо4
2     инфо5
Где 2 номер документа  инфо это название услуги подскажите как написать условие если  чтобы создавался 1 документ и в нем было 5 строк
 
 
   Волшебник
 
1 - 26.09.18 - 12:37
Пригласите программиста.
   Work1
 
2 - 26.09.18 - 12:41
Может кто подскажет
   Work1
 
3 - 26.09.18 - 12:42
Файл.Первая(); 
Пока Файл.ВКонце()=0 Цикл
    Если  Число(ТабЗнач.НомерДок)=СокрЛП(Файл.ND) Тогда

        
        КонецЕсли;
    
    
 Файл.Следующая();
КонецЦикла;
   Work1
 
4 - 26.09.18 - 12:42
Создает 5 доков
   Карст
 
5 - 26.09.18 - 12:56
Создавай документ ДО начала цикла
   Карст
 
6 - 26.09.18 - 12:56
а заполняй в цикле
   uno-group
 
7 - 26.09.18 - 13:17
В цикле
Если текНомерДок<>ДБ.Номер тогда
ЕСли теНомеркДок<>"" тогда
Док.записать();
КонецЕсли;
текНомерДок=ДБ.Номер;
Док.новый();
ДокюНомерДок=ДБ.Номер;
КонецЕСли;
док.новаяСтрока();
...
КонецЦикла;
ЕСли теНомеркДок<>"" тогда
Док.записать();
КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует