Вход | Регистрация



Если Истина/Ложь Тогда

Если Истина/Ложь Тогда
Я
   prtx
 
25.09.18 - 17:18
Добрый вечер.

Встретил я такую конструкция и хочу у знатоков уточнить правильность мыслей моих.

Конструкция 1 - Если Ложь Тогда
Данное чудо мысли мы используем в функция, например есть функция в ее параметры мы передаем какой-то объект, и в начале функции пишем что-то типа:
Если Ложь Тогда
 Док = Документы.ПоступлениеДопРасходов.СоздатьДокумент();
КонецЕсли;

и дольше мы можем юзать контекстную подсказку со свойствами нашего параметры, так?

Конструкция 2 - Если Истина Тогда
Сие чудо человеческой мысли мы используем для того, что бы не юзать области, и сворачивать куски кода, так?

Просто, просто прошу четких ответов или пояснений, для себя и будущих поколений! Всем спасибо!
 
 
   Cool_Profi
 
1 - 25.09.18 - 17:20
1. да, но надо не забывать в продакшене удалять такое.
2. Можно и так.
   PR
 
2 - 25.09.18 - 17:20
42!
   Cyberhawk
 
3 - 25.09.18 - 17:21
Для контекстной подсказки лучше использовать некомпилируемый вариант

#Если Сервер И Не Сервер Тогда

#КонецЕсли
   prtx
 
4 - 25.09.18 - 17:23
(1) а у конструкции 2, есть еще какие-то "волшебные" свойства и/или полезные свойства? а то. я тут залез в код 2015-х годов, а тут такое творится...
   Вафель
 
5 - 25.09.18 - 17:24
(3) чем лучше? тут нужно язык переключать 2 раза
   Cool_Profi
 
6 - 25.09.18 - 17:25
(4) Если внезапно заменить истина на ложь, то не нужно будет комментировать кусок кода
   Cool_Profi
 
7 - 25.09.18 - 17:25
(5) Поставь волшебную программку и волшебный набор шаблонов и не надо будет.
   prtx
 
8 - 25.09.18 - 17:26
(2) это типа порядковый номер подобной темы? плиз дать ссылки на другие темы, а то гугли, и кроме 2-3 тем нифига не нашел, и то там срач.
   Cyberhawk
 
9 - 25.09.18 - 17:26
(5) Шаблоны текста спасают
   prtx
 
10 - 25.09.18 - 17:27
(6) сомнительный варик, потом ищи где начало, где конец.
 
 Рекламное место пустует
   Cyberhawk
 
11 - 25.09.18 - 17:27
Ну а лучше хоты бы тем, что ты видишь такой кусок, в отличие от обычного Если
   Вафель
 
12 - 25.09.18 - 17:27
(7) за нее еще платить нужно
   Cyberhawk
 
13 - 25.09.18 - 17:28
А еще лучше тем, что его можно использовать везде, в отличие от обычного "Если"
   Вафель
 
14 - 25.09.18 - 17:28
(13) а где нельзя если?
   prtx
 
15 - 25.09.18 - 17:29
(7) А ЧТО ЗА ПРОГРАМКА?
   Вафель
 
16 - 25.09.18 - 17:29
кстати "волшебная программа" умеет типы из описания выводить, так что там такое не нужно
   Cool_Profi
 
17 - 25.09.18 - 17:30
(12) У меня стоит бесплатная
   Cool_Profi
 
18 - 25.09.18 - 17:30
   BMW1C
 
19 - 25.09.18 - 17:31
Можно это дело автоматизировать

http://turboconf.ru/content/Images/TypeDeclaration1.gif
   Cyberhawk
 
20 - 25.09.18 - 17:32
(14) Вне тела метода
   Вафель
 
21 - 25.09.18 - 17:33
(19) Эххх. Я думал ты используешь описания функций
   Serg_1960
 
22 - 25.09.18 - 17:34
(3) +1 и не надо 1. из (1)
   BMW1C
 
23 - 25.09.18 - 17:36
(21) пробовали и так и так.
Решили, что этот метод удобнее.
   BMW1C
 
24 - 25.09.18 - 17:37
(19) Так же можно сделать автоматическое удаление таких конструкций, когда они больше не нужны.
   Сияющий Асинхраль
 
25 - 25.09.18 - 17:38
Конструкцию 1 я изредка использую для комментирования кусков текста, которые пока не готов удалить...
   ЕщеОдинПрограммист
 
26 - 25.09.18 - 17:46
(5) Не нужно переключать клавиатуру, нажимай Alt+35 (35 - на правой клавиатуре) - будет решетка. Еще: 60 - меньше, 62 - больше, 38 - амперсанд, 91/93 - [] и тд. На всех виндах работает.
   Cyberhawk
 
27 - 25.09.18 - 17:46
(25) Почему просто не комментируешь?
   Cyberhawk
 
28 - 25.09.18 - 17:47
(26) Гемор. Свои шаблоны текста один раз добавить и пользоваться куда проше.
   Вафель
 
29 - 25.09.18 - 17:51
(26) я такое не запомню никогда
   Timon1405
 
30 - 25.09.18 - 17:52
(0) использую шаблон 2=1
 Если 2=1 Тогда <?"Переменная = "> = <?><?"Выберите тип", ВыборТипа>.ПустаяСсылка() КонецЕсли;

*остается в выбранной строке 

Если 2=1 Тогда Док = ДокументСсылка.ПоступлениеТоваровУслуг.ПустаяСсылка() КонецЕсли; 

поменять "ДокументСсылка" на "Документы"
как автоматизировать этот кусок не знаю
   Сияющий Асинхраль
 
31 - 25.09.18 - 17:56
(27) Ну не люблю я большие куски зеленого цвета :-( , напрягают они меня...
   МимохожийОднако
 
32 - 25.09.18 - 18:01
(28) Горячие клавиши для шаблонов тоже надо запоминать. А листочек с кодами символов тоже можно распечатать. ))
   Cyberhawk
 
33 - 25.09.18 - 18:03
(32) Не клавиши, а набираемый на клавиатуре текст.
У меня для такой конструкции задан текст "\_". Свои собственные конструкции - если ты пользуешься ими часто - никаких проблем запомнить не вызывает
 
 
   Tonik992
 
34 - 25.09.18 - 20:33
(19) Не надо автоматизировать, давно уже существует Enterprise Development Tools
   Сияющий Асинхраль
 
35 - 26.09.18 - 17:08
(34) А ты перед тем как советовать пробовал на этом самом EDT поработать серьезно?
   Гипервизор
 
36 - 26.09.18 - 17:13
Еще забыли раскладку Чистова. И переключаться не надо.
   Cyberhawk
 
37 - 26.09.18 - 17:15
Раскладу не в каждом терминале заказчика установишь. А вот файл с шаблонами текста - в каждом (куда есть возможность передать текстовый файлик).
   Новиков
 
38 - 26.09.18 - 18:02
(26) Вообще красавчег! Распечатал себе :)

Кстати про турбоконфы, снегопаты и прочее. Вродь народ петицию там пишет - чота поломалось в 12-ом релизе, и теперь вроде как что-то у этих инструментов тоже поломалось. Хотя это на дворе - бабка сказал, сам не в теме, объяву разместил о мопеде токма.
   unregistered
 
39 - 26.09.18 - 19:19
(38) > Кстати про турбоконфы, снегопаты и прочее

Ерунда всё это. Подобные проекты живы только до тех пор пока интересны своим авторам. Как только у автора пропадает желание или мотивация к дальнейшему развитию (а уж тем более к поддержке и сопровождению) проект умирает.
И это не говоря о рисках, связанных с тем, что в любой момент в очередной версии платформы может измениться что-то, что повлечет за собой неработоспособность подобных плагинов. А так же о сомнительности тех преимуществ, которые они дают.
   SweetaAngel
 
40 - 26.09.18 - 21:05
(0) Еще вариант когда нужно структурировать код со множеством вложений. Например XML.

Если Ложь Тогда//Узел документ

    Если Ложь Тогда//Узел Поставщик

      Если Ложь Тогда//Узел адрес поставщика


      КонецЕсли;
    КонецЕсли;
    Если Ложь Тогда//Узел Покупатель

      Если Ложь Тогда//Узел адрес покупателя


      КонецЕсли;
    КонецЕсли;
    Если Ложь Тогда//Узел Товары

      Если Ложь Тогда//Узел строка товара


      КонецЕсли;
    КонецЕсли;
    Если Ложь Тогда//Узел автора документа


    КонецЕсли;
КонецЕсли;
   Cyberhawk
 
41 - 26.09.18 - 21:27
(40) Жесть какая. И это только ради возможности свернуть-развернуть кусок кода?
   SweetaAngel
 
42 - 27.09.18 - 05:34
(41) Нет. Так проще следить за структурой, что куда входит.
   assasu
 
43 - 27.09.18 - 05:58
(0) это выдерка из другого кода.
где то было написано Если Переменная = Значение тогда
код был выдернут и приспособлен под текущие нужды.
в текущем варианте нет Переменная и поэтому поставили Ложь.
   Cyberhawk
 
44 - 27.09.18 - 09:13
(42) Если не используется сворачивание блоков "Если", то чем они лучше обычных комментариев?
   Cyberhawk
 
45 - 27.09.18 - 09:14
Типа автоматические отступы, такЕ?
   dmpl
 
46 - 27.09.18 - 09:19
(31) Цвет комментариев меняется в настройках Конфигуратора.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует