Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УФ ЗУП 3 Ведомость

УФ ЗУП 3 Ведомость
Я
   Homer
 
25.09.18 - 09:39
редко работаю на УФ
Внешней обработкой пересчитываю выплаты, после отработки обработки, визуально не меняется сумма начисления, после записи документа, все появляется.
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения) Экспорт
    
    Если ИдентификаторКоманды = "ЗаполнитьДокумент" Тогда
        Режим = РежимДиалогаВопрос.ДаНет;
        Оповещение = Новый ОписаниеОповещения("ПослеОтветаНаВопросОЗаполненииТЧ", ЭтаФорма, Параметры);
        ПоказатьВопрос(Оповещение, "Обработать табличную часть?", Режим, 0); 
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ПослеОтветаНаВопросОЗаполненииТЧ(Результат, Параметры) Экспорт
    
    Если Результат = КодВозвратаДиалога.Нет Тогда
        Возврат;
    КонецЕсли;
    
    Если Не ВладелецФормы = Неопределено Тогда
        НовыйОбъект = ВладелецФормы.Объект;
        
        ЗаполнитьТЧСервер(НовыйОбъект);
        КопироватьДанныеФормы(НовыйОбъект, ВладелецФормы.Объект);
        
        Сообщение = Новый СообщениеПользователю();
        Сообщение.Текст = "Табличная часть обработана!!!";
        Сообщение.Сообщить();
        
    КонецЕсли;
    
    ВладелецФормы.Объект.Комментарий = ВладелецФормы.Объект.Комментарий + " @Обработан";
    Модифицированность = Ложь;
    ОтобразитьИзменениеДанных(НовыйОбъект.Ссылка, ВидИзмененияДанных.Изменение);
    ОповеститьОбИзменении(НовыйОбъект.Ссылка);
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьТЧСервер(НовыйОбъект) Экспорт 
    Запрос = Новый Запрос;
    Запрос.Текст = ПолучитьЗапрос();
    Запрос.УстановитьПараметр("Дата", НачалоМесяца(НовыйОбъект.ПериодРегистрации) + 14*24*3600);//Дата

    Запрос.УстановитьПараметр("Зарплата", НовыйОбъект.Зарплата.Выгрузить());//Ведомость в банк

    
    мТаб = Запрос.Выполнить().Выгрузить();
    
    Для Каждого Строка из НовыйОбъект.Зарплата Цикл
        ЗаполнитьЗначенияСвойств(Строка,мТаб.Получить(Строка.НомерСтроки - 1));
    КонецЦикла;
КонецПроцедуры

&НаСервере
Функция ПолучитьЗапрос()
 
 
   SleepyHead
 
1 - 25.09.18 - 09:45
(0) Какую задачу решаешь, пересчитывая выплаты, и чем не устраивает типовой алгоритм?
   SleepyHead
 
2 - 25.09.18 - 09:46
(0) Возможно, не все нужнгые ТЧ заполняешь, проверь, обновляется ли ТЧ Состав, соответствуют ли идентификаторы этой ТЧ идентификаторм в ТЧ Зарплата и так далее.
   Homer
 
3 - 25.09.18 - 09:47
(1) Пересчет аванса с учетом отклонений
   SleepyHead
 
4 - 25.09.18 - 09:49
(3) Но ведь 1с сама это делает, если сначала рассчитать ЗП за первую половину месяца?
   Homer
 
5 - 25.09.18 - 09:53
(4) не подходит), этим мы тоже пользуемся
(2) нет там больше нужных таблиц
   SleepyHead
 
6 - 25.09.18 - 09:54
(5) Да, я две основные назвал. Но ответ тот же - нужно проверять соответствие идентификаторов и не забыть потом скопировать новые данные в табличные данные формы.
   Homer
 
7 - 25.09.18 - 10:04
ТЧ Состав - там ни чего нет, при отработки обработки, подвал пересчитывается! при расшифровки строки, так же вижу новую сумму. Комментарий обновляется!
   SleepyHead
 
8 - 25.09.18 - 11:03
(7) "ТЧ Состав - там ни чего нет, "

Ну так заполнять значит надо самому. В этой ТЧ должны быть перечислены физлица, которые затем входят ТЧ Зарплата и НДФЛ.
   Homer
 
9 - 25.09.18 - 11:14
(8) я имел ввиду там, не чего интересно нет, там все заполнено. Моя обработка обрабатывает уже текущий данные, и не перезаписывает только сумму
   MuxaH
 
10 - 25.09.18 - 11:20
Там реквизит КВыплате, который на форме пользователю показывается, это именно реквизит формы, а не объекта. Ты его в обработке своей тоже меняешь?
 
 Рекламное место пустует
   Homer
 
11 - 25.09.18 - 12:19
(10)все нашел, поправил,
как теперь сделать Модифицированность = Истина
   Homer
 
12 - 25.09.18 - 12:26
все нашел

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует