Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: ККМ штрих отразить услуги

v7: ККМ штрих отразить услуги
Я
   knopik777
 
22.09.18 - 15:58
Друзья, есть Штрих-on-Line все настроено все работает, есть необходимость добавить отражение услуг. Сейчас в чеке ниже описания товара выводится поле с цифрой 1, а ниже слово товар.
Скажите как отразить услугу. Секциями или чем и как?
Поиском не нашел.
 
 
   Звездец
 
1 - 22.09.18 - 16:33
признаком предмета расчета. Читай описание ФФД 1.05, а потом руководство программиста драйвера
   kupec
 
2 - 24.09.18 - 10:33
(0) Разобрались?
   knopik777
 
3 - 24.09.18 - 15:11
(2) нет. Ищю варианты и примеры
   Kigo_Kigo
 
4 - 24.09.18 - 15:41
А чем продажа товара и продажа услуги отличается по сути пробития чека?
   kupec
 
5 - 24.09.18 - 16:33
(4) тем что указываешь разные параметры при формировании продажи
   kupec
 
6 - 24.09.18 - 16:33
//*****************************************************************************************

//PaymentItemSign ПризнакПредметаРасчета
//Признак прдемета расчета. Возможные значения:

//1. Товар
//2. Подакцизный товар

//3. Работа
//4. Услуга

//5. Ставка азартной игры
//6. Выигрыш азартной игры

//7. Лотерейный билет
//8. Выигрыш лотереи

//9. Предоставление РИД
//10. Платеж

//11. Составной предмет расчета
//12. Иной предмет расчета


//печатаем чек

//ПРОДАЖА

ПроцедураПодключенияК_ККМ();

ФР.Password=ПарольКассира;
ФР.CheckType=0;
ФР.OpenCheck();
//передача адреса для отправки на EMAIL                

Если СокрЛП(Документ.АдресОтправкиЧека)<>"" Тогда
    ФР.CustomerEmail=СокрЛП(Документ.АдресОтправкиЧека);
    ФР.FNSendCustomerEmail();                       
КонецЕсли;
Документ.ВыбратьСтроки();
Пока Документ.ПолучитьСтроку()=1 Цикл
    ФР.Password=ПарольКассира; 
    ФР.Quantity=Документ.Количество;
    ФР.Price=Документ.Цена;
    ФР.Department=1;
    ФР.PaymentTypeSign=1;
    Если Документ.Номенклатура.Услуга=1 Тогда
        ФР.PaymentItemSign=4; 
    Иначе
        ФР.PaymentItemSign=1; 
    КонецЕсли;    
    ФР.StringForPrinting=Документ.Номенклатура.Наименование;
    ФР.FNOperation();
КонецЦикла;
ФР.Password=30;                               
ФР.Summ1=Документ.СуммаПолученныхНаличных;
ФР.StringForPrinting="";
ФР.CloseCheckEX();

ПроцедураОтключенияОт_ККМ();
   Pit0n_08
 
7 - 24.09.18 - 17:05
(7) это код для Штриховых ККМ?
   victuan1
 
8 - 24.09.18 - 17:29
(7) Да.
   kupec
 
9 - 24.09.18 - 18:02
(7) только подкорректируй его под свои нужды

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует