Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

При активизации строки и список выбора...

При активизации строки и список выбора...
Я
   Cool_Profi
 
21.09.18 - 12:25
&НаКлиенте
Процедура ТЧ_ПриАктивизацииСтроки(Элемент)
    ТЧ_ПриАктивизацииСтрокиНаСервере(Элементы.ТЧ.ТекущаяСтрока);
КонецПроцедуры

&НаСервере
Процедура ТЧ_ПриАктивизацииСтрокиНаСервере(п_ИдентификаторСтроки);

    Если п_ИдентификаторСтроки=Неопределено Тогда
        Возврат;
    КонецЕсли;

    л_СписокВыбора = Элементы.ТЧИдТовара.СписокВыбора;
        л_СписокВыбора.Очистить();
/// тут дальше что-то

КонецПроцедуры

При вызове Очистить() 1с вылетает...
8.3.12.1595

На 8.3.11.3133 - работает.

УФ, такси, совместимость 8.3.10

Что я не так сделал?
 
 
   Lexey_
 
1 - 21.09.18 - 12:49
(0)
Примечание:
В обработчике данного события нельзя использовать серверные методы формы с директивой компиляции &НаСервере.
   Cool_Profi
 
2 - 21.09.18 - 12:52
(1) Тогда почему на 8,3.11 работает?
   Вафель
 
3 - 21.09.18 - 12:56
(2) работает, но нельзя
   Cool_Profi
 
4 - 21.09.18 - 12:58
Спасибо за напоминание...
Буду слегка переделать

Список тем форума
Рекламное место пустует  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует