Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как раскрасить не весь столбец табличного поля а только одну ячейку

↓ [Волшебник, 20.09.18 - 15:30]
Как раскрасить не весь столбец табличного поля а только одну ячейку
Я
   Быдло замкадное
 
20.09.18 - 15:11
Есть обработка, у нее табличная часть, она размещена на форме (форма не управляемая).
Получается мы имеем табличное поле (не путать с табличным документом).
Как раскрасить определенную ячейку этого поля?

У меня получилось раскрасить только определенный столбец
Процедура ПланПоМашинамПриПолученииДанных(Элемент, ОформленияСтрок)
    
    Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл 
        
        ОформлениеСтроки.Ячейки.День1.ЦветФона = WebЦвета.Красный;
        
    КонецЦикла;    
    
КонецПроцедуры

https://s8.hostingkartinok.com/uploads/images/2018/09/19325c66b1ce8dfad38bdd7fae878b29.jpg
 
 
   Быдло замкадное
 
1 - 20.09.18 - 15:11
мне нужно например покрасить ячейку 1 день - строка 3.
   Волшебник
 
2 - 20.09.18 - 15:12
Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл 
        
Если условие Тогда
        ОформлениеСтроки.Ячейки.День1.ЦветФона = WebЦвета.Красный;
Иначе
        ОформлениеСтроки.Ячейки.День1.ЦветФона = WebЦвета.Белый;
        
    КонецЕсли;    
        
    КонецЦикла;
   Вафель
 
3 - 20.09.18 - 15:12
наверно по условию нужно красить
   Михаил Козлов
 
4 - 20.09.18 - 15:12
Красьте по условию данных строки.
   Cool_Profi
 
5 - 20.09.18 - 15:13
Если ОформлениеСтроки.ДанныеСтроки.МоёПоле = МоёЗначение Тогда
//красим

КонецЕСли
   Быдло замкадное
 
6 - 20.09.18 - 15:15
отлично, спасибо. И почему поиск такого не выдавал!
   Cool_Profi
 
7 - 20.09.18 - 15:19
(6) Потому что голову поиск не индексирует. И думать не учит
   Волшебник
 
8 - 20.09.18 - 15:30
Ну тупые...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует