Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Обработка выбранного значения

v7: Обработка выбранного значения
Я
   FerGoSec
 
20.09.18 - 12:56
День добрый, форумчане. Давно не работал с 7.7 и что-то подзабыл, помогите кто чем может.
А проблема следующая, есть форма элемента справочника в нем поле подчиненного справочника. Если ничего не трогать то стандартная обработка при нажатии на ... просит заново выбрать элемент номенклатуры что-бы выбрать подчиненные ему(не передает в открываемую форму сама владельца). Решил исправить:

Процедура ПриНачалеВыбораЗначения(ВыдавшийОрган,ФлагСтандОбр)   
    ФлагСтандОбр = 0;
    ОткрытьФорму("Справочник.ОрганыСертификации1",,,,ТекущийЭлемент().Владелец);
КонецПроцедуры

Отлавливаю событие выбора моего реквизита, и открываю уже форму с нужным владельцем, но никак не могу отловить элемент который пользователь выбирает в этой форме, в процедуре ОбработкаВыбораЗначения отладчик просто не останавливается.

Подскажите как либо в стандартную обработку передать владельца, либо поймать выбранный элемент в моём случае
 
 
   kennetmccormick
 
1 - 20.09.18 - 12:59
в форме справочника органы сертификации владельца установть?
   1Сергей
 
2 - 20.09.18 - 13:01
(0) смотри в свойствах параметр "Связать с" или "Связан с", не помню точно
   FerGoSec
 
3 - 20.09.18 - 13:17
(1) Да я вызываю подчиненный справочник и в нем хочу что-бы отбор не надо было еще раз выбирать
   Kigo_Kigo
 
4 - 20.09.18 - 13:55
Процедура ПриОткрытии()

    ВнКонтекст = Форма.Параметр;
    
    Если ПустоеЗначение(ВнКонтекст)=0 Тогда
        ИспользоватьВладельца(ВнКонтекст);
    КонецЕсли;
    
    ИерархическийСписок(1,0);
    
КонецПроцедуры// ПриОткрытии()
   FerGoSec
 
5 - 20.09.18 - 14:16
(4) сначала спрашивает выбрать родителя, а только потом срабатывает процедура ПриОткрытии
   FerGoSec
 
6 - 20.09.18 - 14:17
(2) Мало что-информации по этому параметру, указываю там Владельца, ситуация не меняется, пойду еще читать
   Kigo_Kigo
 
7 - 20.09.18 - 15:19
(5) Это в форме списка для подбора
   FerGoSec
 
8 - 20.09.18 - 15:40
(7) я понял, я и говорю что сначала он просит выбрать номенклатуру, а только потом заходит в форму списка в событие ПриОткрытии, как будто это выполняется как в 8рке ПередОткрытием
   FerGoSec
 
9 - 21.09.18 - 09:24
ап
   Builder
 
10 - 21.09.18 - 09:47
(9) Выложи хотя бы скрин формы, плохо понятно что где у тебя на форме есть.
 
 Рекламное место пустует
   Convert
 
11 - 21.09.18 - 09:54
Ответ в (2). Впиши туда название реквизита владельца
   Convert
 
12 - 21.09.18 - 10:14
(0) А если делать через ПриНачалеВыбораЗначения, то потом ничего отлавливать не нужно. Выбранный элемент сам подставится.

Процедура ПриНачалеВыбораЗначения(ВыдавшийОрган,ФлагСтандОбр)   
    ФлагСтандОбр = 0;
    ОткрытьФорму("Справочник.ОрганыСертификации1",НужныйВладелец.ТекущийЭлемент());
КонецПроцедуры

у справочника "ОрганыСертификации1" Создай форму для выбора. В ней при открытии ИспользоватьВладельца(Форма.Параметр)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует