Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

локальная переменная, в модуле формы

локальная переменная, в модуле формы
Я
   1634344
 
19.09.18 - 14:37
Не могу сообразить как правильно сделать.
Из формы 1 открываем форму 2 и передаем в форму 2 структуру.
Форма 1

&НаКлиенте
Процедура Команда1(Команда)    
    Форма = ПолучитьФорму("ВнешняяОбработка.ВнешняяОбработка1.Форма.ФормаСправочник1",перСтруктураСправочника);
    форма.Открыть();
КонецПроцедуры


На форме 2 получаем структуру присваиваем переменной пер1

Форма2

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    пер1 = Параметры;
КонецПроцедуры

А вот теперь как сделать чтобы структура пер1 было доступна во всем модуле формы в частности при открытии
Форма2

&НаКлиенте
Форма2Процедура ПриОткрытии(Отказ)

КонецПроцедуры
 
 
   Сияющий в темноте
 
1 - 19.09.18 - 14:50
Пихать в реквизит формы,чтобы отправилась на клиента при создании формы.
на сервере переменные живут до окончания серверного вызова.
   Ненавижу 1С
 
2 - 19.09.18 - 15:05
вверху модуля формы пишешь 

Перем пер1;
   1634344
 
3 - 19.09.18 - 15:10
(2) такой вариант пробовал в первую очередь.
   1634344
 
4 - 19.09.18 - 15:25
Сделал так, конечно наверно коряво но как вариант

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    пер1 = Параметры;
    стр=Реквизит1.Добавить();//Реквизит формы тип значения ТЗ

    стр.колонка1=пер1.ключ1;
    стр.колонка2=пер1.ключ2;
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует