Вход | Регистрация


Замена встроенной печатной формой на внешнюю

Замена встроенной печатной формой на внешнюю
Я
   Ник080808
 
18.09.18 - 14:56
Нужно подправить стандартную печатную форму в документе не снимая с поддержки. Раньше можно было внешней присвоить идентификатор встроенной, сейчас не срабатывает и бсп добавляет внешнюю форму дополнительно, а не заменяя. Какие сейчас варианты замены?
 
 
   Deon
 
1 - 18.09.18 - 14:58
(0) А чо за кофа?
   Ник080808
 
2 - 18.09.18 - 14:58
БП
   Deon
 
3 - 18.09.18 - 14:58
Там в администрировании можно включать выключать галочками формы
   Ник080808
 
4 - 18.09.18 - 15:01
где конкретно? все облазил не нашел
   Cyberhawk
 
5 - 18.09.18 - 15:09
И раньше, и сейчас это работает
   Ник080808
 
6 - 18.09.18 - 15:17
замена идентификаторов не работает
   dmt
 
7 - 18.09.18 - 15:37
(6) Команда.ЗаменяемыеКоманды использовал? Имя команды правильно указал?
   Ник080808
 
8 - 18.09.18 - 15:53
(7) да
   Ник080808
 
9 - 18.09.18 - 16:11
БСП 2.2.3.29 если шо
   dmt
 
10 - 18.09.18 - 16:15
(9) покажи код
 
 Рекламное место пустует
   ptiz
 
11 - 18.09.18 - 16:22
(4) В УТ11: НСИ и Администрирование - Печатные формы, объекты и обработки - Подменю Печать
   Ник080808
 
12 - 18.09.18 - 16:24
Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); 
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");     
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Расходная накладная с серийными номерами"); 
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
    ПараметрыРегистрации.Вставить("Версия", "1.0"); 
    ПараметрыРегистрации.Вставить("Информация", ""); 
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, НСтр("Расходная накладная")
    , "НакладнаяССериями", "ВызовСерверногоМетода", Истина, "ПечатьMXL","НакладнаяССериями");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;
    
КонецФункции    

Функция ПолучитьТаблицуКоманд()
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"))//как будет выглядеть описание печ.формы для пользователя

    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));//имя макета печ.формы

    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));//ВызовСерверногоМетода

    Команды.Колонки.Добавить("ЗаменяемыеКоманды", Новый ОписаниеТипов("Строка"));//ВызовСерверногоМетода

    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "",ЗаменяемыеКоманды )
    
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление; 
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
    НоваяКоманда.ЗаменяемыеКоманды = ЗаменяемыеКоманды;
КонецПроцедуры
   Ник080808
 
13 - 18.09.18 - 16:24
(11) это БП
   ptiz
 
14 - 18.09.18 - 16:36
(13) Ты не поверишь, но в БП 3.0 - точно так же.
   dmt
 
15 - 18.09.18 - 17:04
Нет в БП 3 стандартной печ.формы "НакладнаяССериями", которую ты пытаешься заменить
   Ник080808
 
16 - 18.09.18 - 17:18
(15) (14) я не говорил что БП 3) БП для Украины 2.09) там нет такого подменю и есть такая печатная форма. Но не нашел нигде в коде "ЗаменяемыеКоманды ". Это с какой БСП?
   dmt
 
17 - 18.09.18 - 17:22
(16) Ну и е*ись с ней сам ))
   Ник080808
 
18 - 18.09.18 - 17:29
(17) спасибо тебе, добрый человек)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует