Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

мобила - шк

мобила - шк
Я
   Sj
 
18.09.18 - 00:27
Привет!

  Мобильное приложение. Сканер штрих-кодов. Команда Сканировать.
После "каких-то" манипуляций на смартфоне появляется сообщение "Сканер штрих-кодов уже открыт". Умом-то я понимаю, что он ни .... не открыт, но что делать, кроме перезагрузки приложения?

&НаКлиенте
Процедура Сканировать(Команда)
    
    #Если МобильноеПриложениеКлиент Тогда

        Оп1 = Новый ОписаниеОповещения("ВыполнитьПослеСканирования", ЭтотОбъект);
        Оп2 = Новый ОписаниеОповещения("ОбработчикЗакрытия", ЭтотОбъект);
        Если ЗначениеЗаполнено(ФизЛицо) Тогда
            Т1 = "документ.";
        Иначе    
            Т1 = "свой личный штрихкод.";
        КонецЕсли;
        СредстваМультимедиа.ПоказатьСканированиеШтрихКодов("Пожалуйста, сканируйте " + Т1, Оп1, Оп2);
    #КонецЕсли

    
КонецПроцедуры
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует