Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Отразить предоплату по ФР Атолл 30ф

v7: Отразить предоплату по ФР Атолл 30ф
Я
   brenli
 
17.09.18 - 21:10
ВСем привет. КАк отразить предоплату чтобы при печати чека пропечатывалось - не полный расчет, а предоплата?
 
 
   Builder
 
1 - 17.09.18 - 21:24
Да как обычный товар.
"Предоплата по договору №1" - 1 шт, 100 руб.
   brenli
 
2 - 18.09.18 - 06:43
(1)Я так понимаю что перед вызовом метода Регистрация() нужно какое то свойство задать?
   piter3
 
3 - 18.09.18 - 07:10
фдд какой?
   Сияющий в темноте
 
4 - 18.09.18 - 12:29
Предоплата за конкретный товар или аванс?
по 105 там разные признаки предмета и способа расчета указываются
   brenli
 
5 - 19.09.18 - 15:11
(4) Предоплата за товар. Конкретный.
Т.е сейчас в каждой строчке  пишет полный расчет, а надо когда есть предоплата чтобы это было указано.
   Woldemar177
 
6 - 19.09.18 - 18:29
(0) (5) обратитесь в АСЦ ;)))))
   Kigo_Kigo
 
7 - 19.09.18 - 18:57
Функция ПечататьЧек(Объект, Пароль, СписокТоваров, СуммаЧека, Получено, Скидка, ПризнВозврата, ПУП, Кассир, НомерСекции, НомерЧека, ДлинаСтроки)
    
    Рез = 0;
    
    Если ПодключитьсяКФР(Объект) = 1 Тогда    
        
        Объект.ValuePurpose = 56;
        Объект.Value = 3;
        Объект.SetValue();
        
        Объект.AttrValue = Кассир;
        Объект.AttrNumber = 1021;
        Объект.WriteAttribute();
        
        Объект.AttrValue = ПУП;
        Объект.AttrNumber = 1055;
        Объект.WriteAttribute();
        
        Объект.Password = Пароль;
        
        // входим в режим регистрации

        Объект.CheckType = 1;
        Объект.Mode = 1;
        Если Объект.SetMode() <> 0 тогда
            ОписаниеРезультата = Объект.ResultDescription;
            Возврат Рез;
        КонецЕсли;
        
        Объект.CheckMode = 1// CheckMode - Режим формирования чека:0 - только в электронном виде без печати на чековой ленте;1 - печатать на чековой ленте;

        Объект.OpenCheck();
        
        //Если Скидка > 0  Тогда

        //    Объект.Percents = Скидка;

         //    Объект.Destination = 0;

         //    Если Объект.PercentsDiscount() <> 0 тогда

         //        ОписаниеРезультата = Объект.ResultDescription;

         //        Возврат Рез;

         //    КонецЕсли;

         //ИначеЕсли Скидка < 0  Тогда

         //    Объект.Percents = (-1) * Скидка;

         //    Объект.Destination = 0;

         //    Если Объект.PercentsCharge() <> 0 тогда

         //        ОписаниеРезультата = Объект.ResultDescription;

         //        Возврат Рез;

         //    КонецЕсли;              

        //КонецЕсли;

        // продажа без сдачи 

        
        СписокТоваров.ВыбратьСтроки();
        
        Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
            
            Объект.Name = СписокТоваров.ТовНаим;
            Объект.Price = СписокТоваров.Цена;
            Объект.Quantity = СписокТоваров.Количество;
        
            Если СписокТоваров.СтавкаНДС = "none" Тогда
                Объект.TaxTypeNumber = 4;
            ИначеЕсли СписокТоваров.СтавкаНДС = "18" Тогда
                Объект.TaxTypeNumber = 3;
            ИначеЕсли СписокТоваров.СтавкаНДС = "10" Тогда
                Объект.TaxTypeNumber = 2;
            ИначеЕсли СписокТоваров.СтавкаНДС = "0" Тогда
                Объект.TaxTypeNumber = 1;        
            КонецЕсли;
            
            Если ПризнВозврата = 0 Тогда
                Если Объект.Registration() <> 0 тогда
                    ОписаниеРезультата = Объект.ResultDescription;
                    Возврат Рез;
                КонецЕсли;
            Иначе    
                Если Объект.Return() <> 0 тогда
                    ОписаниеРезультата = Объект.ResultDescription;
                     Возврат Рез;
                КонецЕсли;
            КонецЕсли;
            
        КонецЦикла;
        
        //Объект.TypeClose = 0;

        //Объект.Summ = 500.00;

        //Объект.Payment();

        //Объект.CloseCheck();


        
        
        Если Док.Получено <> 0 Тогда
            Объект.TypeClose = 0;
            Объект.Summ = Док.Получено;
            Объект.Payment();
        КонецЕсли;
        Если Док.ПоБанку <> 0 Тогда 
            Объект.TypeClose = 1;
            Объект.Summ = Док.ПоБанку;
            Объект.Payment();
        КонецЕсли;
        СписокТоваров.ПолучитьСтрокуПоНомеру(1);
        Если Лев(СписокТоваров.ТовНаим,17)  = "Аванс(предоплата)"Тогда
        Иначе
            
            Если Док.Предоплата <> 0 Тогда 
                Объект.TypeClose = 2;
                Объект.Summ = Док.Предоплата;
                Объект.Payment();
            КонецЕсли;  
            
        КонецЕсли;



        
        //Объект.Summ = СуммаЧека;

        //Объект.TypeClose = 0; 

        //

        //Если Объект.Delivery() <> 0 тогда

        //    ОписаниеРезультата = Объект.ResultDescription;

         //    Возврат Рез;

        //КонецЕсли;

                
        //Объект.TypeClose = 0;

        Если Объект.CloseCheck() <> 0 тогда
            ОписаниеРезультата = Объект.ResultDescription;
             Возврат Рез;
        КонецЕсли;
        
        Если Рез = 1 тогда
            Рез = ОтключитьсяОтФР(Объект);
        КонецЕсли;    
        
        ОписаниеПоследнейОшибки =    Объект.ResultDescription;
        КодПоследнейОшибки        =     Объект.ResultCode;
        
        Если КодПоследнейОшибки = 0 тогда
            Рез = 1;
        Иначе
            ОписаниеРезультата = ОписаниеПоследнейОшибки;
        КонецЕсли; 
    КонецЕсли;
    
    Возврат Рез;
    
КонецФункции

Список тем форума
Рекламное место пустует  Рекламное место пустует
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует