Вход | Регистрация


ЧтениеXML

ЧтениеXML
Я
   Никкккк
 
17.09.18 - 11:25
Помогите,пожалуйста,с чтением XML строки. Строка хранится в xml виде.Как прочитать и получить данные из этой строки?Можете привести примеры
 
 
   Sasha_H
 
1 - 17.09.18 - 11:26
   Никкккк
 
2 - 17.09.18 - 11:29
(1) Там документ,а мне нужно строку
   Temai
 
3 - 17.09.18 - 11:33
Глобальный контекст (Global context)
XMLЗначение (XMLValue)
Синтаксис:

XMLЗначение(<Тип>, <СтрокаXML>)
Параметры:

<Тип> (обязательный)

Тип: Тип.
Тип, значение которого надо получить при преобразовании из строкового представления XML.
<СтрокаXML> (обязательный)

Тип: Строка.
Строка, содержащая строковое представление значения, полученное из XML.
Возвращаемое значение:

Тип: Null; Булево; Число; Строка; Дата; УникальныйИдентификатор; ДвоичныеДанные; ХранилищеЗначения; значения перечислений, значения системных перечислений (ВидСчета; ВидДвиженияБухгалтерии; ВидДвиженияНакопления; ДопустимыйЗнак; ДопустимаяДлина; ЧастиДаты; Неопределено или все ссылки на объекты базы данных.

Описание:

Выполняет преобразование из строки, полученной из текста элемента или значения атрибута XML, в значение в соответствии с указанным типом. Выполняет действие обратное действию метода XMLСтрока.

Доступность:

Тонкий клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Пример:

ЧитаемДату = Ложь;
Пока ЧтениеXML.Прочитать() Цикл
    Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
        Если ЧтениеXML.ЛокальноеИмя = "Дата" Тогда
            ЧитаемДату = Истина;
        КонецЕсли;
    ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
        Если ЧитаемДату Тогда
            Дата = XMLЗначение(Тип("Дата"), ЧтениеXML.Значение);
        КонецЕсли
    КонецЕсли
КонецЕсли
 

См. также:

Глобальный контекст, метод XMLСтрока
   Никкккк
 
4 - 17.09.18 - 11:36
(3) Спасибо
   Sasha_H
 
5 - 17.09.18 - 11:36
(1) Читаем тему внимательно!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует