Вход | Регистрация


Подбор в поле табличной части документа

Подбор в поле табличной части документа
Я
   TolstiyBeremenniy
 
14.09.18 - 10:39
Данный код реализует подбор в поле документа, на форме.
Как будет выглядеть код если подбор нужно делать у поля табличной
части документа? Что будет на месте, -

ЭтотОбъект
ЭтотОбъект.Запись[ИмяКода]




&НаКлиенте
Процедура КодКатегорииЗемельНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ВыборКода("КодКатегорииЗемель", "КатегорииЗемельныхУчастков");
КонецПроцедуры

&НаКлиенте
Процедура ВыборКода(ИмяКода, НазваниеМакета)
    СтандартнаяОбработка = Ложь;
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ТипОбъекта",      "РегистрСведений");
    ПараметрыФормы.Вставить("НазваниеОбъекта", "РегистрацияЗемельныхУчастков");
    ПараметрыФормы.Вставить("НазваниеМакета",  НазваниеМакета);
    ПараметрыФормы.Вставить("ТекущийПериод",   ЭтотОбъект.Запись.Период);
    ПараметрыФормы.Вставить("ТекущийКод",      ЭтотОбъект.Запись[ИмяКода]);
    ДополнительныеПараметры = Новый Структура;
    ДополнительныеПараметры.Вставить("ИмяКода", ИмяКода);
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", ЭтотОбъект, ДополнительныеПараметры);
    ОткрытьФорму("ОбщаяФорма.ФормаВыбораКода", ПараметрыФормы,,,,,ОповещениеОЗакрытии);
КонецПроцедуры

&НаКлиенте
Процедура ВыборКодаЗавершение(РезультатЗакрытия, ДополнительныеПараметры) Экспорт
    ИмяКода      = ДополнительныеПараметры.ИмяКода;
    ВыбранныйКод = РезультатЗакрытия;
    Если ВыбранныйКод <> Неопределено Тогда
        Модифицированность  = Истина;
        ЭтотОбъект.Запись[ИмяКода] = ВыбранныйКод;
    КонецЕсли;
КонецПроцедуры
 
 
   TolstiyBeremenniy
 
1 - 14.09.18 - 10:42
Прошу прощения, вот код для поля формы документа.
Предыдущий для формы регистра сведений.

&НаКлиенте
Процедура ВыборКода(ИмяКода, НазваниеМакета)
    
    СтандартнаяОбработка = Ложь;
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ТипОбъекта", "РегистрСведений");
    ПараметрыФормы.Вставить("НазваниеОбъекта", "РегистрацияЗемельныхУчастков");
    ПараметрыФормы.Вставить("НазваниеМакета", НазваниеМакета);
    ПараметрыФормы.Вставить("ТекущийПериод", Объект.Дата);
    ПараметрыФормы.Вставить("ТекущийКод", Объект[ИмяКода]);
    
    ДополнительныеПараметры = Новый Структура;
    ДополнительныеПараметры.Вставить("ИмяКода", ИмяКода);
    
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", ЭтотОбъект, ДополнительныеПараметры);
    
    ОткрытьФорму("ОбщаяФорма.ФормаВыбораКода", ПараметрыФормы,,,,,ОповещениеОЗакрытии);
    
КонецПроцедуры

&НаКлиенте
Процедура ВыборКодаЗавершение(РезультатЗакрытия, ДополнительныеПараметры) Экспорт
    
    ИмяКода = ДополнительныеПараметры.ИмяКода;
    
    ВыбранныйКод = РезультатЗакрытия;
    
    Если ВыбранныйКод <> Неопределено Тогда
        
        Модифицированность = Истина;
        
        Объект[ИмяКода] = ВыбранныйКод;
        
    КонецЕсли;
    
КонецПроцедуры
   TolstiyBeremenniy
 
2 - 14.09.18 - 14:13
Не подскажете ли
   TolstiyBeremenniy
 
3 - 14.09.18 - 14:32
На отбор в табличной части документа, такая ошибка ->


{Документ.ИзменениеПараметровЗемельногоУчастка.Форма.ФормаДокумента.Форма(96)}: Ошибка при вызове конструктора (ОписаниеОповещения)
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", Объект, ДополнительныеПараметры);
по причине:
Не найден экспортируемый метод: ВыборКодаЗавершение


Как нужно правильно?

&НаКлиенте
Процедура ЗемельныеУчасткиКодКатегорииЗемельНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ВыборКода("КодКатегорииЗемель", "КатегорииЗемельныхУчастков");
КонецПроцедуры

&НаКлиенте
Процедура ВыборКода(ИмяКода, НазваниеМакета)
    СтандартнаяОбработка = Ложь;
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ТипОбъекта",      "РегистрСведений");
    ПараметрыФормы.Вставить("НазваниеОбъекта", "РегистрацияЗемельныхУчастков");
    ПараметрыФормы.Вставить("НазваниеМакета",  НазваниеМакета);
    ПараметрыФормы.Вставить("ТекущийПериод",   Объект.Дата);
    //ПараметрыФормы.Вставить("ТекущийКод",      Объект[ИмяКода]);

    ПараметрыФормы.Вставить("ТекущийКод",ЭтаФорма.ТекущийЭлемент.ТекущиеДанные.КодКатегорииЗемель);
    ДополнительныеПараметры = Новый Структура;
    ДополнительныеПараметры.Вставить("ИмяКода", ИмяКода);
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", Объект, ДополнительныеПараметры);
    ОткрытьФорму("ОбщаяФорма.ФормаВыбораКода", ПараметрыФормы,,,,,ОповещениеОЗакрытии);
КонецПроцедуры

&НаКлиенте
Процедура ВыборКодаЗавершение(РезультатЗакрытия, ДополнительныеПараметры) Экспорт
    ИмяКода      = ДополнительныеПараметры.ИмяКода;
    ВыбранныйКод = РезультатЗакрытия;
    Если ВыбранныйКод <> Неопределено Тогда
        Модифицированность  = Истина;
        //Объект[ИмяКода] = ВыбранныйКод;

        ЭтаФорма.ТекущийЭлемент.ТекущиеДанные.КодКатегорииЗемель = ВыбранныйКод;
    КонецЕсли;
КонецПроцедуры
   Lexey_
 
4 - 14.09.18 - 14:33
Ливингстар никак не угомонится...
   Lexey_
 
5 - 14.09.18 - 14:36
   TolstiyBeremenniy
 
6 - 14.09.18 - 14:41
(5) Это для поля формы документа!
Сейчас мне нужно для поля табличной части формы документа.
Там по другому все!!!! Пока не понял как.
   Lexey_
 
7 - 14.09.18 - 14:47
(6) не ори, т.е. точное совпадение текста ошибки тебя не смущает?
   TolstiyBeremenniy
 
8 - 14.09.18 - 14:52
(7) В документе нужно писать Объект
и Экспорт есть
вот я и не пойму
   TolstiyBeremenniy
 
9 - 14.09.18 - 14:53
В ДополнительныхПараметрах я что то не так передал.
Или Не Объект нужно передавать!!!!!
Подкажите как правильно?
   Lexey_
 
10 - 14.09.18 - 15:04
 
 Рекламное место пустует
   Lexey_
 
11 - 14.09.18 - 15:06
(10) в той теме в десятом сообщении тебе даже понятно было
   TolstiyBeremenniy
 
12 - 14.09.18 - 15:09
Заработало:

енте
Процедура ЗемельныеУчасткиКодКатегорииЗемельНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ВыборКода("КодКатегорииЗемель", "КатегорииЗемельныхУчастков");
КонецПроцедуры

&НаКлиенте
Процедура ВыборКода(ИмяКода, НазваниеМакета)
    СтандартнаяОбработка = Ложь;
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ТипОбъекта",      "РегистрСведений");
    ПараметрыФормы.Вставить("НазваниеОбъекта", "РегистрацияЗемельныхУчастков");
    ПараметрыФормы.Вставить("НазваниеМакета",  НазваниеМакета);
    ПараметрыФормы.Вставить("ТекущийПериод",   Объект.Дата);
    //ПараметрыФормы.Вставить("ТекущийКод",      Объект[ИмяКода]);

    ПараметрыФормы.Вставить("ТекущийКод",ЭтаФорма.ТекущийЭлемент.ТекущиеДанные.КодКатегорииЗемель);
    ДополнительныеПараметры = Новый Структура;
    ДополнительныеПараметры.Вставить("ИмяКода", ИмяКода);
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", ЭтаФорма, ДополнительныеПараметры);
    ОткрытьФорму("ОбщаяФорма.ФормаВыбораКода", ПараметрыФормы,,,,,ОповещениеОЗакрытии);
КонецПроцедуры

&НаКлиенте
Процедура ВыборКодаЗавершение(РезультатЗакрытия, ДополнительныеПараметры) Экспорт
    ИмяКода      = ДополнительныеПараметры.ИмяКода;
    ВыбранныйКод = РезультатЗакрытия;
    Если ВыбранныйКод <> Неопределено Тогда
        Модифицированность  = Истина;
        //Объект[ИмяКода] = ВыбранныйКод;

        ЭтаФорма.ТекущийЭлемент.ТекущиеДанные.КодКатегорииЗемель = ВыбранныйКод;
    КонецЕсли;
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует