Вход | Регистрация

1С:Предприятие ::

Метки: 

Не найден экспортируемый метод: ВыборКодаЗавершение

Я
   TolstiyBeremenniy
 
14.09.18 - 07:12
У формы записи регистра сведений делаю подбор, у одного поля.
По подобию подбора в типовом документе. Но выходит ошибка
{РегистрСведений.КоэффициентыРасчетаЗемельногоНалога.Форма.ФормаЗаписи.Форма(19)}: Ошибка при вызове конструктора (ОписаниеОповещения)
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", ЭтотОбъект.Запись, ДополнительныеПараметры);
по причине:
Не найден экспортируемый метод: ВыборКодаЗавершение

Эта процедура же есть в модуле, почему ругается?



&НаКлиенте
Процедура КодКатегорииЗемельНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ВыборКода("КодКатегорииЗемель", "КатегорииЗемельныхУчастков");
КонецПроцедуры

&НаКлиенте
Процедура ВыборКода(ИмяКода, НазваниеМакета)
    СтандартнаяОбработка = Ложь;
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ТипОбъекта",      "РегистрСведений");
    ПараметрыФормы.Вставить("НазваниеОбъекта", "РегистрацияЗемельныхУчастков");
    ПараметрыФормы.Вставить("НазваниеМакета",  НазваниеМакета);
    ПараметрыФормы.Вставить("ТекущийПериод",   ЭтотОбъект.Запись.Период);
    ПараметрыФормы.Вставить("ТекущийКод",      ЭтотОбъект.Запись[ИмяКода]);
    ДополнительныеПараметры = Новый Структура;
    ДополнительныеПараметры.Вставить("ИмяКода", ИмяКода);
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", ЭтотОбъект.Запись, ДополнительныеПараметры);
    ОткрытьФорму("ОбщаяФорма.ФормаВыбораКода", ПараметрыФормы,,,,,ОповещениеОЗакрытии);
КонецПроцедуры

&НаКлиенте
Процедура ВыборКодаЗавершение(РезультатЗакрытия, ДополнительныеПараметры) Экспорт
    ИмяКода      = ДополнительныеПараметры.ИмяКода;
    ВыбранныйКод = РезультатЗакрытия;
    Если ВыбранныйКод <> Неопределено Тогда
        Модифицированность  = Истина;
        ЭтотОбъект.Запись[ИмяКода] = ВыбранныйКод;
    КонецЕсли;
КонецПроцедуры
 
 
   TolstiyBeremenniy
 
1 - 14.09.18 - 07:39
Подскажете по вопросу? Я чего то не вижу или недопонимаю. Процедура есть, а ОписаниеОповещения её не видит?
   Mankubus
 
2 - 14.09.18 - 07:45
(0) >>ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", ЭтотОбъект.Запись, ДополнительныеПараметры);

Зачем здесь "ЭтотОбъект.Запись"? Напиши ЭтаФорма
   TolstiyBeremenniy
 
3 - 14.09.18 - 07:51
(2) Этот код я взял с формы одного типового документа.
Тым везде было Объект. В форме регистра сведений на Объект
шла ошибка. Я написал везде ЭтотОбъект. А ЭтотОбъект.Запись,
так как у регистра сведений значения полей тут хранятся.
Пока ещё не запустил этот код.

Сейчас попробую написать ЭтаФорма.
   TolstiyBeremenniy
 
4 - 14.09.18 - 08:01
Все равно ошибка ((((( Что нужно поправить? Что не так?

{РегистрСведений.КоэффициентыРасчетаЗемельногоНалога.Форма.ФормаЗаписи.Форма(19)}: Ошибка при вызове конструктора (ОписаниеОповещения)
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", ЭтаФорма, ДополнительныеПараметры);
по причине:
Не найден экспортируемый метод: ВыборКодаЗавершение
   TolstiyBeremenniy
 
5 - 14.09.18 - 08:06
Что не так????



&НаКлиенте
Процедура КодКатегорииЗемельНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ВыборКода("КодКатегорииЗемель", "КатегорииЗемельныхУчастков");
КонецПроцедуры

&НаКлиенте
Процедура ВыборКода(ИмяКода, НазваниеМакета)
    СтандартнаяОбработка = Ложь;
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ТипОбъекта",      "РегистрСведений");
    ПараметрыФормы.Вставить("НазваниеОбъекта", "РегистрацияЗемельныхУчастков");
    ПараметрыФормы.Вставить("НазваниеМакета",  НазваниеМакета);
    ПараметрыФормы.Вставить("ТекущийПериод",   ЭтотОбъект.Запись.Период);
    ПараметрыФормы.Вставить("ТекущийКод",      ЭтотОбъект.Запись[ИмяКода]);
    ДополнительныеПараметры = Новый Структура;
    ДополнительныеПараметры.Вставить("ИмяКода", ИмяКода);
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", ЭтаФорма, ДополнительныеПараметры);
    ОткрытьФорму("ОбщаяФорма.ФормаВыбораКода", ПараметрыФормы,,,,,ОповещениеОЗакрытии);
КонецПроцедуры

&НаКлиенте
Процедура ВыборКодаЗавершение(РезультатЗакрытия, ДополнительныеПараметры) 
    ИмяКода      = ДополнительныеПараметры.ИмяКода;
    ВыбранныйКод = РезультатЗакрытия;
    Если ВыбранныйКод <> Неопределено Тогда
        Модифицированность  = Истина;
        ЭтотОбъект.Запись[ИмяКода] = ВыбранныйКод;
    КонецЕсли;
КонецПроцедуры
   Остап Сулейманович
 
6 - 14.09.18 - 08:11
(5) Вот здесь :
Процедура ВыборКодаЗавершение(РезультатЗакрытия, ДополнительныеПараметры)
нет слова Экспорт
   TolstiyBeremenniy
 
7 - 14.09.18 - 08:23
И так тоже ошибка ((((((

{РегистрСведений.КоэффициентыРасчетаЗемельногоНалога.Форма.ФормаЗаписи.Форма(19)}: Ошибка при вызове конструктора (ОписаниеОповещения)
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ВыборКодаЗавершение", ЭтотОбъект, ДополнительныеПараметры);
по причине:
Не найден экспортируемый метод: ВыборКодаЗавершение

(6) Оно было, я его убрал. Убрал так как ошибка шла, не знал что менять. Сейчас верну.
   TolstiyBeremenniy
 
8 - 14.09.18 - 08:28
(6) Да, спасибо! Если я не ошибаюсь пошло! Забыл я про это слово Экспорт. Но почему первый раз с ним не работало не понятно.
   Пробел
 
9 - 14.09.18 - 08:33
В первый раз не пошло из-за "ЭтотОбъект.Запись", во второй из-за Экспорта)

Вторым параметром указывается модуль, откуда будет вызвана процедура, а Вы указали какой-то реквизит объекта.
   TolstiyBeremenniy
 
10 - 14.09.18 - 08:35
(9) Понятно. Спасибо. Методом проб и ошибок делал.
 
 Рекламное место пустует
   TolstiyBeremenniy
 
11 - 14.09.18 - 14:51
(9) В документе нужно писать Объект
и Экспорт есть
вот я и не пойму


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует