Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Обмен по СОМ

Обмен по СОМ
Я
   S-Sheriff
 
12.09.18 - 10:53
Здравствуйте! Проблема такая:
При попытке соединения с COM-сервером произошла следующая ошибка:
{ОбщийМодуль.МодульРегламентныхЗаданий.Модуль(415)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): {МодульВнешнегоСоединения(13)}: Ошибка при вызове конструктора (ComОбъект)
На обычной винде (64 бит) всё работает, а на серверной НЕТ.
База бухгалтерия 3.0 (серверная) и бухгалтерия 2.0 (файловая) обе базы на одном сервере, при попытке соединиться по СОМ, вот такая ошибка.
Текст модуля ниже - 
Перем СтрокаПодключения;
    
    Если СтруктураПараметров = Неопределено Тогда
        Возврат Неопределено;
    КонецЕсли;
    
    ПараметровДостаточно = МодульЦемзавод.ОпределитьДостаточностьПараметровДляПодключенияКИнформационнойБазе(СтруктураПараметров, СтрокаПодключения, СтрокаСообщенияОбОшибке);
    
    Если Не ПараметровДостаточно Тогда
        Возврат Неопределено;
    КонецЕсли;
    
    Если СтруктураПараметров.СерверныйРежим Тогда
        ПараметрыПодключения = "Srvr=""" + СокрЛП(СтруктураПараметров.ИмяСервера) + """; Ref=""" + СокрЛП(СтруктураПараметров.ИмяБазы) + """; Usr=""" + СокрЛП(СтруктураПараметров.Пользователь) + """; Pwd=""" + СокрЛП(СтруктураПараметров.Пароль) + """;";
    Иначе
        ПараметрыПодключения = "File=""" + СокрЛП(СтруктураПараметров.ПутьКБазе) + """; Usr=""" + СокрЛП(СтруктураПараметров.Пользователь) + """; Pwd=""" + СокрЛП(СтруктураПараметров.Пароль) + """;";
    КонецЕсли;
    
    
    Попытка
        //#Если Клиент Тогда

        //Состояние("Идет процесс соединения ...");

        Сообщить("Идет процесс соединения ...");
        //#КонецЕсли

        
                
        Попытка
            Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда
                Обработчик = Новый COMObject("V82.COMConnector");
            Иначе
                Обработчик = Новый COMObject("V83.COMConnector");
            КонецЕсли;
        Исключение
            Сообщить("Ошибка создания объекта "+Обработчик+" !") ;
            Сообщить(ОписаниеОшибки()) ;
        КонецПопытки;

        
        ТекCOMОбъект = Обработчик.Connect(ПараметрыПодключения);
                    
        //#Если Клиент Тогда

        //Состояние("Соединение установлено");

        Сообщить("Соединение установлено");
        //#КонецЕсли        

            
    Исключение
        
        СтрокаСообщенияОбОшибке = "При попытке соедиения с COM-сервером произошла следующая ошибка:" + Символы.ПС 
                        + ОписаниеОшибки();
        //#Если Клиент Тогда

            Сообщить(СтрокаСообщенияОбОшибке, СтатусСообщения.Важное);
            //Состояние("Соединение установить не удалось");

            //Состояние();

            Сообщить("Соединение установить не удалось");
        //#КонецЕсли

                            
        Возврат Неопределено;
        
    КонецПопытки;
    
    Возврат ТекCOMОбъект;

Что делать и как исправить?
 
 
   S-Sheriff
 
1 - 14.09.18 - 11:22
Получается ещё такой момент, делал вот так - 

1. Установка ОС на чистовую
2. Установка SQL
3. Установка Платформы под текущим пользователем (Администратор)
-----Результат тот же--------
4. Регистрация comcntr.dll через командную строку
-----Результат тот же--------
5. Делаю аналогично описанной статьи тут http://katalog.forum-1c.ru/public/197627/
-----Результат тот же--------
6. Регистрация компоненты в папка System32 и SysWow64
7. Переустановил Платформу и создал пользователя, который предлагает платформа (UserV8) и добавил роли, как описано тут http://1centerprise8.blogspot.com/2018/02/agent-1s-domennyj-polzovatel.html
-----Ошибка {ОбщийМодуль.МодульРегламентныхЗаданий.Модуль(407)}: Ошибка при вызове конструктора (COMОбъект): -2147024891(0x80070005): Отказано в доступе.
При попытке соедиения с COM-сервером произошла следующая ошибка:
{ОбщийМодуль.МодульРегламентныхЗаданий.Модуль(415)}: Значение не является значением объектного типа (Connect)-----
8. Настройка локальных политик безопасности согласно инструкции от сюда http://1centerprise8.blogspot.com/2018/02/agent-1s-domennyj-polzovatel.html
в последние 3 пункта, раздела 5, добавил пользователя UserV8
-----Результат - Отказано в доступе-------
9. Добавили сервер в домен
-----Результат тот же-------- Ошибка как и прежде.
10. Установил платформу 8.3.12 и повторил заново пункт 4 и 5
Что по итогу имеем. Непосредственно на самом сервере подключение не проходит никак.
Подключение проходит на клиентских (пользовательских) компах, НО, тоже не во всех режимах.
Из файловой в файловую есть коннект, а вот из серверной в файловую нет (нужен как раз последний вариант подключения).
Выручайте, господа, очень нужна помощь!
   Cyberhawk
 
2 - 14.09.18 - 11:24
Сколько платят за решение вопроса?
   OldCondom
 
3 - 14.09.18 - 11:31
Переписать это УГ на веб сервис.
   S-Sheriff
 
4 - 14.09.18 - 12:56
(3) не вариант
   S-Sheriff
 
5 - 14.09.18 - 12:58
(2) во сколько оцениваете?
   Вафель
 
6 - 14.09.18 - 12:59
файл лежит на том же сервере где и сервер 1с?
   Лефмихалыч
 
7 - 14.09.18 - 12:59
(1) гуглить "Я - старовер. Мне как-то железные понятнее." пробовал?

Этим граблям в обед сто лет
   Cyberhawk
 
8 - 14.09.18 - 12:59
(5) Думаю, за пару человеко-дней можно с большой вероятностью управиться
   S-Sheriff
 
9 - 16.09.18 - 18:54
(6) Какой файл?
   S-Sheriff
 
10 - 16.09.18 - 18:54
(7) Предложи свой вариант, раз ты уже не старовер..
 
 Рекламное место пустует
   Fram
 
11 - 16.09.18 - 20:17
Когда подключается из серверной к файловой делаешь это НаСервере или НаКлиенте?
   S-Sheriff
 
12 - 17.09.18 - 12:18
Проблему решил, спасибо за "помощь"!)
   craxx
 
13 - 17.09.18 - 12:35
(8) проблема решается минут за 15. Вангую дело было в разрешениях для юзеров для использования COM+ компоненты.
   СантаМарина
 
14 - 17.09.18 - 12:45
(12) А поделиться?
   craxx
 
15 - 17.09.18 - 12:51
(14) чего там делиться? прописывается запуск компоненты от пользователя с админскими правами да и все. У него видимо из-под текущего юзера шел запуск, а USR1CV83 бесправный скорее всего.
   Cyberhawk
 
16 - 17.09.18 - 12:58
(13) Так Я и не оценивал непосредственную длительность выполнения работы. Я отвечал на вопрос "во сколько оцениваете" )
   Serginio1
 
17 - 17.09.18 - 17:57
Проверь соединение от админа.
Есть подозрение, что нет прав на папку файловой базы
   S-Sheriff
 
18 - 18.09.18 - 05:47
(13) нет, не то
   S-Sheriff
 
19 - 18.09.18 - 05:48
(15) Очень далеки от истины)
   S-Sheriff
 
20 - 18.09.18 - 05:48
(17) Все права есть и пользователей там два, один Админ, второй USR1CV83
   S-Sheriff
 
21 - 18.09.18 - 05:50
(13) И если Вы внимательно перечитаете второе моё сообщение, то там уже это всё расписано, вангует он))
   Сияющий в темноте
 
22 - 18.09.18 - 12:33
на серверную ставить 64 битного клиента,в не  будет внешка,которая на сервере отработает,ну и одинаковые платформы в двух базах.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует