Вход | Регистрация

1С:Предприятие ::

Метки: 

Ошибка получения макета

Я
   TolstiyBeremenniy
 
11.09.18 - 06:52
Хочу вывести макет из документа. Что я не так делаю?

&НаКлиенте
Процедура ПечатьМакета(Команда)
    МакетОбработки = ПолучитьМакетНаСервере();
    //

    СекцияШапка  = МакетОбработки.ПолучитьОбласть("Шапка");
    СекцияСтрока = МакетОбработки.ПолучитьОбласть("Строка");
    СекцияПодвал = МакетОбработки.ПолучитьОбласть("Подвал");
    ЭтаФорма.ПолеОтчета.Очистить();
    //

    ЭтаФорма.ПолеОтчета.Вывести(СекцияШапка);
    НомПП = 1;
    Для каждого СтрТз Из ЭтотОбъект.КритерииОценки Цикл


&НаСервере
Функция ПолучитьМакетНаСервере()
    //ОтчетОбъект = РеквизитФормыВЗначение("Объект");

    Макет       = ЭтотОбъект.ПолучитьМакет("Макет");
    Возврат Макет;
КонецФункции
 
 
   TolstiyBeremenniy
 
1 - 11.09.18 - 06:53
Пишет метод не обнаружен ПолучитьМакет()
   hhhh
 
2 - 11.09.18 - 07:01
(1) ЭтотОбъект - это твоя форма вообще-то. У формы не макетов, правильно программа тебе говорит.
   hhhh
 
3 - 11.09.18 - 07:01
нет макетов у формы.
   TolstiyBeremenniy
 
4 - 11.09.18 - 07:02
А как получить макет? Я создал его у докумнета.
   TolstiyBeremenniy
 
5 - 11.09.18 - 07:06
Как получить макет документа, подскажите пожалуйста?
   Лодырь
 
6 - 11.09.18 - 07:13
Схема = РеквизитФормыВЗначение("Объект").ПолучитьМакет("МакетСклада");
   TolstiyBeremenniy
 
7 - 11.09.18 - 07:17
(6) Спасибо!
   TolstiyBeremenniy
 
8 - 11.09.18 - 07:19
Подскажите а как правильно сейчас это вывести?
Там макет по табличной части документа.
А то обычно я выводил в табличное поле. А тут как?

&НаКлиенте
Процедура ПечатьМакета(Команда)
    МакетОбработки = ПолучитьМакетНаСервере();
    //

    СекцияШапка  = МакетОбработки.ПолучитьОбласть("Шапка");
    СекцияСтрока = МакетОбработки.ПолучитьОбласть("Строка");
    СекцияПодвал = МакетОбработки.ПолучитьОбласть("Подвал");
    ЭтаФорма.ПолеОтчета.Очистить();
    //

    ЭтаФорма.ПолеОтчета.Вывести(СекцияШапка);
    НомПП = 1;
    Для каждого СтрТз Из ЭтотОбъект.КритерииОценки Цикл
        СекцияСтрока.Параметры.Ном         = НомПП;
        НомПП = НомПП + 1;
        //

    КонецЦикла;
    //

    ЭтаФорма.ПолеОтчета.Вывести(СекцияПодвал);
    //

    ЭтаФорма.ПолеОтчета.АвтоМасштаб = Истина;
КонецПроцедуры
   craxx
 
9 - 11.09.18 - 07:20
(8) в серверной процедуре и вывести


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует