Вход | Регистрация


Права на объекты в зависимости от ролей

Права на объекты в зависимости от ролей
Я
   TolstiyBeremenniy
 
11.09.18 - 04:07
Есть 2 новые роли. Нужно дать права на созданные объекты.
Как правильно блокировать их доступность?

    Если Не РольДоступна("СозданиеКритериевОценки") И Не РольДоступна("ЧтениеКритериевОценки") Тогда
        
    КонецЕсли;
 
 
   TolstiyBeremenniy
 
1 - 11.09.18 - 05:23
Bynthatqc nfrcb/
   TolstiyBeremenniy
 
2 - 11.09.18 - 05:23
Интерфейс такси.
   PuhUfa
 
3 - 11.09.18 - 05:29
Отказ = Истина;
Возврат;


зы А вообще просто нужно нормально роли сделать что бы не писать такое
   TolstiyBeremenniy
 
4 - 11.09.18 - 05:32
(3) В какой процедуре писать Отказ = Истина; ?
   TolstiyBeremenniy
 
5 - 11.09.18 - 05:32
(3) Как нормально сделать роли?
   PuhUfa
 
6 - 11.09.18 - 05:44
(4) в присоздании
(5) сделай отдельную роль. в ней настрой нужный доступ к нужным объектам а в остальных ролях убери.
   TolstiyBeremenniy
 
7 - 11.09.18 - 06:24
У меня вот эти отдельные роли. Оставлю у них галки только на нужные объекты. А как разделить, создание, чтение?

СозданиеКритериевОценки
ЧтениеКритериевОценки
   TolstiyBeremenniy
 
8 - 11.09.18 - 06:36
Из за чего такая ошибка может быть?

{Документ.ВводКритериевОценкиКачестваРаботыСотрудников.Форма.ФормаДокумента.Форма(69)}: Ошибка при вызове метода контекста (РольДоступна)
    Если Не РольДоступна("СозданиеКритериевОценки") И Не РольДоступна("ЧтениеКритериевОценки") Тогда
по причине:
Недопустимое значение параметра (параметр номер '1')
   catena
 
9 - 11.09.18 - 06:42
(7)" А как разделить, создание, чтение? " - там галочки разные для этих действий.
   hhhh
 
10 - 11.09.18 - 06:53
(8) "Из за чего такая ошибка может быть?"

Ливингстар, перелогиньтесь.
 
 Рекламное место пустует
   TolstiyBeremenniy
 
11 - 11.09.18 - 08:01
(8+) Бегло прохожу по задачам тз. Задаю вопросы что не понятно. "СозданиеКритериевОценки" и "ЧтениеКритериевОценки" такие роли есть. В чем ошибка?
   Segate
 
12 - 11.09.18 - 08:03
(11)в программисте, очевидно.

Поубивал бы за такое конечно в 2018...
   TolstiyBeremenniy
 
13 - 11.09.18 - 09:00
(12) А как нужно?
   TolstiyBeremenniy
 
14 - 11.09.18 - 09:00
(12) Главное что бы работало же, не так ли?
   TolstiyBeremenniy
 
15 - 11.09.18 - 09:25
Делал вызов на сервере, почему ошибка?

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    //Если Не РольДоступна("СозданиеКритериевОценки") И Не РольДоступна("ЧтениеКритериевОценки") Тогда

    //    

    //КонецЕсли;

КонецПроцедуры
   Segate
 
16 - 11.09.18 - 09:44
(13) у тебя есть роли, и в ролях есть настройки(Чтение, изменение, просмотр, модификация(вроде так)) раздай эти права ролям и не надо ничего проверять.
В ролях можно настраивать доступ не только к документам в целом, но и к реквизитам документа.

(14) главное, чтоб потом, когда пользователю назначат роли в предприятии через БСП было понятно какие права у них появляются, а какие нет. Чтобы не приходилось потом выяснять это методом научного тыка.
   TolstiyBeremenniy
 
17 - 11.09.18 - 10:00
(16) Ок, скоро займусь этими ролями.
Ну так почему методом научного тыка, если все либо галками
задано у роли или в коде прописано, тоже понятно как.
   Segate
 
18 - 11.09.18 - 11:11
(17) потому что БСП, например обновление прав "в конфигураторе"(простановку галок пользователям) проводит в фоновом режиме, и не всегда "РольДоступна" будет отрабатывать корректно. Это раз.
Второе: у вас в роли будет стаять право на чтение и изменение объекта, и следующий после вас проставляя эту роль будет уверен, что дал права на объект, но нет, доступность будет ограничиваться в коде(и дай бог в процедуре "При создании", а не где-то в общем модуле куда передают форму для корректного заполнения перед открытием), что в данном случае глупо и не нужно.
   TolstiyBeremenniy
 
19 - 17.09.18 - 10:53
Есть 2 Роли:

1. СозданиеКритериевОценки
2. ЧтениеКритериевОценки

и 2 объекта

1. Справочник
2. Документ

У роли 1. оставил все галки на справочник и документ.
У роли 2. оставил только галки чтение, просмотр.

Захожу под пользователем, у которого стоят права, -

Администратор системы,
Открытие внешних отчетов обработок,
Полные права.

У него не стоят эти 2 роли. Но я захожу под ним, можно создавать, документ. Как это возможно, если у него не стоят эти галки???
   TolstiyBeremenniy
 
20 - 17.09.18 - 10:57
(19+) Наверное из за полных прав. Посмотрел , да, у полных прав есть галки на эти объекты.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует