Вход | Регистрация


1С:Предприятие ::

Метки: 

Сделать чтоб после ввода штрихкода окно не закрывалось

Я
   imon4ik
 
10.09.18 - 21:58
После ввода штрихкода в меню поиска штрихкода в подборе номенклатуры (клавиша F7) окно сразу закріваться и для вібора новой номенклатурі его нужно снова открівать. Как сделать так, что б окно не закрывалось до нажатия кнопки Нет. 1с 8,3.
Помогите пожалуйста.

Результат = РаботаСТорговымОборудованием.ВвестиШтрихкод();

    Если Не ПустаяСтрока(Результат) Тогда
        ПолучитьСерверТО().ОбработатьВведенныйШтрихкод(Результат, ЭтаФорма);
        
    КонецЕсли;




Функция ВвестиШтрихкод() Экспорт

   Результат = "";    

    ВвестиСтроку(Результат, "Введите штрихкод");
    
    Возврат Результат;

КонецФункции// ВвестиШтрихкод()
 
 
   PR
 
1 - 10.09.18 - 22:39
Это ты ищешь исполнителя?
   imon4ik
 
2 - 10.09.18 - 22:41
(1) Ищу помощь. Может кто-то направит меня в нужное русло.
   imon4ik
 
3 - 10.09.18 - 23:14
Может подскажете как цикл сделать ?
   Lexey_
 
4 - 10.09.18 - 23:18
(3)
Пока ВвестиСтроку() Цикл

КонецЦикла;
   imon4ik
 
5 - 10.09.18 - 23:29
(4) Пока ВвестиСтроку ругается (((

Попробовал

ЧислоСтрок = 10;
    Для Сч = 1 По ЧислоСтрок Цикл
    Результат = РаботаСТорговымОборудованием.ВвестиШтрихкод();
        Если Не ПустаяСтрока(Результат) Тогда
        ПолучитьСерверТО().ОбработатьВведенныйШтрихкод(Результат, ЭтаФорма);
        КонецЕсли;    

Работает, но делает 10 попыток, как сделать, чтоб окно закрывалось после нажатия "Отмена"
   Lexey_
 
6 - 10.09.18 - 23:32
(5) "ругается", сделай, чтоб не ругалось
   Lexey_
 
7 - 10.09.18 - 23:36
(5) "как сделать, чтоб окно закрывалось после нажатия "Отмена""
об этом написано в (4)
   imon4ik
 
8 - 10.09.18 - 23:47
(7) {ОбщийМодуль.РаботаСТорговымОборудованием.Модуль(174,6)}: Змінна не визначена (ВвестиСтроку)
Пока <<?>>ВвестиСтроку Цикл (Перевірка: Товстий клієнт (звичайна прикладна програма))
   Lexey_
 
9 - 10.09.18 - 23:52
(8) everything is simple: the variable is not defined, see (4) and look for the differences
   imon4ik
 
10 - 10.09.18 - 23:57
(9) Сделал Следущие изменения и пишет что Недостаточно фактичесских параметров ВвестиСтроку((( Прошу помочь.


Функция ВвестиШтрихкод() Экспорт
    
    Пока ВвестиСтроку() Цикл

   Результат = "";  
   
    ВвестиСтроку(Результат, "Введите штрихкод");
            Возврат Результат;
    КонецЦикла;

КонецФункции// ВвестиШтрихкод()
 
 Рекламное место пустует
   Lexey_
 
11 - 11.09.18 - 00:01
(10) уже лучше, теперь почитай СП, посмотри свой код в (0) и добавь параметров
   Lexey_
 
12 - 11.09.18 - 00:03
(10) и зачем 2 раза ВвестиСтроку()?
ты точно понимаешь, что делаешь?
   imon4ik
 
13 - 11.09.18 - 00:04
(11) Спасибо!
Сделал, чтоб не ругалось. Но Ожидаемый результат не достигнут. При первом вводе штрихкода он не добавляется, при втором добавляется и окно само закрывается.


Функция ВвестиШтрихкод() Экспорт
    

   Результат = "";  
         Пока ВвестиСтроку(Результат, "Введите штрихкод") Цикл
    ВвестиСтроку(Результат, "Введите штрихкод");
            Возврат Результат;
    КонецЦикла;

КонецФункции// ВвестиШтрихкод()
   imon4ik
 
14 - 11.09.18 - 00:06
(12) Сделал так. Окно закрывается после первого ввода. Результат не достигнут
Функция ВвестиШтрихкод() Экспорт
    

   Результат = "";  
         Пока ВвестиСтроку(Результат, "Введите штрихкод") Цикл
                Возврат Результат;
    КонецЦикла;

КонецФункции// ВвестиШтрихкод()
   Lexey_
 
15 - 11.09.18 - 00:09
(14) " Возврат Результат;"
так ты выходишь из цикла после первого ввода
   imon4ik
 
16 - 11.09.18 - 00:14
Уже получается то что хотел, но только после двойного введения штрихкода.


Результат = РаботаСТорговымОборудованием.ВвестиШтрихкод();
Пока ВвестиСтроку(Результат, "Введите штрихкод") Цикл
    Если Не ПустаяСтрока(Результат) Тогда
        ПолучитьСерверТО().ОбработатьВведенныйШтрихкод(Результат, ЭтаФорма);
    КонецЕсли;    
КонецЦикла;
   Lexey_
 
17 - 11.09.18 - 00:18
(16) не делай двойное введение, ты ж сам его написал
   imon4ik
 
18 - 11.09.18 - 00:20
(15) Если убираю Возврат Результат, то окно действительно не закрывается, но и штрихкод не ищется (
   Lexey_
 
19 - 11.09.18 - 00:24
(18) ну в (16) убери одну лишнюю строку и всё
   imon4ik
 
20 - 11.09.18 - 00:30
(19) Убрал, ничего не поменялось (( Я Вам уже надоел, наверное....



Результат = РаботаСТорговымОборудованием.ВвестиШтрихкод();
Пока ВвестиСтроку(Результат, "Введите штрихкод") Цикл
            ПолучитьСерверТО().ОбработатьВведенныйШтрихкод(Результат, ЭтаФорма);
                КонецЦикла;
   Lexey_
 
21 - 11.09.18 - 00:32
(20) жесть...
зачем ты убрал то, что не влияет на открытие диалога ввода строки?
   imon4ik
 
22 - 11.09.18 - 00:33
(21) Ура! Сделал!!!! Спасибо большое!!!!!

Функция ВвестиШтрихкод() Экспорт
    

    Результат = "";    

        
    Возврат Результат;


КонецФункции// ВвестиШтрихкод()



Процедура КоманднаяПанельТоварыПоискПоШтрихКоду(Кнопка)
        
        Результат = РаботаСТорговымОборудованием.ВвестиШтрихкод();
Пока ВвестиСтроку(Результат, "Введите штрихкод") Цикл
            ПолучитьСерверТО().ОбработатьВведенныйШтрихкод(Результат, ЭтаФорма);
                КонецЦикла;

КонецПроцедуры// КоманднаяПанельТоварыПоискПоШтрихКоду()
   imon4ik
 
23 - 11.09.18 - 00:34
(21) Спасибо, что учили, а не сделали все за меня! Для меня это урок!!
   Lexey_
 
24 - 11.09.18 - 00:40
(23) думай дальше, в (22) еще есть лишний код)
   imon4ik
 
25 - 11.09.18 - 00:51
(24) Я нашел косяк. Это отлично работает в одном документе и убило функцию у остальных документах. Для решения задачи я создал еще одну функцию ВвестиШтрихкодЦиклом и код, который Вы помогли написать вставил туда. Соответсвенно документы у которых нужен новый функционал будут ссылаться на функцию с циклом, а остальные по старому.

Тыкните носом в ошибку.



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует