Вход | Регистрация

1С:Предприятие ::

Метки: 

По представлению получить объект (управл. формы)

Я
   lirt82
 
07.09.18 - 12:17
Есть самописная обработка, на форме реквизит тип СписокЗначений, при открытии получаем список регистров сведении.
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    Для Каждого Стр Из Метаданные.РегистрыСведений Цикл 
        СписРегСвед.Добавить(СтрЗаменить(Стр.ПолноеИмя(), "РегистрСведений.", ""), Стр.Представление());
    КонецЦикла;
    СписРегСвед.СортироватьПоПредставлению();
    
КонецПроцедуры

Далее по кнопке "Обработать" нужно обратно получить из представления сам объект, для последующей обработки.
 
 
   lirt82
 
1 - 07.09.18 - 12:19
Для каждого Стр Из СписРегСвед Цикл
//получаем по представлению сам объект

//обрабатываем

КонецЦикла;
   Михаил Козлов
 
2 - 07.09.18 - 12:47
имяРегистра = стр.Значение;
   youalex
 
3 - 07.09.18 - 12:51
а зачем здесь СтрЗаменить() если есть Стр.Имя
   lirt82
 
4 - 07.09.18 - 12:59
(2) так я получаю имя а дальше?
Для каждого Стр Из СписРегСвед Цикл
   ИмяРег = Стр.Значение
   РегистрДляОбработки = Метаданные.НайтиПоПолномуИмени("РегистрыСведений[Стр.Значение]");
  //теперь нужно получить сам объект метаданных

****************
вот так не получается возвращает всегда неопределено
   lirt82
 
5 - 07.09.18 - 12:59
(4) РегистрДляОбработки = Метаданные.НайтиПоПолномуИмени("РегистрСведений[Стр.Значение]"); - тоже Неопределено
   lirt82
 
6 - 07.09.18 - 13:01
Стр.Значение = "АдресныйКлассификатор" Тип Строка
   Михаил Козлов
 
7 - 07.09.18 - 13:01
Так не получится: РегистрДляОбработки = Метаданные.РегистрыСведений[имяРегистра]?
   lirt82
 
8 - 07.09.18 - 13:02
(7) +1000000 тема закрыта:-)
   DionisSergeevich
 
9 - 07.09.18 - 13:05
Найти подход коммент("РегистрСведений... А не регистры
   DionisSergeevich
 
10 - 07.09.18 - 13:06
Долбаный телефон. НайтиПоПолномуИмени("РегистрСведений.
 
 Рекламное место пустует


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует