Вход | Регистрация


1С:Предприятие ::

Метки: 

не удается открыть форму справочника

Я
   TolstiyBeremenniy
 
07.09.18 - 08:07
Создал форму справочника, открываю её по кнопке из документа.
Выдается ошибка

{Документ.ИзменениеПараметровЗемельногоУчастка.Форма.ФормаДокумента.Форма(16)}: Ошибка при вызове метода контекста (ОткрытьФорму)
    ОткрытьФорму("Справочник.ОбъектыЭксплуатации.ФормаПодбораПараметровЗемельногоУчастка", , Элементы.ЗемельныеУчастки);
по причине:
Неизвестное имя формы. Имя: "Справочник.ОбъектыЭксплуатации.ФормаПодбораПараметровЗемельногоУчастка"
 
 
   TolstiyBeremenniy
 
1 - 07.09.18 - 08:08
(0+) Как она может быть не известна если она есть?
   TolstiyBeremenniy
 
2 - 07.09.18 - 08:09
Подскажите пожалуйста, почему не получается открыть форму?
   Metman
 
3 - 07.09.18 - 08:11
Справочники.ОбъектыЭксплуатации.ФормаПодбораПараметровЗемельногоУчастка.ОткрытьФорму(<ИмяФормы>)
   TolstiyBeremenniy
 
4 - 07.09.18 - 08:11
Форма есть, почему не открывается?

http://joxi.ru/DmB8nRGCwBVYbA
   Zmich
 
5 - 07.09.18 - 08:12
(0). Попробуй так:
"Справочник.ОбъектыЭксплуатации.Форма.ФормаПодбораПараметровЗемельногоУчастка"
   TolstiyBeremenniy
 
6 - 07.09.18 - 08:12
(3) То есть это по стилю интерфейса Такси?
А код (4) устарел что ли?
В этой же базе так же формы открываются по коду видел.
Не мог он устареть. От чего это тогда? Все же правильно написано!
   TolstiyBeremenniy
 
7 - 07.09.18 - 08:15
В (4) же все верно написано, от чего ошибка?
   TolstiyBeremenniy
 
8 - 07.09.18 - 08:18
Новая ошибка, как все же нужно?

{Документ.ИзменениеПараметровЗемельногоУчастка.Форма.ФормаДокумента.Форма(16)}: Ошибка при вызове метода контекста (ОткрытьФорму)
    ОткрытьФорму("Справочник.ОбъектыЭксплуатации.Форма.ФормаПодбораПараметровЗемельногоУчастка", , Элементы.ЗемельныеУчастки);
по причине:
Неправильное условие отбора
   Остап Сулейманович
 
9 - 07.09.18 - 08:21
(8) Ну так форма уже пытается открыться. То есть с открытием все правильно. Теперь оно ругается на то, что в форме установлен неправильный отбор.
Я бы попытался отбор отключить.
   TolstiyBeremenniy
 
10 - 07.09.18 - 08:23
(9) Я не задавал никакого отбора. А где он включен?
Отбор, фильтр то есть задать нужно, но пока я хочу открыть форму.
 
 Рекламное место пустует
   Остап Сулейманович
 
11 - 07.09.18 - 08:25
(10) Ну ты же форму скопировал? Вот и скопировал вместе с прописанным там отбором.
   TolstiyBeremenniy
 
12 - 07.09.18 - 08:26
Вот так вот, другая форма открылась без проблем.

ОткрытьФорму("Справочник.ОбъектыЭксплуатации.ФормаВыбора", , Элементы.ЗемельныеУчастки);

Почему же эта не открывается?
   Остап Сулейманович
 
13 - 07.09.18 - 08:28
(12) Потому что "там" устанавливается некорректный отбор. Отбор, который в исходнике был "в контексте", а в копии стал "не в контексте". Вот и все.
Пока удал отбор вообще.
   TolstiyBeremenniy
 
14 - 07.09.18 - 08:31
(13) О какой копии речь?
   TolstiyBeremenniy
 
15 - 07.09.18 - 08:31
Я создал новую форму выбора, и хочу её открыть. Не получается!!!!
   Остап Сулейманович
 
16 - 07.09.18 - 08:34
(15) Удали отбор в своей форме.
   TolstiyBeremenniy
 
17 - 07.09.18 - 08:50
(16) Извините что туплю, но какой отбор?
Вот этот нельзя удалить.

http://joxi.ru/12MzBxdtMGVJqA
   Остап Сулейманович
 
18 - 07.09.18 - 09:05
   Остап Сулейманович
 
19 - 07.09.18 - 09:06
+(18) Начинать со свойств реквизита. (на картинке справа).
   Остап Сулейманович
 
20 - 07.09.18 - 09:08
   TolstiyBeremenniy
 
21 - 07.09.18 - 09:13
(20) Я сделал источником данных произвольный запрос.

Задаю там параметр. А как в него передать организацию из документа? Где установить сам параметр?
   TolstiyBeremenniy
 
22 - 07.09.18 - 09:13
(21+)

ВЫБРАТЬ
    РегистрацияЗемельныхУчастков.ОсновноеСредство КАК ОсновноеСредство,
    РегистрацияЗемельныхУчастков.КБК КАК КБК,
    РегистрацияЗемельныхУчастков.КодКатегорииЗемель КАК КодКатегорииЗемель,
    РегистрацияЗемельныхУчастков.НалоговаяСтавка КАК НалоговаяСтавка,
    РегистрацияЗемельныхУчастков.НалоговаяЛьготаПоНалоговойБазе КАК НалоговаяЛьготаПоНалоговойБазе,
    РегистрацияЗемельныхУчастков.КадастроваяСтоимость КАК КадастроваяСтоимость
ИЗ
    РегистрСведений.РегистрацияЗемельныхУчастков КАК РегистрацияЗемельныхУчастков
ГДЕ
    РегистрацияЗемельныхУчастков.Организация = &ОрганизацияИзДокумента
   TolstiyBeremenniy
 
23 - 07.09.18 - 09:19
Форма открылась. Но как сейчас в этот запрос передать параметр организация из шапки документа?

http://joxi.ru/Y2LzyDWt9GkaDr
   Остап Сулейманович
 
24 - 07.09.18 - 09:20
(21) С отбором уже совладал?

"Где установить сам параметр?" Сам параметр устанавливается :
1. При открытии формы в процедуре ПриСозданииНаСервере
2. При изменении интерактивном изменении в процедуре ПриИзменении. ЗЫ. Это чаще всего так. Но могут быть варианты.

Устанавливаются кодом :
<ИдентификаторДС>.Параметры.УстановитьЗначениеПараметра(<ИмяПараметра>, ЗначениеПараметра);
   TolstiyBeremenniy
 
25 - 07.09.18 - 09:20
пробовал задавать как

http://joxi.ru/krDz8kEtE5PDZ2
   TolstiyBeremenniy
 
26 - 07.09.18 - 09:21
(24) Я удалил то что было. Делаю произвольный запрос источник данных.
   Остап Сулейманович
 
27 - 07.09.18 - 09:22
(23) Птля... У тебя же ОрганизацияИзДокумента - параметр запроса. Нафига он еще и в отборе? Оставь что-то одно. Лучше всего в отборе. Если умеешь его настроить программно.
   TolstiyBeremenniy
 
28 - 07.09.18 - 09:22
(24) Но а если сам запрос тут  http://joxi.ru/KAxBVMwTMLza3m

куда мне задавать то параметры? параметры чего?
   Остап Сулейманович
 
29 - 07.09.18 - 09:26
(28) В запросе ДС есть такой текст 
"
ГДЕ
    РегистрацияЗемельныхУчастков.Организация = &ОрганизацияИзДокумента
"
Вот это вот "&ОрганизацияИзДокумента" и есть параметр запроса. Устанавливается он как написано в (24)
   Остап Сулейманович
 
30 - 07.09.18 - 09:29
(29) Если в тексте запроса удалить предложение "ГДЕ..." - тогда запрос выберет данные по всем организациям. И нужно будет настраивать отбор уже на клиенте в настройках отбора.
Это можно делать программно. Пример здесь : Как программно добавить отбор в динамический список на УФ 8.3? посты 7, 8
   TolstiyBeremenniy
 
31 - 07.09.18 - 09:29
(29) У меня эта форма открывается из документа.

&НаКлиенте
Процедура Подбор2(Команда)
    ОткрытьФорму("Справочник.ОбъектыЭксплуатации.Форма.ФормаПодбораПараметровЗемельногоУчастка", , Элементы.ЗемельныеУчастки);
КонецПроцедуры



Нужно то есть как то в процедуре ОткрытьФорму передать туда параметры?
   Остап Сулейманович
 
32 - 07.09.18 - 09:31
(31) Вторым параметром метода ОткрытьФорму. У тебя он пустой.

ИЗ СП :

<Параметры> (необязательный)

Тип: Структура.
Параметры формы. Ключ структуры - имя параметра, а значение - значение параметра формы. Имя элемента должно совпадать с именем параметра структуры.
П = Новый Структура("Ключ", Поставщик);
Форма = ПолучитьФорму("Справочник.Контрагенты.ФормаОбъекта", П);
Форма.Открыть();
   TolstiyBeremenniy
 
33 - 07.09.18 - 09:33
(32) Да спасибо, большое! Продвигаюсь!!!
 
 
   TolstiyBeremenniy
 
34 - 07.09.18 - 09:44
(32) Подскажите пожалуйста а какому объекту
задавать параметр? Нужно же передать произвольному запросу.



&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Параметры.Свойство("ОрганизацияИзДокумента") Тогда
        Запрос.УстановитьПараметр("ОрганизацияИзДокумнета", Параметры.ОрганизацияИзДокумента);
    КонецЕсли;
КонецПроцедуры
   TolstiyBeremenniy
 
35 - 07.09.18 - 09:48
Как задать что параметр я передаю произвольному запросу
динамического списка.
   TolstiyBeremenniy
 
36 - 07.09.18 - 09:50
Похоже так, -

    Если Параметры.Свойство("ОрганизацияИзДокумента") Тогда
        РегистрацияЗемельныйУчастков.Параметры.УстановитьЗначениеПараметра(УстановитьПараметр("ОрганизацияИзДокумнета", Параметры.ОрганизацияИзДокумента);
    КонецЕсли;
   TolstiyBeremenniy
 
37 - 07.09.18 - 09:54
(36+) Прошу прощения, вот так, -
    Если Параметры.Свойство("ОрганизацияИзДокумента") Тогда
        РегистрацияЗемельныйУчастков.Параметры.УстановитьЗначениеПараметра("ОрганизацияИзДокумента", Параметры.ОрганизацияИзДокумента);
    КонецЕсли;
   TolstiyBeremenniy
 
38 - 07.09.18 - 09:59
Странно но все равно идет такая ошибка.

http://joxi.ru/vAWz4ext1Ep1R2

Параметр передался.
   Остап Сулейманович
 
39 - 07.09.18 - 10:08
(38) Убери уже все отборы в настройках ДС.
   spiller26
 
40 - 07.09.18 - 10:11
(38) Отладчик тебе для чего?
   spiller26
 
41 - 07.09.18 - 10:21
1. Запрос лучше сделать так 

ВЫБРАТЬ
    РегистрацияЗемельныхУчастков.ОсновноеСредство КАК ОсновноеСредство,
    РегистрацияЗемельныхУчастков.КБК КАК КБК,
    РегистрацияЗемельныхУчастков.КодКатегорииЗемель КАК КодКатегорииЗемель,
    РегистрацияЗемельныхУчастков.НалоговаяСтавка КАК НалоговаяСтавка,
    РегистрацияЗемельныхУчастков.НалоговаяЛьготаПоНалоговойБазе КАК НалоговаяЛьготаПоНалоговойБазе,
    РегистрацияЗемельныхУчастков.КадастроваяСтоимость КАК КадастроваяСтоимость
ИЗ
    РегистрСведений.РегистрацияЗемельныхУчастков КАК РегистрацияЗемельныхУчастков
{ГДЕ
    РегистрацияЗемельныхУчастков.Организация = &ОрганизацияИзДокумента}
   spiller26
 
42 - 07.09.18 - 10:34
затем
передаешь в параметрах организацию, 

&НаКлиенте
Процедура ПриОткрытии(Отказ)
СписокЧегототам.Параметры.УстановитьЗначениеПараметра("ОрганизацияИзДокумента", Параметры.Организация);
...

Вот как-то так
   TolstiyBeremenniy
 
43 - 07.09.18 - 10:46
(39) Спасибо! Сейчас да дошло. Я его сам там сделал в этот раз. В тот там просто не было ничего кажется.

(42) Ну я подобно делаю. Хочется наконец увидеть его в деле, как это заработает!!!!!

А почему в условии фигурные скобки, в чем тут преимущество?
   TolstiyBeremenniy
 
44 - 07.09.18 - 10:55
Подскажите что я не так сделал?

1. Я сделал форму выбора справочника.
2. источник данных произвольный запрос, передаю ему параметр.
2. Открываю форму выбора из документа

&НаКлиенте
Процедура Подбор2(Команда)
    П = Новый Структура;
    // пара ключ (имя переменной) - значение (произв. типа)

    П.Вставить("ОрганизацияИзДокумента", Объект.Организация);
    //П.Вставить("Имя", "Иван");

    //П.Вставить("ДатаРождения", '19800802');    

    ОткрытьФорму("Справочник.ОбъектыЭксплуатации.Форма.ФормаПодбораПараметровЗемельногоУчастка", П, Элементы.ЗемельныеУчастки);
КонецПроцедуры
    

В форме выбора


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Параметры.Свойство("ОрганизацияИзДокумента") Тогда
        РегистрацияЗемельныйУчастков.Параметры.УстановитьЗначениеПараметра("ОрганизацияИзДокумента", Параметры.ОрганизацияИзДокумента);
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
    Элементы.ЗемельныеУчастки.ДобавитьСтроку();
    Элементы.ЗемельныеУчастки.ТекущиеДанные.ЗемельныйУчасток = ВыбранноеЗначение;
КонецПроцедуры


Сейчас открывается по нажатию кнопки форма выбора, но по двойному щелчку переходит на документ, и ничего не добавляется в Тч документа. Что я не так сделал?
   TolstiyBeremenniy
 
45 - 07.09.18 - 11:00
По двойному клику открываются докумнеты
   spiller26
 
46 - 07.09.18 - 11:03
(44) Естественно ничего не будет. Пиши "ОписаниеОповещенияОЗакрытии"
   TolstiyBeremenniy
 
47 - 07.09.18 - 11:06
(46) Я понял, я вот это не там написал, -

    Элементы.ЗемельныеУчастки.ДобавитьСтроку();
    Элементы.ЗемельныеУчастки.ТекущиеДанные.ЗемельныйУчасток = ВыбранноеЗначение;

Это нужно в форме документа, в свойстве табличной части, куда добавляются значения или значение.

А это, ОписаниеОповещенияОЗакрытии как зачем?
   TolstiyBeremenniy
 
48 - 07.09.18 - 11:09
Да ничего не происходит не понятно почему ((( Сейчас же все правильно сделал. Почему не срабатывает?
   TolstiyBeremenniy
 
49 - 07.09.18 - 11:10
(46) Я делал по примеру с ИТС там не было про ОписаниеОповещенияОЗакрытии
 
 Рекламное место пустует
   Остап Сулейманович
 
50 - 07.09.18 - 11:11
(45) Патамучта.
ОбработкаВыбора должна быть в форме откуда вызывается подбор. В твоем случае в форме документа. И привязано к событиям твоего Элементы.ЗемельныеУчастки. Но это фиговый вариант. Лучше событие привязывать к всей форме. Примерно так :
ОткрытьФорму("Справочник.ОбъектыЭксплуатации.Форма.ФормаПодбораПараметровЗемельногоУчастка", П, ЭтаФорма);

В форме подбора должно быть ОповеститьОВыборе.
В твоем случае в Обработчике события "Выбор" элемента "ЗемельныеУчастки"
Типа такого :

Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
ТД = Элемент.ТекущиеДанные;
Если НЕ ТД.ЭтоГруппа Тогда
  СтандартнаяОбработка = Ложь;
  ОповеститьОВыборе(ТД.Ссылка);
КоецЕсли;
КонецПроцедуры
   TolstiyBeremenniy
 
51 - 07.09.18 - 11:11
Тут даже точка останова не срабатывает. Должно же передаваться значение из формы выбора. И я его принимаю в табличной части документа, -

&НаКлиенте
Процедура ЗемельныеУчасткиОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    Элементы.ЗемельныеУчастки.ДобавитьСтроку();
    Элементы.ЗемельныеУчастки.ТекущиеДанные.ЗемельныйУчасток = ВыбранноеЗначение;
КонецПроцедуры
   TolstiyBeremenniy
 
52 - 07.09.18 - 11:12
(50) Да я не там сделал это.
Но я же переделал. Вот (51). Тут же правильно?!
Все равно не работае. Сейчас то почему?
   Остап Сулейманович
 
53 - 07.09.18 - 11:13
(51) Чтобы вызвалась ОбработкаВыбора нужно, чтобы кто-то сделал ОповеститьОВыборе.
   Остап Сулейманович
 
54 - 07.09.18 - 11:15
ОповеститьОВыборе должно сделаться из "ФормаПодбора". Чаще всего для этого используют обработку события Выбор элемента в котором отображается ДС. см. (50).
   TolstiyBeremenniy
 
55 - 07.09.18 - 11:15
(53) Ок, сделаю. Странно что про это не написали в ИТС.
Но где делать процедуру (50) в моем случае?
   spiller26
 
56 - 07.09.18 - 11:19
(53) Вот тебе простейший вариант


&НаКлиенте
Процедура Подбор2(Команда)
    
    П = Новый Структура;
    Оп = Новый ОписаниеОповещения("ВыполнитьПослеЗакрытияВыбора", ЭтотОбъект);

    ОткрытьФорму("Справочник.Номенклатура.ФормаВыбора", П, ЭтаФорма,,,, Оп);
    
КонецПроцедуры


&НаКлиенте
Процедура ВыполнитьПослеЗакрытияВыбора(ВыбранноеЗначение, ИсточникВыбора) Экспорт
    
    
КонецПроцедуры
   TolstiyBeremenniy
 
57 - 07.09.18 - 11:19
(54) Событие выбор есть у таблицы документа, для которой я
и делаю подбор. Но нде все же делать ОповеститьОВыборе ?
   TolstiyBeremenniy
 
58 - 07.09.18 - 11:20
(56) То есть что то передается в параметр, режим закрытия окна. И это поможет?
   Остап Сулейманович
 
59 - 07.09.18 - 11:20
(57) В "формеПодпора". В обработчике события "выбор" твоего ДС.
   spiller26
 
60 - 07.09.18 - 11:20
Читайте вот тут
http://its.1c.ru/docs/v8nonmodal/
   spiller26
 
61 - 07.09.18 - 11:22
(58) Ну у тебя же "формавыбора" (надеюсь), то естественно она должна передавать автоматически выбранное.
   TolstiyBeremenniy
 
62 - 07.09.18 - 11:22
(56)

У меня ОткрытьФорму("Справочник.ОбъектыЭксплуатации.Форма.ФормаПодбораПараметровЗемельногоУчастка", П, Элементы.ЗемельныеУчастки);

А У вас

ОткрытьФорму("Справочник.Номенклатура.ФормаВыбора", П, ЭтаФорма,,,, Оп);
   Остап Сулейманович
 
63 - 07.09.18 - 11:22
(56) Это не будет "Подбор".
Не сможешь таким способом из формы выбрать последовательно несколько значений. Поскольку для передачи в вызывающую форму значения вызываемую нужно будет каждый раз закрывать.
   TolstiyBeremenniy
 
64 - 07.09.18 - 11:23
(62+) Имеет ли значение Элменты.ЗемельныеУчастки или ЭтаФорма. Думаю да.
   Остап Сулейманович
 
65 - 07.09.18 - 11:24
(64) Это указывает на то, кто получит "ОповеститьОВыборе". Элемент ЗемельныеУчастки или ЭтаФорма.
   TolstiyBeremenniy
 
66 - 07.09.18 - 11:27
(65) Я вот приготовил процедуру в форме выбора,
подскажите пожалуйста как будет правильно. Если вам не трудно. А то вижу у меня голова что то отказывает ((

&НаКлиенте
Процедура РегистрацияЗемельныйУчастковВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    // Вставить содержимое обработчика.

КонецПроцедуры
   spiller26
 
67 - 07.09.18 - 11:27
(63) Не написано что это вообще подбор.

(64) Это владелец, данной открытой формы.
ОткрытьФорму(<ИмяФормы>, <Параметры>, <Владелец>, <Уникальность>, <Окно>, <НавигационнаяСсылка>, <ОписаниеОповещенияОЗакрытии>, <РежимОткрытияОкна>)
   Остап Сулейманович
 
68 - 07.09.18 - 11:29
(66) Это правильно.

Внутри процедуры (простейший вариант):
СтандартнаяОбработка = Ложь;
ОповеститьОВыборе(ВыбраннаяСтрока);
   spiller26
 
69 - 07.09.18 - 11:29
(66) Что вы хотите в итоге сделать? Опишите последовательность.
Выбрать десяток другой и добавить их или выбрать один элемент справочника?
   TolstiyBeremenniy
 
70 - 07.09.18 - 11:29
(65) Так будет?

ТД = Элемент.ТекущиеДанные;
Если НЕ ТД.ЭтоГруппа Тогда
  СтандартнаяОбработка = Ложь;
  ОповеститьОВыборе(ТД.Ссылка);
КоецЕсли;

(67) Да я делаю подбор. Раздвоилась тема. Извините.
(67) Ну да владелец. То есть в вашем примере тоже будет
за место ЭтаФорма, Элементы.ЗемельныеУчастки ?
   TolstiyBeremenniy
 
71 - 07.09.18 - 11:31
(69) Есть документ. На нем создал кнопку подбор.
У справочника делаю форму выбора с динамическим списком.
Источник значений произвольный запрос.
Нужно открывать форму подбора с данными из регистра сведений
и по двойному щелчку, заносить выбранные значения в Тч документа.
   Остап Сулейманович
 
72 - 07.09.18 - 11:33
(70) Ну не дословно.
Вот здесь :
ТД = Элемент.ТекущиеДанные;
Вместо Элемент нужно написать
Элементы.<ТвойДС>.ТекущиеДанные;
   TolstiyBeremenniy
 
73 - 07.09.18 - 11:35
(72) Понял. Пробую!
   TolstiyBeremenniy
 
74 - 07.09.18 - 11:38
(69) Множественный выбор хотелось бы.
   Остап Сулейманович
 
75 - 07.09.18 - 11:39
+ (72) И вообще... Проверку на группы нужно проводить, если это действительно нужно. Может твой ДС групп вообще не отображает? Зачем проверка? Или нужна возможность выбрать группу наряду с элементом. Тогда тоже проверка не имеет смысла.
Пробуй сначала без проверок. Что выбрал - о том и оповестил.
   TolstiyBeremenniy
 
76 - 07.09.18 - 11:46
(75) выдало ошибку
{Справочник.ОбъектыЭксплуатации.Форма.ФормаПодбораПараметровЗемельногоУчастка.Форма(11)}: Поле объекта не обнаружено (РегистрацияЗемельныхУчастков)
ТД = Элементы.РегистрацияЗемельныхУчастков.ТекущиеДанные;


а поле то это есть!!!!
   Остап Сулейманович
 
77 - 07.09.18 - 11:48
Сделай пока

СтандартнаяОбработка = Ложь;
ОповеститьОВыборе(ВыбраннаяСтрока);
   TolstiyBeremenniy
 
78 - 07.09.18 - 11:55
(77) Подбор добавляет строку, с выпадающим списком. Но пустую. То есть, без значения. Это наверное вот тут нужно
смотреть?

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
    Элементы.ЗемельныеУчастки.ДобавитьСтроку();
    Элементы.ЗемельныеУчастки.ТекущиеДанные.ЗемельныйУчасток = ВыбранноеЗначение;
КонецПроцедуры
   Остап Сулейманович
 
79 - 07.09.18 - 11:56
(78) Йес. Смотреть там. И переписать все нафик.

текСтрока = Элементы.ЗемельныеУчастки.ДобавитьСтроку();
текСтрока.ЗемельныйУчасток = ВыбранноеЗначение;
   TolstiyBeremenniy
 
80 - 07.09.18 - 12:04
(79) Вроде что то пошло.

&НаКлиенте
Процедура ЗемельныеУчасткиОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    Элементы.ЗемельныеУчастки.ДобавитьСтроку();
    Элементы.ЗемельныеУчастки.ТекущиеДанные.ЗемельныйУчасток = ВыбранноеЗначение.ОсновноеСредство;
КонецПроцедуры


А не подскажете ли как делается множественный выбор?
Сложно ли расширить функционал имеющийся до этой возможности.
   spiller26
 
81 - 07.09.18 - 12:04
Посмотри в типовой БП 3.0 как сделан подбор Номенклатуры в документах Поступления и Реализации.

1. Открываешь формы выбора списка.
2. При закрытии должен выбранное куда пометить (структура возврата).
3. Оповестить форму владельца, что выбор сделан.
3. У формы есть событие "ОбработкаВыбора", там вот и обрабатывай выбранное.
   Rico_1C
 
82 - 07.09.18 - 12:05
(0) Пройди курсы и не тупи:
https://xn----1-bedvffifm4g.xn--p1ai/courses/

И недавно в 1С был набор на 4 курса !..
   Остап Сулейманович
 
83 - 07.09.18 - 12:05
ТоварисчЪ!!! В взялись лепить подбор не имея понятия об :
1. Передаче параметров между формами?
2. О работе с динамическими списками?
3. О работе с табличными частями?
4. Не имея представления о методах и событиях управляемых форм?

На что вы рассчитываете?
   Остап Сулейманович
 
84 - 07.09.18 - 12:09
(80)
"как делается множественный выбор?".
Разрешить множественный выбор в "формеПодбора". (В свойствах ДС установить соответствующий флажок). Изменить процедуру ОбработкаВыбора. Поскольку туда будет прилетать не одиночное значение, а список выбранных значений.

"Сложно ли расширить функционал..."
Кому как.
   spiller26
 
85 - 07.09.18 - 12:10
(83) Наверное рассчитывает, что мы ему на блюдечке всё принесём.
   Остап Сулейманович
 
86 - 07.09.18 - 12:11
(80) Перепиши вот так :
текСтрока = Элементы.ЗемельныеУчастки.ДобавитьСтроку();
текСтрока.ЗемельныйУчасток = ВыбранноеЗначение.ОсновноеСредство;
   TolstiyBeremenniy
 
87 - 07.09.18 - 12:15
(85) Не не рассчитываю. Я лишь спрашиваю. И сам рою все.

Так получилось множественный выбор:

&НаКлиенте
Процедура Подбор2(Команда)
    П = Новый Структура;
    // пара ключ (имя переменной) - значение (произв. типа)

    П.Вставить("ОрганизацияИзДокумента", Объект.Организация);
    П.Вставить("ЗакрыватьПриВыборе", Ложь);
   spiller26
 
88 - 07.09.18 - 12:17
Не всё вы как хотите, но я уже не могу объяснять. Всё в (82)
   TolstiyBeremenniy
 
89 - 07.09.18 - 12:20
(88) Ну работает подбор! Спасибо вам!!!!
   TolstiyBeremenniy
 
90 - 07.09.18 - 12:21
Только сил пока нет тестировать.
Но с вашей помощью все развязки учтены были вроде как.

В конце множественный сделал, как в (87). Галку у списка не ставил.



Список тем форума
Рекламное место пустует Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует