Вход | Регистрация

1С:Предприятие ::

Метки: 

Установка ответственного при создании документа

Я
   TolstiyBeremenniy
 
07.09.18 - 04:45
При создании документа нужно прописать текущего пользователя.
Как проверить что документ новый? ЭтоНовый() почему то не работает.
Хотя есть такая функция.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Объект.Ответственный = ПараметрыСеанса.ТекущийПользователь;
КонецПроцедуры
 
 
   TolstiyBeremenniy
 
1 - 07.09.18 - 04:46
Так наверное? Если ЭтоНовый() не работает!

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Не ЗначениеЗаполнено(Объект.Ссылка) Тогда
        Объект.Ответственный = ПараметрыСеанса.ТекущийПользователь;
    КонецЕсли;
КонецПроцедуры
   shadow_sw
 
2 - 07.09.18 - 06:26
Параметры.Ключ.Пустая()

с Вас 500 руб в фонд Мисты
   los_hooliganos
 
3 - 07.09.18 - 06:41
ЭтоНовый работает в модуле объекта.
А в модуле формы ЭтоНовый не работает


Список тем форума
Рекламное место пустует Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует