Вход | Регистрация


Странное поведение ВПФ

Странное поведение ВПФ
Я
   НоваяВолна
 
06.09.18 - 10:30
Создал ВПФ, как внешнюю с формой. Протестировал, работает. Подключаю ее в документ, печатную форму выводит правильно, но выдает ошибку

{ОбщийМодуль.УниверсальныеМеханизмы.Модуль(1386)}: Поле объекта не обнаружено (КоличествоЭкземпляров)
        ПечДокумент.КоличествоЭкземпляров = КоличествоЭкземпляров; 

Вот эта функция:
Функция НапечататьДокумент(ПечДокумент, КоличествоЭкземпляров = 1, НаПринтер = Ложь, Заголовок = "", Ссылка = Неопределено, ПараметрыПечДокумента = Неопределено) Экспорт

    Если ПечДокумент = Неопределено тогда
        Возврат Неопределено;
    КонецЕсли;

    // Получить необходимое количество копий

    Если КоличествоЭкземпляров > 0 Тогда
        ПечДокумент.КоличествоЭкземпляров = КоличествоЭкземпляров;
    КонецЕсли;

    Если НЕ ПечДокумент.АвтоМасштаб
       И НЕ ЗначениеЗаполнено(ПечДокумент.ИмяПринтера) Тогда
        ПечДокумент.АвтоМасштаб = Истина;
    КонецЕсли;

    Если ТипЗнч(НаПринтер) = Тип("Булево") Тогда
        Если НаПринтер Тогда
            ПечДокумент.Вывод = ИспользованиеВывода.Разрешить;
            ПечДокумент.Напечатать();
        Иначе
            ФормаПечати = ПолучитьОбщуюФорму("ПечатьДокументов",, Новый УникальныйИдентификатор);
            ФормаПечати.ОбъектПечати     = Ссылка;
            ФормаПечати.ПечатныйДокумент = ПечДокумент;
            ФормаПечати.Заголовок        = Заголовок;
            ФормаПечати.Защита           = УправлениеДопПравамиПользователей.ЗащитаТаблиц();
            ФормаПечати.ПараметрыПечатногоДокумента        = ПараметрыПечДокумента;
            ФормаПечати.Открыть();
            Возврат ФормаПечати;
        КонецЕсли;
    ИначеЕсли ТипЗнч(НаПринтер) = Тип("Массив") Тогда
        ПечДокумент.Вывод = ИспользованиеВывода.Разрешить;
        ПечДокумент.Напечатать();

        НаПринтер.Добавить(ПечДокумент);
    КонецЕсли;
    Возврат Неопределено;
КонецФункции// НапечататьДокумент()



По точке останова проверял во внешнем файле. И Параметр ПечДокумент выгладит так:

https://d.radikal.ru/d28/1809/d3/e12a8ae839ce.jpg

т.е. КоличествоЭкземпляров там есть.

Что не так, понять не могу.
 
 
   НоваяВолна
 
1 - 06.09.18 - 13:50
..
   Очевидно
 
2 - 06.09.18 - 14:47
...
   Очевидно
 
3 - 06.09.18 - 14:49
... после
    Если ПечДокумент = Неопределено тогда
        Возврат Неопределено;
    КонецЕсли;

Добавь :

Если не ТипЗнч(ПечДокумент) = Тип("ТабличныйДокумент") Тогда
Сообщить("Печ документ = "+СокрЛП(ПечДокумент)+" и тип у него сейчас :"+СокрЛП(ТипЗнч(ПечДокумент))+"");
КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует