Вход | Регистрация

  1  2   
Работа ::

Метки: 

Пример кода которым вы гордитесь...

Я
   Мистикан
 
05.09.18 - 13:54
Недавно одна компания перед собеседованием попросила прислать кусок кода которым, я цитирую "Вы гордитесь".
Я даже растерялся.
А какие еще забавные ситуации у вас бывали при поиске работы?
 
 
   Мистикан
 
1 - 05.09.18 - 13:55
Да и вообще, что можно наваять на языке 1с, чтобы гордиться?
   HawkEye
 
2 - 05.09.18 - 13:55
баян...
напиши свои вопросы которые ты задашь соискателю когда будешь искать программиста себе в команду.
   tesseract
 
3 - 05.09.18 - 13:57
(1) Сделать из 1500 строк кода 200, с 60-кратным приростом производительности. У меня несколько раз получалось.
   иубиповец
 
4 - 05.09.18 - 13:59
(0) Пришлите пустой Вордовский документ. Код который я не написал, так как объяснил пользователям, что то что им нужно можно получить по другому, стандартными механизмами:)
   Lexey_
 
5 - 05.09.18 - 13:59
(0) это тебе к Г1С, он каждую свою строку считает гениальной
   Джинн
 
6 - 05.09.18 - 13:59
(4) +100500 Сам хотел это написать.
   almar
 
7 - 05.09.18 - 13:59
(0) Вот, сразу вспомнилось (это не мое)

Функция обПадежОдногоСлова(Знач Слово,Знач Падеж=2,Знач Пол="*",ВидСклонения=0) Экспорт
    z5=Найти(Слово,"-");
    z6=?(z5=0,"","-"+обПадежОдногоСлова(Сред(Слово,z5+1,СтрДлина(Слово)-z5+1),Падеж,Пол,ВидСклонения));
    Слово=НРег(?(z5=0,Слово,Лев(Слово,z5-1)));
    z7=Прав(Слово,3);z8=Прав(z7,2);z9=Прав(z8,1);
    z5=СтрДлина(Слово);
    za=Найти("ая ия ел ок яц ий па да ца ша ба та га ка",z8);
    zb=Найти("аеёийоуэюяжнгхкчшщ",Лев(z7,1));
    zc=Макс(Падеж,-Падеж);
    zd=?(za=4,5,Найти("айяь",z9));
    zd=?((zc=1)или(z9=".")или((ВидСклонения=2)и(Найти("оиеу"+?(Пол="ч","","бвгджзклмнпрстфхцчшщъ"),z9)>0))или((ВидСклонения=1)и(Найти("мия мяэ лия кия жая лея",z7)>0)),9,?((zd=4)и(Пол="ч"),2,?(ВидСклонения=1,?(Найти("оеиую",z9)+Найти("их ых аа еа ёа иа оа уа ыа эа юа яа",z8)>0,9,?(Пол<>"ч",?(za=1,7,?(z9="а",?(za>18,1,6),9)),?(((Найти("ой ый",z8)>0)и(z5>4)и(Прав(Слово,4)<>"опой"))или((zb>10)и(za=16)),8,zd))),zd)));
    ze=Найти("лец вей бей дец пец мец нец рец вец аец иец ыец бер",z7);
    zf=?((zd=8)и(zc<>5),?((zb>15)или(Найти("жий ний",z7)>0),"е","о"),?(Слово="лев","ьв",?((Найти("аеёийоуэюя",Сред(Слово,z5-3 ,1))=0)и((zb>11)или(zb=0))и(ze<>45),"",?(za=7,"л",?(za=10,"к",?(za=13,"йц",?(ze=0,"",?(ze<12,"ь"+?(ze=1,"ц",""),?(ze<37,"ц",?(ze<49,"йц","р"))))))))));
    zf=?((zd=9)или((ВидСклонения=3)и(Прав(Слово,1)="ы")),Слово,Лев(Слово,z5-?((zd>6)или(zf<>""),2,?(zd>0,1,0)))+zf+СокрП(Сред("а у а "+Сред("оыые",Найти("внч",z9)+1,1)+"ме "+?(Найти("гжкхш",Лев(z8,1))>0,"и","ы")+" е у ойе я ю я ем"+?(za=16,"и","е")+" и е ю ейе и и ь ьюи и и ю ейи ойойу ойойойойуюойойгомуго"+?((zf="е")или(za=16)или((zb>12)и(zb<16)),"и","ы")+"мм",10*zd+2*zc-3,2)));
    Возврат ?(""=Слово,"",?(ВидСклонения>0,ВРег(Лев(zf,1))+?((Падеж<0)и(ВидСклонения>1),".",Сред(zf,2)),zf)+z6);
КонецФункции

Функция обПадежФИО(ФИО,Падеж=2,Пол=3,z4="123",z5=1) Экспорт
    z6=Нрег(Прав(СокрП(ФИО),4));
    z7=Прав(z6,1);
    Возврат?(z5<4,обПадежФИО(СокрЛП(СтрЗаменить(Сред(ФИО,Найти(ФИО+" "," ")+1),".",". ")),Падеж,Пол,СтрЗаменить(z4,z5,обПадежОдногоСлова(?((z5=3)и(z7="ы"),ФИО,Лев(ФИО,Найти(ФИО+" "," ")-1)),Падеж,Сред("ча"+z7,?(Пол=3,?(z6="оглы",1,?(z6="кызы",1,3)),Пол),1),z5)+" "),z5+1),z4);
КонецФункции

Функция обПадежПрофессии(Знач Слово,Знач Падеж=2, Пол=0) Экспорт
    z1=СокрЛП(z1);z4=Найти(z1+" "," ")+1;z5=Лев(z1,z4-2);z6=Прав(z5,2);
    z7=?((Найти("ая ий ый",z6)>0)и(Найти("ющий нный",Сред(z1,z4-5,4))=0)и(Пол=0),"1","*");
    Возврат НРег(?((z6="ая")или(Прав(z6,1)="а"),обПадежОдногоСлова(z5,Падеж,z7,1)+" "+обПадежОдногоСлова(Сред(Слово,z4),Падеж),обПадежОдногоСлова(z5,Падеж,"ч",1)+?((z6="ий")и(Найти(z1," ")=0),""," "+?(z7="1",обПадежПрофессии(Сред(Слово,z4),Падеж,Число(z7)),Сред(z1,z4)))));
КонецФункции
   KnightAlone
 
8 - 05.09.18 - 14:02
(0) предлагаю варианты:

Сообщить("Я живу в России матушке и все остальные страны нам завидуют!");

Сообщить("Мои родители самые лучшие на свете!");

еще детьми можно гордиться, но это уже не всем подойдет. а гордиться букавками в коде. бррр
   Мистикан
 
9 - 05.09.18 - 14:02
(3) ну такое бывает когда какая нить бибизянка код писала, толком не понимая что она делает. Или кому то было лень и он что нашел то и стырил, не разбираясь.
(7) Я прям как сейчас вижу твою боль
   Мистикан
 
10 - 05.09.18 - 14:03
(8) ага
 
 Рекламное место пустует
   tesseract
 
11 - 05.09.18 - 14:04
(9) В ЗУП компонента склонения уже лет 10 как встроена причем.
   H A D G E H O G s
 
12 - 05.09.18 - 14:04
function __CoCreateInstance(const CLSID:TCLSID; unkOuter:IUnknown; dwClsContext:Longint; const iid:TIID; out pv):HResult; stdcall;
var
  i:byte;
  hMutex, hWait:THandle;
  DispatchObject:IDispatch;
  // Disp:TComObject;
  // refcount:integer;
  InterfaceRecord:PInterfaceRecord;
begin
  Result:=REGDB_E_CLASSNOTREG;
  for i:=0 to Length(InterfaceTable) - 1 do
  begin
  InterfaceRecord:=@InterfaceTable[i];
    if IsEqualGUID(InterfaceRecord^.CLSID, CLSID) then
    begin
      Result:=S_OK;
      inc(InterfaceRecord^.count);
      if InterfaceRecord^.count=2 then begin
      //Result:=REGDB_E_CLASSNOTREG;
      //exit;

      end;

      DispatchObject:=InterfaceRecord^.DispObj;
      if DispatchObject = nil then
      begin

        case i of
          0:
            DispatchObject:=AddInExtension.Create;
          1:
            DispatchObject:=AddInSign.Create
        else begin
          exit;
        end;
        end;
        //InterfaceRecord^.DispObj:=DispatchObject;
      end
      else begin
        //InterfaceTable[i].DispObj:=nil;
        end;
      DispatchObject.QueryInterface(iid, pv);
       exit;
    end;
  end;
  hMutex:=CreateMutex(nil, false, 'CreateInstanceBuzy');
  hWait:=WaitForSingleObject(hMutex, INFINITE);
  if hWait <> WAIT_OBJECT_0 then
  begin
    ReleaseMutex(hMutex);
    CloseHandle(hMutex);
    exit;
  end;

  _UnHookCodeHook(@_CoCreateInstance_RestoreData);
  _UnHookCodeHook(@_CLSIDFromProgID_RestoreData);
  Result:=_CoCreateInstance(CLSID, unkOuter, dwClsContext, iid, pv);
  _SetCodeHook(@_CoCreateInstance, @__CoCreateInstance, @_CoCreateInstance_RestoreData);
  _SetCodeHook(@_CLSIDFromProgID, @__CLSIDFromProgID, @_CLSIDFromProgID_RestoreData);
  ReleaseMutex(hMutex);
  CloseHandle(hMutex);
end;
   Смотрящий
 
13 - 05.09.18 - 14:04
(0) Аш'эры совсем офуели, программерам на голову садятся ...
   tesseract
 
14 - 05.09.18 - 14:07
(12) Где try.. finally?
   Мистикан
 
15 - 05.09.18 - 14:11
(13) это прикалюха не для HR, видимо требование руководителя проектных групп.
   Обфускация
 
16 - 05.09.18 - 14:14
Format c:\
   Numerus Mikhail
 
17 - 05.09.18 - 14:17
Пока что как-то так:
НаборЗаписей = РегистрыСведений.контактнаяИнформация.СоздатьНаборЗаписей();
НаборЗаписей.Записать();
   Wirtuozzz_Х
 
18 - 05.09.18 - 14:18
(0) я бы какой нибудь бред по заполнению субконто через КД2.0 отправил.
   gant0ha_b
 
19 - 05.09.18 - 14:19
(17) гы гы
   tesseract
 
20 - 05.09.18 - 14:22
(18) У меня такое через RESTAPI грузиться с гребенного раруса. Нифига сложного.
   Мистикан
 
21 - 05.09.18 - 14:23
не
Для сч=0 По Метаданные.Документы.Количество()-1 Цикл
    Выборка = Документы[Метаданные.Документы[сч].Имя].Выбрать(Дата("00010000000000"),Дата("30010000000000"));
    Пока выборка.следующий() Цикл
        тОбъект = Выборка.Ссылка.ПолучитьОбъект();
        тОбъект.Удалить();
    КонецЦикла;
КонецЦикла;
   Wirtuozzz_Х
 
22 - 05.09.18 - 14:24
А вообще истиная гордость это самая первая программа:

ОбщегоНазначенияКлиентСервер.СообщитьПользователю(НСтр("ru='Привет мир!;en = 'Hello world!'"),,,,);

Вот это гордость и восторг, все остальное скукотища )
   Мистикан
 
23 - 05.09.18 - 14:27
(18) не. я отправил работающий вариант расчета конечного прайса клиента с учетом скидки (без учета бонусной системы) по всем позициям на остатках запросом для УТ11. Сгореть мозг у проверяющего должен был где то на 400 строке запроса =)))
   gant0ha_b
 
24 - 05.09.18 - 14:27
Вы лучше напишите куда резюме не слать, что бы не попасть к таким подозрительным и душным людям в коллектив.
   Малыш Джон
 
25 - 05.09.18 - 14:28
(23) то есть послал кусок кода, который принимающий решение скорее всего сочтет нечитабельным? хмм... умно
   Wirtuozzz_Х
 
26 - 05.09.18 - 14:30
(23) не думаю, что эта портянка вызовет дикий восторг, а вот количество вопросов оптимизации твоего запроса могут поставить тебя в тупик.
   tesseract
 
27 - 05.09.18 - 14:35
(23) У меня один кадр через regexp наименование фильтровал, вместо товарных групп. 4 часа записывали данные в регистр ( не было тогда свойств) и прайс на 800 листов печатался в 18 раз быстрее.
   Лефмихалыч
 
28 - 05.09.18 - 14:35
(0) эбанутый вопрос, действительно
   Numerus Mikhail
 
29 - 05.09.18 - 14:37
Предлагаю спрашивать у них в ответ кем из нанятых ими людей они гордятся больше остальных.
   tesseract
 
30 - 05.09.18 - 14:39
Лучший ответ - а вы кем приходитесь руководству фирмы?
   Wirtuozzz_Х
 
31 - 05.09.18 - 14:52
(0) Мне тайм менеджер сказал: Мы ищем пажа для ее величества главного бухгалтера".

На вопрос согласен ли я с должностью, я сказал: Да, но ЗП от 250 на руки. Он сказал что распологает такими деньгами, я встал и пожелав им счатливо оставаться ушел.
   Еврейчик
 
32 - 05.09.18 - 14:55
(31)не располагает такими деньгами наверное?
Кстати, а кунилингус входил бы в обязанности?
   Wirtuozzz_Х
 
33 - 05.09.18 - 15:00
(32) Да, сказал, что такую зп мне не дадут. Да ужас, какая то ненормальная транспортная компания, где сначала говорили, что там и планирование и распределение задач и руководитель там супер пуппер и на рынке они уже 3000 лет, а на деле, еще спрашивали, соглашусь ли я с Новокосино забирать какого то сотрудника на авто и везти его в фирму, сказали, что это будет большим бонусом. Наркоманы.
 
 
   Wirtuozzz_Х
 
34 - 05.09.18 - 15:03
(32) Господи, это все ты, обколотый наркоман. Иди лучше по 2 минуты в день бегай и голодай по 1.5 часа в месяц, а божественная чага тебе даст по шарам.
   Мистикан
 
35 - 05.09.18 - 15:16
(25) с другой стороны если принимающий решение поймет что это и для чего можно использовать... ему в плюс с моей стороны =)
Руководителей же тоже оцениваешь когда устраиваешься, у меня было пара случаев что я отказывал из за того что понимал кто мной руководить будет =)
   MaxS
 
36 - 05.09.18 - 15:17
СделатьВсё("ВсёВсё");
   bolobol
 
37 - 05.09.18 - 15:31
(36) СделатьВсё("Быстро! Н-на...");
   Buster007
 
38 - 05.09.18 - 15:40
нормальный вопрос. Можно выкинуть слово "гордитесь", но тогда будут присылать свой г.код неформатированный)
суть этого посмотреть на твой код и применяемые тобой подходы в некоторых случаях
по мне так это гораздо лучше, чем писать какой-то код
   Buster007
 
39 - 05.09.18 - 15:41
(23) ты себя переоцениваешь ;)
   Fragster
 
40 - 05.09.18 - 15:45
вот прикольный только что написал:

    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    &Заявка,
    |    &ВерсияФорматаРеф,
    |    &_Звездочка
    |ИЗ
    |    РегистрСведений.ОписаниеЗаявки КАК ОписаниеЗаявки
    |ГДЕ
    |    ОписаниеЗаявки.Заявка = &Заявка
    |    И ОписаниеЗаявки.ВерсияФорматаРеф <> &ВерсияФорматаРеф";
    Запрос.Текст = СтрЗаменить(Запрос.Текст, "&_Звездочка", "ОписаниеЗаявки.*");
    Запрос.УстановитьПараметр("Заявка", Заявка);
    Запрос.УстановитьПараметр("ВерсияФорматаРеф", ВерсияФорматаРеф);
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
        Запись = РегистрыСведений.ОписаниеЗаявкиКлиента.СоздатьМенеджерЗаписи();
        ЗаполнитьЗначенияСвойств(Запись, Выборка);
        Запись.Записать();
    КонецЦикла;
   dmt
 
41 - 05.09.18 - 15:50
(40) Поле &Заявка не лишнее?
   Fragster
 
42 - 05.09.18 - 15:51
(41) ну да, без него тоже будет работать
   Малыш Джон
 
43 - 05.09.18 - 15:53
(36) СделатьВсё(Перечисления.СпособыРаботы.БезГлюков);
   Asmody
 
44 - 05.09.18 - 15:53
У меня сын (8 лет) программки на сретче составляет. Вот этими "примерами" я горжусь.
https://scratch.mit.edu/projects/238569973/#fullscreen
   Nyoko
 
45 - 05.09.18 - 15:55
Пока Истина Цикл
Сообщить("Я крут!");
КонецЦикла;
   Малыш Джон
 
46 - 05.09.18 - 15:56
(45)
Пока Истина Цикл
Сообщить("Я в домике!");
КонецЦикла;
   NSSerg
 
47 - 05.09.18 - 15:57
(38) "Пришлите законченный кусок кода, который не стыдно показать, чтоб мы могли посмотреть ваш стиль программирования"?
   spiller26
 
48 - 05.09.18 - 15:58
Они идеальные и я горжусь этим (сорказм)
Я не знаю что вам даже выбрать...
   Малыш Джон
 
49 - 05.09.18 - 15:59
(47) "Ой, не знаю... У меня всё такое идеальное.."
 
 Рекламное место пустует
   Dotoshin
 
50 - 05.09.18 - 16:03
(0) Ну так все просто:)))
Сообщить("Я горжусь")
   pavig
 
51 - 05.09.18 - 16:07
(7)
По памяти написал?)
   bolobol
 
52 - 05.09.18 - 16:07
(43) Тут будет ошибка: значение отсутствует чуть более, чем полностью.

Если уж на то пошло:
Процедура Что-тоТамПриЗаписи(Источник...
   #Если Клиент Тогда
      Источник= Документы.Какой-тоДокумент.СоздатьДокумент();
   #КонецЕсли
КонецПроцедуры
   Fragster
 
53 - 05.09.18 - 16:09
(52) норм, но вариант
   #Если Клиент И НЕ Клиент Тогда
лучше

А я так вообще Если Ложь Тогда пишу (хоть это и не во всех случаях применимо)
   Мандалай
 
54 - 05.09.18 - 16:09
(52)Небось с интернета спер.
   Злопчинский
 
55 - 05.09.18 - 16:15
(46)
Пока Ложь=Ложь Цикл
Сообщить("Воистину в домике");
КонецЦикла;
   ptiz
 
56 - 05.09.18 - 16:18
Мой лучший код не сохранился, ибо был написан на асме для БК-0010 :(
   Быдло замкадное
 
57 - 05.09.18 - 16:20
Я вчера впервые использовал СМЕЩЕНИЕ в таблице значений))

Товары.Сдвинуть(НайденнаяСтрока, - Смещение);
   Быдло замкадное
 
58 - 05.09.18 - 16:20
(57) точнее СДВИНУТЬ
   Dotoshin
 
59 - 05.09.18 - 16:21
Функция ПолучитьЗавтрашнююДату()
    ТекущаяДата = ТекущаяДата();
    Пока (ТекущаяДата() - ТекущаяДата) < 86400 Цикл
    КонецЦикла;
    //
    Возврат ТекущаяДата();
КонецФункции
   uno-group
 
60 - 05.09.18 - 16:23
Первой в глобальнике добавляю
Процедура глВРазработке()
"Предупреждение("Извините, процедура находиться в разработке, придется пока ручками.");
КонецПроцедуры
В процесе активных дороботак активно юзается и на последок где то остается кнопка "Сделать все!!!" В ней глВРазработке()
   Мандалай
 
61 - 05.09.18 - 16:23
(57)Ты бог
   Мандалай
 
62 - 05.09.18 - 16:24
(58)Точнее полубог
   spiller26
 
63 - 05.09.18 - 16:24
Функция ПолучитьИстину()
    Возврат Истина;
КонецФункции
   bolobol
 
64 - 05.09.18 - 16:31
(54) Вы не поняли смысла! Дао не постигнуто... или не достигнуто, или не дао...
   bolobol
 
65 - 05.09.18 - 16:33
(63) Это из БПС! Плагиат!
   bolobol
 
66 - 05.09.18 - 16:34
*БСП
   Лефмихалыч
 
67 - 05.09.18 - 16:34
(44) кстати, да
+1
   NSSerg
 
68 - 05.09.18 - 16:40
Это работающий код на perl.
<>;
    $_ < $z or ($z += $_, ++ $a)
    for sort {$a <=> $b} split " ", <>;
print $a
Это с лурка, тоже perl
`$=`;$_=\%!;($_)=/(.)/;$==++$|;($.,$/,$,,$\,$",$;,$^,$#,$~,$*,$:,@%)=(
$!=~/(.)(.).(.)(.)(.)(.)..(.)(.)(.)..(.)......(.)/,$"),$=++;$.++;$.++;
$_++;$_++;($_,$\,$,)=($~.$"."$;$/$%[$?]$_$\$,$:$%[$?]",$"&$~,$#,);$,++
;$,++;$^|=$";`$_$\$,$/$:$;$~$*$%[$?]$.$~$*${#}$%[$?]$;$\$"$^$~$*.>&$=`
   bolobol
 
69 - 05.09.18 - 16:43
Я там только Сиськи вижу!
   NSSerg
 
70 - 05.09.18 - 16:50
(69) Это проверка на сиськофилию.
   bolobol
 
71 - 05.09.18 - 16:53
(70) Т.е. - я прошёл проверку!? Меня уже берут?
   NSSerg
 
72 - 05.09.18 - 16:55
(71) Это проверка работодателя.
   Мандалай
 
73 - 05.09.18 - 16:55
(71)В сиськофилы, да
   bolobol
 
74 - 05.09.18 - 17:02
(72) Это только девочкам подходит - оценить, насколько представитель работодателя сиськофил))

Нужно что-то альтернативное неперлить, оценивать, насколько работодатель членофил и/или <18+>
   kennetmccormick
 
75 - 05.09.18 - 17:04
фразы типа "Прорекламируйте себя", "Чем Вы нам можете помочь"
   bolobol
 
76 - 05.09.18 - 17:06
(75) Тут надо менеджеру звонить - каждый должен заниматься своим делом. Я хорошо говнокодю, менеджер хорошо рекламирует - совсем не пахнет!
   bolobol
 
77 - 05.09.18 - 17:07
(75) Со вторым вопросом сложнее. Честно ответить "Расстаться с деньгами" - как-то стрёмно, что ли...
   elCust
 
78 - 05.09.18 - 17:10
Тайное послание от разработчика:

https://vk.com/govnokod1c?z=photo-117389545_456239032%2Falbum-117389545_00%2Frev
   Сергиус
 
79 - 05.09.18 - 17:11
(0)Можно ответить, что горжусь любым свои кодом)
   Cool_Profi
 
80 - 05.09.18 - 17:12
У меня весь код под DNA. Так что не надо провоцировать
   Мандалай
 
81 - 05.09.18 - 17:12
(79)Это ж каким бесстыжим надо быть.
   bolobol
 
82 - 05.09.18 - 17:13
(81) "Фу, таким быть!" ещё скажите)))
   bolobol
 
83 - 05.09.18 - 17:14
(78) ВК заперт - дайте альтернативу, плиз!
   Cool_Profi
 
84 - 05.09.18 - 17:14
(81) Обоснуй.
   OldCondom
 
85 - 05.09.18 - 17:22
Тут как в единоборствах: лучшая драка та, которой не было.
Пример кода, которым горжусь:
"Добрый день! Вашу хотелку можно реализовать типовыми средствами, вот ссылка на пояснения с картинками: *ссылка на ИТС*".
   ejikbeznojek
 
86 - 05.09.18 - 17:26
   gant0ha_b
 
87 - 05.09.18 - 17:29
да, нет .. это такой вопрос стандарный .. все хотят получить кусок кода получше .. но стесняются спросить прямо. Некоторые ведь так и пишут .. необходимо предоставить свои работы.
   OldCondom
 
88 - 05.09.18 - 17:34
(87) Значешь... тут все не так просто... Вот прямо как с троеточиями... Видишь ли... я хочу создать видимость глубоко смысла... Вероятно дело в том, что у меня не получается создать этот смысл практически, вероятно... что-то еще... Да, что-то еще... Чувствуешь? Загадка и глубочайший смысл моего послания окутала весь несвязный бред этого послания. Да... есть над чем подумать... Прямо как комментарии к фильмам. "Очень хороший фильм, нраица. Есть над чем подумоть!".

Так к чему я это. "все хотят получить кусок кода получше" - ты это серьезно?
   OldCondom
 
89 - 05.09.18 - 17:34
(88) прошу не расстреливать за ошибку "троеточие" <> "многоточие". Так задумано.
   Numerus Mikhail
 
90 - 05.09.18 - 17:37
(80) NDA скорее
   elCust
 
91 - 05.09.18 - 17:39
Кандидат на вакансию программиста прислал решение тестового задания (внешняя обработка). Модуль запаролен. Заинтриговал! Взломали пароль. В коде нашли кусок:

Если ТекущаяДата() > Дата(2017, 5, 20) Тогда
   Предупреждение("Период тестирования обработки истек :/");
Возврат;
КонецЕсли;

(с) vk.com/govnokod1c
   Numerus Mikhail
 
92 - 05.09.18 - 17:39
(91) я бы его взял
   kennetmccormick
 
93 - 05.09.18 - 17:45
а почему в НПФ спрашивают- есть или нет разница в какой виде бизнеса работать? Только там такой вопрос слышал
   VladZ
 
94 - 05.09.18 - 17:46
(0) Где-то я уже это слышал... :)
   Мандалай
 
95 - 05.09.18 - 18:21
(84)Василь Иваныч принимает экзамен по политологии у Петьки с Анкой. Анка у доски.
Василь Иваныч спрашивает:
- Анка, что предъявляли депутаты при проходе на Съезд Советов?
Анка молчит, Петька подсказывает шепотом:
- Ма-анда-аты.
Анка:
- Сам пи*дюк, Василь Иваныч, че он обзывается?
   PR
 
96 - 05.09.18 - 18:22
(0) А ты на кого устраивался?
   palsergeich
 
97 - 05.09.18 - 19:15
(91) Вполне себе нормальное решение именно для тестовой задачи, хорошо что еще что сервер лицензирования с NFR ключом встроил))).
Тоже взял бы.
   PR
 
98 - 05.09.18 - 19:21
(97) Нормальное решение - это если лезет на сервер, получает обфусцированный код или сразу результат решения или дать доступ в опубликованную базу без конфигуратора :))
   Доктор Манхэттен
 
99 - 05.09.18 - 19:30
(3) C 60-крантым уменьшением функционала
   mszsuz
 
100 - 05.09.18 - 20:18
// 100

  1  2   

Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

В секцию "Работа" можно добавлять сообщения только после регистрации на форуме.
Если вы уже зарегистрированы, вам нужно войти на форум.
Рекламное место пустует