Вход | Регистрация

1С:Предприятие ::

Метки: 

Как выделить цветом СТРОКИ в таблице отчета по условию?

Я
   dft2014
 
05.09.18 - 13:04
Как выделить цветом СТРОКИ в таблице отчета по определенному условию? Ниже код:

НовТабДок = Новый ТабличныйДокумент;
Макет = Объект.МакетОтчета;
Шапка = Макет.ПолучитьОбласть("Шапка"); 
НовТабДок.Вывести(Шапка);

Запрос = Новый Запрос;
РезультатЗапроса = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать(); 

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    СтрокаТЧ = Макет.ПолучитьОбласть("СтрокаТЧ");
    СтрокаТЧ.Параметры.ФИО = ВыборкаДетальныеЗаписи.ФИО;
    
    Если ВыборкаДетальныеЗаписи.Остаток > 10 Тогда
        НовТабДок.Область("R6C7").ЦветФона = WebЦвета.ЖелтоЗеленый;
    КонецЕсли;
    
    СтрокаТЧ.Параметры.Остаток = ВыборкаДетальныеЗаписи.ОстатокТекДата;
КонецЦикла;
 
 
   dft2014
 
1 - 05.09.18 - 13:06
Код в (0) мне не подходит, т.к. окрашивает только конкретную ячейку, а мне надо, чтобы окрашивались все строки, у которых выполняется условие: ВыборкаДетальныеЗаписи.Остаток > 10
   Nikoss
 
2 - 05.09.18 - 13:09
(1) сделай в макете 2 строки одинаковые, только одна крашеная, другая нет. И выводи одну из них в зависимости от условия.
   Гипервизор
 
3 - 05.09.18 - 13:10
Начнем с того, что есть "таблица отчета", строки которой надо раскрасить?
   ПегийЛунь
 
4 - 05.09.18 - 13:17
ЭтуВыведем = Макет.ПолучитьОбласть("СтрокаТЧ ");
ЩасПокрасимОбласть = ТабДокумент.Вывести(ЭтуВыведем);
ЩасПокрасимОбласть.ЦветФона = Новый Цвет(255,0,0);
   аспид
 
5 - 05.09.18 - 13:25
СтрокаТЧ.Область("R1C1:R1C12").ЦветФона = WebЦвета.ЖелтоЗеленый;

С первой по двенадцатую колонку. или сам регулируй
   аспид
 
6 - 05.09.18 - 13:27
Если ВыборкаДетальныеЗаписи.Остаток > 10 Тогда
  СтрокаТЧ.Область("R1C1:R1C12").ЦветФона = WebЦвета.ЖелтоЗеленый;
иначе
СтрокаТЧ.Область("R1C1:R1C12").ЦветФона = WebЦвета.Белый;
КонецЕсли;
 Вот так вернее.


   riks05
 
7 - 05.09.18 - 13:28
а сделать на СКД и прописать это в условном оформлении не предлогать?


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует