Вход | Регистрация

1С:Предприятие ::

Метки: 

Запись в регистр не типового значения

Я
   TolstiyBeremenniy
 
05.09.18 - 06:05
Конфигурация ERP.
Документ РегистрацияЗемельныхУчастков.
Он делает движение в регистр сведений РегистрацияЗемельныхУчастков.
Добавил в тч документа новое поле.
В зависимости от условия, заполняется либо имеющееся поле
с типового функционала, либо новое. Мною созданное.
Нужно чтобы в ресурс регистра попадало значение или из
типового поля, как сейчас есть. Или из нового если заполнено оно.
Стал смотреть обработку проведения, там как всегда все сложно.
И не понятно как это сделать.
Не подскажете где доработать запись в регистр?
То есть прописать, что бы добавлялось в ресурс или то или то
значение из табличной части. В зависимости от условия.
 
 
   DSSS
 
1 - 05.09.18 - 06:08
1. Создать подписку на событие "ПередЗаписью" для регистра
2. В этой подписке добавить условие, что если твое поле, тогда твой ресурс
   TolstiyBeremenniy
 
2 - 05.09.18 - 06:14
(1) А типовой функционал же будет работать?
   TolstiyBeremenniy
 
3 - 05.09.18 - 06:15
(1) В подписке на событие перед записью, перебирать табличную часть и делать движение как обычно с нужным условием?
   TolstiyBeremenniy
 
4 - 05.09.18 - 06:18
Мне кажется как то смутно это все.
Хотелось бы поправить типовой функционал.
Это возможно?
   TolstiyBeremenniy
 
5 - 05.09.18 - 06:20
(1) Может это как то просто делается, как я не знаю?
Подскажите если точно знаете как сделать это.
   TolstiyBeremenniy
 
6 - 05.09.18 - 06:31
(1) В подписке нужно делать цикл?
   PaulBC
 
7 - 05.09.18 - 06:31
В модуле менеджера документа Процедура РегистрацияЗемельныхУчастков
   TolstiyBeremenniy
 
8 - 05.09.18 - 06:35
(7)

Процедура РегистрацияЗемельныхУчастков(ТекстыЗапроса, Регистры)
    
    ИмяРегистра = "РегистрацияЗемельныхУчастков";
    
    Если Не ПроведениеСерверУТ.ТребуетсяТаблицаДляДвижений(ИмяРегистра, Регистры) Тогда
        Возврат;
    КонецЕсли;
    
    Текст =
    "ВЫБРАТЬ
    |    &Ссылка КАК Регистратор,
    |    &Дата КАК Период,
    |    
    |    &Организация КАК Организация,
    |    ТабличнаяЧастьДокумента.ОсновноеСредство КАК ОсновноеСредство,
    |    
    |    ИСТИНА КАК ВключатьВНалоговуюБазу,
    |    &КодКатегорииЗемель КАК КодКатегорииЗемель,
    |    ТабличнаяЧастьДокумента.КадастровыйНомер КАК КадастровыйНомер,
    |    ТабличнаяЧастьДокумента.КадастроваяСтоимость КАК КадастроваяСтоимость,
    |    ТабличнаяЧастьДокумента.ОбщаяСобственность КАК ОбщаяСобственность,
    |    ТабличнаяЧастьДокумента.ДоляВПравеОбщейСобственностиЧислитель КАК ДоляВПравеОбщейСобственностиЧислитель,
    |    ТабличнаяЧастьДокумента.ДоляВПравеОбщейСобственностиЗнаменатель КАК ДоляВПравеОбщейСобственностиЗнаменатель,
    |    ТабличнаяЧастьДокумента.ЖилищноеСтроительство КАК ЖилищноеСтроительство,
    |    ТабличнаяЧастьДокумента.ДатаНачалаПроектирования КАК ДатаНачалаПроектирования,
    |    ТабличнаяЧастьДокумента.ДатаРегистрацииПравНаОбъектНедвижимости КАК ДатаРегистрацииПравНаОбъектНедвижимости,
    |    &ПостановкаНаУчетВНалоговомОргане КАК ПостановкаНаУчетВНалоговомОргане,
    |    &НалоговыйОрган КАК НалоговыйОрган,
    |    &КодПоОКТМО КАК КодПоОКТМО,
    |    &КодПоОКАТО КАК КодПоОКАТО,
    |    &КБК КАК КБК,
    |    &НалоговаяСтавка КАК НалоговаяСтавка,
    |    &НалоговаяЛьготаПоНалоговойБазе КАК НалоговаяЛьготаПоНалоговойБазе,
    |    &КодНалоговойЛьготыОсвобождениеОтНалогообложенияПоСтатье395 КАК КодНалоговойЛьготыОсвобождениеОтНалогообложенияПоСтатье395,
    |    &КодНалоговойЛьготыУменьшениеНалоговойБазыПоСтатье391 КАК КодНалоговойЛьготыУменьшениеНалоговойБазыПоСтатье391,
    |    &УменьшениеНалоговойБазыПоСтатье391 КАК УменьшениеНалоговойБазыПоСтатье391,
    |    &УменьшениеНалоговойБазыНаСумму КАК УменьшениеНалоговойБазыНаСумму,
    |    &ДоляНеОблагаемойНалогомПлощадиЧислитель КАК ДоляНеОблагаемойНалогомПлощадиЧислитель,
    |    &ДоляНеОблагаемойНалогомПлощадиЗнаменатель КАК ДоляНеОблагаемойНалогомПлощадиЗнаменатель,
    |    &НеОблагаемаяНалогомСумма КАК НеОблагаемаяНалогомСумма,
    |    &СниженнаяНалоговаяСтавка КАК СниженнаяНалоговаяСтавка,
    |    &ПроцентУменьшенияСуммыНалога КАК ПроцентУменьшенияСуммыНалога,
    |    &СуммаУменьшенияСуммыНалога КАК СуммаУменьшенияСуммыНалога,
    |    
    |    ЗНАЧЕНИЕ(Перечисление.ВидЗаписиОРегистрации.Регистрация) КАК ВидЗаписи
    |    
    |ИЗ
    |    Документ.РегистрацияЗемельныхУчастков.ОС КАК ТабличнаяЧастьДокумента
    |ГДЕ
    |    ТабличнаяЧастьДокумента.Ссылка = &Ссылка";
    
    ТекстыЗапроса.Добавить(Текст, ИмяРегистра, Истина);
    
КонецПроцедуры




То есть этот запрос извлекает данные документа что бы потом, где то записать их в регистр?
И нужно поменять запрос, если нужны данные другого поля?
   PaulBC
 
9 - 05.09.18 - 06:39
(8) Да
   TolstiyBeremenniy
 
10 - 05.09.18 - 06:39
(9) Ок! Спасибо большое! Пробую!
 
 Рекламное место пустует
   PaulBC
 
11 - 05.09.18 - 06:43
   TolstiyBeremenniy
 
12 - 05.09.18 - 06:46
(11) Не хилая статья !!!!
   FIXXXL
 
13 - 05.09.18 - 10:07
ПередЗаписью кинь свое значение в типовое поле, если по условию проходит
дальше "оно само"
   TolstiyBeremenniy
 
14 - 05.09.18 - 10:20
(13) Как то не сильно доходчиво.
То есть достаточно было бы кода, - 

Если НужноеУсловие Тогда
   РесурсРегистра = ЗначениеТиповогоПоля;
Иначе
   РесурсРегистра = ЗначениеНовогоПоля;
КонецЕсли;
   FIXXXL
 
15 - 05.09.18 - 15:41
(14) нет, в документе, до проведения по регистрам

Если НужноеУсловие Тогда
   ЗначениеТиповогоПоля= ЗначениеНовогоПоля;
КонецЕсли;


ЗначениеТиповогоПоля у тебя же пустое Если НужноеУсловие? ну вот и заполни его


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует