Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Не получается сделать флажок "Подпись и печать" во внешней печатной форме

Не получается сделать флажок "Подпись и печать" во внешней печатной форме
Я
   Saari
 
30.08.18 - 16:45
В БУХ 3.0 во встроенной в конфигурацию печатной форме документа "Акт сверки расчетов" есть флажок "Подпись и печать". Если флажок установить, то в подвале печатной формы появляется печать организации.

Есть внешняя печатная форма, которая выводит в подвале такую же печать. Но не получается сделать флажок "Подпись и печать" во внешней печатной форме.
Не могу найти где и как этот флажок реализован во встроенной печатной форме.
Подскажите, пожалуйста.
 
 
   Пуля
 
1 - 30.08.18 - 17:13
Это код из типовой БП
    // Добавляем реквизит

    ИмяРеквизита = "ПодписьИПечать";
    НовыеРеквизитыФормы = Новый Массив;
    РеквизитФормы = Новый РеквизитФормы(ИмяРеквизита, Новый ОписаниеТипов("Булево"),, НСтр("ru = 'Подпись и печать'"));
    НовыеРеквизитыФормы.Добавить(РеквизитФормы);
    Форма.ИзменитьРеквизиты(НовыеРеквизитыФормы);
   Пуля
 
2 - 30.08.18 - 17:14
Если ПодписьИПечать Тогда
            Для Каждого ВложениеПодписьИПечать Из ЭтотОбъект.ВложенияПодписьИПечать Цикл
                Если ВложениеПодписьИПечать.Представление = Представление Тогда
                    АдресВоВременномХранилище = ВложениеПодписьИПечать.АдресВоВременномХранилище;
                    Идентификатор             = ВложениеПодписьИПечать.Идентификатор;
                    Прервать;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
   azernot
 
3 - 30.08.18 - 17:21
После формирования табличного документа вызови
        УправлениеПечатьюБП.ДополнитьДокументПодписьюИПечатью(ТабличныйДокумент, Шапка, ОбъектыПечати, ПараметрыПечати);
   Saari
 
4 - 31.08.18 - 08:29
(3)
Параметр "ПараметрыПечати" лишний, если вызывать эту процедуру из внешней обработки.
Пока не получается...
   Saari
 
5 - 31.08.18 - 09:02
(1) где именно это нужно прописать (нашел в общем модуле)?
   Saari
 
6 - 31.08.18 - 10:46
Получилось!
Как сказал (3):
"После формирования табличного документа вызови УправлениеПечатьюБП.ДополнитьДокументПодписьюИПечатью(ТабличныйДокумент, Шапка, ОбъектыПечати, ПараметрыПечати);"

Но! Перед этим вызовом нужно определить ПараметрыПечати следующим образом: 
ПараметрыПечати = Новый Структура("ДополнитьКомплектВнешнимиПечатнымиФормами");
ПараметрыПечати.Вставить("ДополнитьКомплектВнешнимиПечатнымиФормами", Ложь);

Макет для внешней обработки используется штатный (из документа АктСверки).

Всем спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует