Вход | Регистрация

1С:Предприятие ::

Метки: 

СКД: Значение шапки документа из значения ТЧ

Я
   lg2marvel
 
30.08.18 - 14:22
Привет.
В истонике в ТЧ Транзит есть реквизит Касса, нужно передать его в шапку документа Приходный кассовый ордер в реквизит ПодразделениеКТ.

В конвертации свойств Касса - > ПодразделениеКТ ПередВыгрузкой пишу запрос:

Если (Источник.ВидОперации = Перечисления.ВидыОперацийПКО.асТранзит) Тогда
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ ПЕРВЫЕ 1
        |ПриходныйКассовыйОрдер.Транзит.(
        |    Касса.Ссылка
        |    ) КАК Касса
        |ИЗ
        |    Документ.ПриходныйКассовыйОрдер КАК ПриходныйКассовыйОрдер
        |ГДЕ
        |    ПриходныйКассовыйОрдер.Ссылка = &Ссылка ";
    Запрос.УстановитьПараметр("Ссылка", Источник.Ссылка);
    
    Выборка = Запрос.Выполнить().Выбрать();    
    Пока Выборка.Следующий() Цикл    
        Сообщить(Выборка.Касса);
        Значение = Выборка.Касса;
    КонецЦикла;

КонецЕсли;

Но в результате при выгрузке из источника получаю ошибку:
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(9411)}: Метод объекта не обнаружен (УникальныйИдентификатор)
            УникальныйИдентификатор = СсылкаНаИсточник.УникальныйИдентификатор();

Может я что-то туплю и есть какой-то более нормлаьный выход из ситуации?
 
 
   DrShad
 
1 - 30.08.18 - 14:30
причем тут СКД?
   Пуля
 
2 - 30.08.18 - 14:32
Причем тут С
   lg2marvel
 
3 - 30.08.18 - 14:32
(1) КД
   DrShad
 
4 - 30.08.18 - 14:37
(3)ладно
и как твоя ошибка связана с твоим излишним запросом?
   lg2marvel
 
5 - 30.08.18 - 14:43
(4) Смотрю результат работы запроса - да, действительно, в выборка.Касса нет кассы, хотя странно, в консоли отрабатывала с результатом.

Можно как-то получить значение реквизита ТЧ источника без запроса?
   DrShad
 
6 - 30.08.18 - 14:45
Источник.Транзит[0].Касса
   lg2marvel
 
7 - 30.08.18 - 14:52
(6) Спасибо, пробую варианты
   lg2marvel
 
8 - 30.08.18 - 14:56
Отработало на ура!
Всем спасибо

Если (Источник.ВидОперации = Перечисления.ВидыОперацийПКО.асТранзит) Тогда
Если Источник.Транзит.Количество() Тогда
//    Сообщить(Источник.Транзит[0].Касса);

    Значение = Источник.Транзит[0].Касса;
Иначе
    Сообщить("Документ "+Источник.Ссылка+" не будет выгружен из-за отсутствия ТЧ");
    Отказ = истина;

КонецЕсли;

КонецЕсли;


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует