Вход | Регистрация


Вопрос с простейшим циклом

Вопрос с простейшим циклом
Я
   maptbln
 
30.08.18 - 11:40
Есть следующий цикл 

КоличествоСтрокФин = тпБюджетныеОперации.Количество()-1;
 
Для НС = 0 по КоличествоСтрокФин-1 Цикл
    Для НС1 = 1 по КоличествоСтрокФин Цикл
        Если тпБюджетныеОперации[НС][1] = тпБюджетныеОперации[НС1][1] и тпБюджетныеОперации[НС][2] = тпБюджетныеОперации[НС1][2] Тогда 
            тпБюджетныеОперации.Удалить(НС1);
            КоличествоСтрокФин = тпБюджетныеОперации.Количество()-1;
        КонецЕсли;
            КонецЦикла;
КонецЦикла;    

Но он вечно вылетает индексом за пределы массива и не удаляет в итоге то , что нужно
подскажите пожалуйста,как привести его в правильные вид
 
 
   Волшебник
 
1 - 30.08.18 - 11:41
удалять за пределами цикла
   maptbln
 
2 - 30.08.18 - 11:44
(1) сформировать массив для удаления потом его пройти , так что ли?
   Волшебник
 
3 - 30.08.18 - 11:44
(2) Да
   Быдло замкадное
 
4 - 30.08.18 - 11:45
обходить с зада вперед.
   Buster007
 
5 - 30.08.18 - 11:47
(4) +
   maptbln
 
6 - 30.08.18 - 12:04
КоличествоСтрокФин = тпБюджетныеОперации.Количество()-1;
МассивУдаления =Новый Массив();

Для НС = 0 по КоличествоСтрокФин-1 Цикл
    Для НС1 = 1 по КоличествоСтрокФин Цикл
        Если тпБюджетныеОперации[НС][1] = тпБюджетныеОперации[НС1][1] и тпБюджетныеОперации[НС][2] = тпБюджетныеОперации[НС1][2] Тогда 
        МассивУдаления.Добавить(тпБюджетныеОперации[НС1]);        
        КонецЕсли;
            КонецЦикла;
КонецЦикла;    

КЭМ = МассивУдаления.ВГраница();
сч = КоличествоСтрокФин;
Пока КЭМ >= 0 Цикл
    Пока сч >= 0 Цикл
        Если МассивУдаления[КЭМ] = тпБюджетныеОперации[сч] тогда
            тпБюджетныеОперации.Удалить(сч);
        КонецЕсли;
        сч = сч-1;
        КонецЦикла;
    КЭМ = КЭМ-1;
КоличествоСтрок = тпБюджетныеОперации.Количество();
сч = КоличествоСтрокФин-1;    
КонецЦикла;

и снова не попадаю
   Рэйв
 
7 - 30.08.18 - 12:09
(0)Для троля тебе следует открыть для себя...
Для Каждого..
   maptbln
 
8 - 30.08.18 - 12:30
(7) если б , а как можно при помощи для Каждого реализовать проверку моего условия?
   Вафель
 
9 - 30.08.18 - 12:30
гугли тему удаление строк в тз
   Пуля
 
10 - 30.08.18 - 12:36
Ты свернуть таблицу не пробовал?
 
 Рекламное место пустует
   maptbln
 
11 - 30.08.18 - 12:38
(9) Понял, (10) нет пока

Список тем форума
Рекламное место пустует  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует