Вход | Регистрация

1С:Предприятие ::

Метки: 

В ВебКлиенте ругается на Ожидается Символ ;

Я
   9451523
 
30.08.18 - 10:19
Привет Всем
На веб клиенте в 1с 8.3 при открытии стало выскакивать такое сообщение: Form.ФормаЗаписи.Form(89,13) Ожидается символ ;
вот код:

&НаСервере
Функция ВыгрузитьФайл()
    ЗаписьЗнч = РеквизитФормыВЗначение("Запись");
    Если Запись.ЭтоВебКлиент Тогда
    ДанныеХранилища = ПоместитьВоВременноеХранилище(ЗаписьЗнч.Файл.Получить());
    Если ТипЗнч(ДанныеХранилища) <> Тип("ДвоичныеДанные") Тогда
        Возврат Неопределено;
    КонецЕсли;
    ПакетДанных = Новый Структура;
    ПакетДанных.Вставить("Имя",ПолучитьИмяВременногоФайла(Запись.Расширение));
    ПакетДанных.Вставить("ДанныеХранилища",ПоместитьВоВременноеХранилище(ДанныеХранилища));
    Возврат ПакетДанных;
    Иначе
    Возврат ПоместитьВоВременноеХранилище(ЗаписьЗнч.Файл.Получить());
    КонецЕсли;    
КонецФункции

&НаКлиенте
Процедура ОткрытьФайл(Команда)
    
    файлВремХр = ВыгрузитьФайл();
    ИмяВрФайла = ПолучитьИмяВременногоФайла(Запись.ИмяФайла);
    ПолучитьФайл(файлВремХр, ИмяВрФайла, Ложь);
    ЗапуститьПриложение(ИмяВрФайла); 

КонецПроцедуры

вроде все правильно, где ошибка то?
 
 
   hhhh
 
1 - 30.08.18 - 11:16
(0) ну и как мы тут увидим какая из строк 89-я? Телепатически?
   Denis_CFO
 
2 - 30.08.18 - 11:38
(0) если 13 символ - тогда после КонецФункции
   Сияющий в темноте
 
3 - 30.08.18 - 12:40
А где здесь 89 строк когда?


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует